Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

GRE & L2tpv3 Issue

My problem with tunnelling is as follows:

I need to create a layer 2 tunnel with an mtu of 1500 (normal Ethernet), as I

need to be able to tunnel PPPoE with a default MTU.

I have tried to create an L2TPv3 psuedowire for the tunnel. However the overhead

on the tunnel meant the PPPoE packets became too large.

To get around this I have tried running the tunnel over a GRE tunnel with the

mtu increased using the "ip mtu" command. This doesn't seem to work and packets

through the pseudowire seem to get invisibly dropped.

I am unable to increase the MTU on the network inbetween as the network is not

in our control. Are there any better ways of doing this that you know of?

The configuration I am using at both ends is like this:

!

pseudowire-class etherpw

encapsulation l2tpv3

ip local interface Tunnel0

!

interface Tunnel0

ip address 10.2.1.2 255.255.255.252

ip mtu 1600

tunnel source Loopback0

tunnel destination 87.248.130.11

!

interface Loopback0

ip address 87.248.130.10 255.255.255.255

!

interface FastEthernet0

description LAN Interface

no ip address

no ip redirects

no ip proxy-arp

speed auto

no cdp enable

!

interface FastEthernet0.102

encapsulation dot1Q 102

no snmp trap link-status

no cdp enable

xconnect 10.2.1.1 102 pw-class etherpw

I forgot to mention that the tunnel was working, but only when packets exceeded

an mtu of 1436. I use the "ip mtu 1600" to artificially increase packet size so

the L2TPv3 tunnel headers + contents of size 1500 fitted in the GRE tunnel. The

tunnel will still function with "ip mtu 1400", but not with the size of packets

we are using.

What do I need to do to get this working properly?

*Note that this is a personal issue not related to my day job.

thanks

Paul

1 REPLY
Silver

Re: GRE & L2tpv3 Issue

mtu can be set in 2 ways either with a common "mtu" interface command and the protocol specific "ip mtu" cmd.

Changing the MTU value with the mtu interface configuration command can affect values for the protocol-specific versions of the command (the ip mtu command, for example). If the value specified with the ip mtu interface configuration command is the same as the value specified with the mtu interface configuration command, and you change the value for the mtu interface configuration command, the ip mtu value automatically matches the new mtu interface configuration command value. However, changing the values for the ip mtu configuration commands has no effect on the value for the mtu interface configuration command.So, better change the mtu size with the "mtu" command .This will automatically reflect in the " ip mtu" command .

287
Views
0
Helpful
1
Replies
CreatePlease to create content