Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

GRE over WAN

I am trying to setup a GRE tunnel using loopback addresses on two different routers.   For security reasons, I dont want to advertise that ip addresses of the tunnel interfaces on the network.  I can ping the ip address of both the local and remote loopback addresses, the GRE tunnel wont go up/up.                  

Here is the config of R1 (local router)

                  

interface Loopback0

ip address 10.1.1.1 255.255.255.255

!

interface Tunnel0

ip address 10.0.1.1 255.255.255.0

tunnel source Loopback0

tunnel destination 3.3.3.3

!

interface FastEthernet0/0

ip address 10.1.2.1 255.255.255.0

duplex auto

speed auto

!

interface Ethernet1/0

no ip address

shutdown

half-duplex

!

router eigrp 1

network 10.1.1.1 0.0.0.0

network 10.1.2.0 0.0.0.255

no auto-summary

!

no ip http server

!

ip forward-protocol nd

ip route 10.0.3.3 255.255.255.255 10.2.3.3

There is an intermediate router R2 between R1 and R2 to simulate for an updates PE router that we will be going through.  Thought this was possible but not having any luck.

3 REPLIES
Hall of Fame Super Bronze

GRE over WAN

Please post your routing table and configuration from the 3 devices.

Hall of Fame Super Silver

GRE over WAN

Ronald

The question from Edison is an excellent starting point. To add a bit to his question, the main requirement for a standard GRE tunnel to come up/up is that the router must have a valid route to the tunnel destination in the routing table. There are no static routes for the 3.3.3.3 destination so the router will need to have learned the route to 3.3.3.3 via EIGRP. And Edison's request to post the routing table is an excellent way to determine whether this requirement has been met.

HTH

Rick

New Member

GRE over WAN

I'm wondering if tunnel destination 3.3.3.3 is not just typo...

i think static route:

ip route 10.0.3.3 255.255.255.255 10.2.3.3

is somehow a clue.

If you can ping from one loopback to other one using command like:

from R3: ping 10.1.1.1 source loopback 0

you should look on that "tunnel destination"!!

262
Views
0
Helpful
3
Replies