Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

GRE problem

Hi

I have a problem with GRE configuration. between router A and B there is 1 more router. all 3 router area under same ospf domain. after configure as belows, tunnel interface is keep flapping with error message "routing loop ...". can i fix this problem?

A.

int loopback 0

ip address 1.1.1.1 255.255.255.0

int seial 0/0

ip address 2.2.12.1 255.255.255.0

Tunnel 10

ip unnumbered s0/0

tunnel source lo0

tunnel destination 2.2.2.2

router ospf 1

passive interface tunnel 10

.....

B.

int loopback 0

ip address 2.2.2.2 255.255.255.0

int seial 0/0

ip address 2.2.54.1 255.255.255.0

Tunnel 10

ip unnumbered s0/0

tunnel source lo0

tunnel destination 1.1.1.1

router ospf 1

passive interface tunnel 10

.....

2 REPLIES
VIP Purple

Re: GRE problem

Hello,

what does the error say exactly, does it mention something about recursive routing ? Try and add a static route on your router A:

ip route 2.2.2.2 255.255.255.255 Serial0/0

and on Router B:

ip route 1.1.1.1 255.255.255.255 Serial0/0

If that does not help, can you post the full configuration of both routers ?

Regards,

GP

New Member

Re: GRE problem

Hi GP

thanks for answering.

actually, i already solve this with puting the ip ospf cost 9999 in the tunnel interface. but i think your solution is interesting one. i will try next time.

thanks again

126
Views
5
Helpful
2
Replies
CreatePlease to create content