Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

GRE QOS or Traffic Shaping over enterprise

Scenerio:- GRE Tunnel configured from points "A" to point "E" and works fine.

Between "A-B" "B-C" "C-D" "D-E" there are no QOS mechanism's. Links vary from 10mb/100mb/Gigabit.

Question:

If on the GRE Tunnel you place traffic shaping of say 5mb, does this then mean that "end to end" on all links 5mb is reservered for the GRE Tunnel across all links.

How is this policed/managed or controlled ?

Do you require the traffic shaping on both ends for this to work or is one end sufficient ?

1 ACCEPTED SOLUTION

Accepted Solutions
Super Bronze

Re: GRE QOS or Traffic Shaping over enterprise

Yes, that's correct, another reason to use a shaper, or policier, might be to keep some customer traffic within a contracted amount.

As to the question of insuring 5 Mbps for the tunnel traffic end-to-end, that would require both sufficient physical bandwidth along the way and QoS settings on each link to guarantee the 5 Mbps. You're again correct that normally the tunnel traffic would likely just be treated as BE, but you can treat it special.

E.g. (NB: syntax might be incorrect)

access-list extended 5mbrgre

permit ip host tunnelsrc host tunneldest

class-map match-all 5mbgre

match protocol gre

match group 5mbgre

policy-map inbetweenlink

class 5mbgre

bandwidth 5000

interface sometype #

service-policy output inbetweenlink

The above example, or something providing the same 5 Mbps guarantee would be needed on all the interfaces, i.e. A to B, B to C, C to D, D to E, and the reverse.

You could also use IP Precedence or DSCP tags on the GRE traffic, and match against those. That would avoid the need for every hop to analyze traffic protocol and/or addresses.

3 REPLIES
Super Bronze

Re: GRE QOS or Traffic Shaping over enterprise

If you place a 5 Mbps shaper on the tunnel, it would not allow traffic entering the tunnel to exceed 5 Mbps transmission rate. Has nothing, directly, to do with intervening physical links.

One reason why you might want do this, if you don't control routers B, C and D, shaping may allow you to make a "mirror" congestion point, upstream of a physical congestion point that you can't manage.

New Member

Re: GRE QOS or Traffic Shaping over enterprise

Thanks for that.

The idea is to limit an customers access to 5mb via the tunnel. But, what effect is there on the tunnel traffic, if between routers C and D there is traffic shaping policy(called "traffic"). How can the tunnel guarentee 5mb if it is not defined in the "traffic" policy. My understanding is that the tunnel traffic would be put into the "default" or "best effort" queue end-to-end, hence, there is not a guarentee of 5mb !

Super Bronze

Re: GRE QOS or Traffic Shaping over enterprise

Yes, that's correct, another reason to use a shaper, or policier, might be to keep some customer traffic within a contracted amount.

As to the question of insuring 5 Mbps for the tunnel traffic end-to-end, that would require both sufficient physical bandwidth along the way and QoS settings on each link to guarantee the 5 Mbps. You're again correct that normally the tunnel traffic would likely just be treated as BE, but you can treat it special.

E.g. (NB: syntax might be incorrect)

access-list extended 5mbrgre

permit ip host tunnelsrc host tunneldest

class-map match-all 5mbgre

match protocol gre

match group 5mbgre

policy-map inbetweenlink

class 5mbgre

bandwidth 5000

interface sometype #

service-policy output inbetweenlink

The above example, or something providing the same 5 Mbps guarantee would be needed on all the interfaces, i.e. A to B, B to C, C to D, D to E, and the reverse.

You could also use IP Precedence or DSCP tags on the GRE traffic, and match against those. That would avoid the need for every hop to analyze traffic protocol and/or addresses.

221
Views
0
Helpful
3
Replies
CreatePlease to create content