Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Bronze

GRE tunnel and ip address

Hi everybody

Let say we have two routers,R1 and R2 connected via internet as shown below:

R1 s0/0-------------internet----------------S0/0 R2

R1s0/0 ip address 199.199.199.1/24

       loopback 1 10.10.10.1/24

R2 s0/0 ip address 200.200.200.2/24

        loopback 2 12.12.12.2/24

we want to establish gre tunnel between R1 and R2

===================================

  GRE tunnel configurations:

R1

tunnel interface 24

tunnel source loopback 1

tunnel destination 12.12.12.2

What ip address should be assigned to tunnel 24?  should it be 199.199.199.1, the ip address on s0/0 on R1?

R2

tunnel interface 42

tunnel source loopback 2

tunnel destination 10.10.10.1

What ip address should be assigned to tunnel 42?  should it be 200.200.200.2 the ip address on s0/0 on R2?

========================================================================================================

Eigrp by default uses bandwidth and delay to calculate the metric.

what are default bandwidth and delay on gre tunnel interface?

thanks and have a great weekend.

3 ACCEPTED SOLUTIONS

Accepted Solutions

GRE tunnel and ip address

Hi Sarah,

There are 2 areas where GRE Tunnels are used . Once in public space and one in private space.

In public space normally the source is the public ip on the device facing the ISP and destination is the public ip on the end point. The reason why being the public space doesn't know the private ip addresses on the loopbacks.

Essentially what happens in a GRE packet is it encapsulates your packet and sticks in another IP address in the front and ship it. So you can't possibly use the private ip address as source.

However, you can use it in a private space as you would have full reachability via IGP or some routing protocol between the loopbacks etc.and packets dont route out to the internet.

Now, depending on what protocols you want to run you can use either static, dynamic routing protocols between the tunnel end points.

Here is a sample config

Router1 [S0](64.45.15.17) ------ Internet -------(65.17.89.11)[S0]Router2---192.168.1.0/24
   |_(10.0.0.1)_____________GRE Tunnel____________________(10.0.0.2)_|

Router1
*******

interface Tunnel0
ip address 10.0.0.1 255.255.255.252
tunnel source 64.45.15.17
tunnel destination 65.17.89.11

Router2
*******

interface Tunnel0
ip address 10.0.0.2 255.255.255.252
tunnel source 65.17.89.11
tunnel destination 64.45.15.17

And just apply the necessary routes for those tunnels:

for example

ip route 192.168.1.0 255.255.255.0 Tunnel0


========================================================================================================

Eigrp by default uses bandwidth and delay to calculate the metric.

what are default bandwidth and delay on gre tunnel interface?


The GRE tunnel interfaces by default allocate a BW of 9Kbps for Routing protocol updates etc. You normally change that to the bandwidth of the physical interface. i.e say if you are using a fastethernet then  you use bandwidth in kbps

R1#sh int tunnel 0

Tunnel0 is up, line protocol is up

  Hardware is Tunnel

  MTU 1514 bytes, BW 9 Kbit, DLY 500000 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation TUNNEL, loopback not set

  Keepalive not set

  Tunnel source 192.168.1.1, destination 192.168.1.2

  Tunnel protocol/transport GRE/IP, key disabled, sequencing disabled

  Tunnel TTL 255

  Checksumming of packets disabled,  fast tunneling enabled

  Last input never, output never, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/0 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     0 packets input, 0 bytes, 0 no buffer

     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

     0 packets output, 0 bytes, 0 underruns

     0 output errors, 0 collisions, 0 interface resets

     0 output buffer failures, 0 output buffers swapped out

HTH

Kishore

Hall of Fame Super Bronze

GRE tunnel and ip address

Its significance is the same as any interface, to send/receive IP flows on via that interface.

A GRE tunnel is treated as a point-to-point interface, if you have a point-to-point circuit - do you assign the IP addresses at both ends under the same subnet? The answer is Yes.

Hall of Fame Super Bronze

GRE tunnel and ip address

I'm fine, thanks for asking. How about you?

6 REPLIES

GRE tunnel and ip address

Hi Sarah,

There are 2 areas where GRE Tunnels are used . Once in public space and one in private space.

In public space normally the source is the public ip on the device facing the ISP and destination is the public ip on the end point. The reason why being the public space doesn't know the private ip addresses on the loopbacks.

Essentially what happens in a GRE packet is it encapsulates your packet and sticks in another IP address in the front and ship it. So you can't possibly use the private ip address as source.

However, you can use it in a private space as you would have full reachability via IGP or some routing protocol between the loopbacks etc.and packets dont route out to the internet.

Now, depending on what protocols you want to run you can use either static, dynamic routing protocols between the tunnel end points.

Here is a sample config

Router1 [S0](64.45.15.17) ------ Internet -------(65.17.89.11)[S0]Router2---192.168.1.0/24
   |_(10.0.0.1)_____________GRE Tunnel____________________(10.0.0.2)_|

Router1
*******

interface Tunnel0
ip address 10.0.0.1 255.255.255.252
tunnel source 64.45.15.17
tunnel destination 65.17.89.11

Router2
*******

interface Tunnel0
ip address 10.0.0.2 255.255.255.252
tunnel source 65.17.89.11
tunnel destination 64.45.15.17

And just apply the necessary routes for those tunnels:

for example

ip route 192.168.1.0 255.255.255.0 Tunnel0


========================================================================================================

Eigrp by default uses bandwidth and delay to calculate the metric.

what are default bandwidth and delay on gre tunnel interface?


The GRE tunnel interfaces by default allocate a BW of 9Kbps for Routing protocol updates etc. You normally change that to the bandwidth of the physical interface. i.e say if you are using a fastethernet then  you use bandwidth in kbps

R1#sh int tunnel 0

Tunnel0 is up, line protocol is up

  Hardware is Tunnel

  MTU 1514 bytes, BW 9 Kbit, DLY 500000 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation TUNNEL, loopback not set

  Keepalive not set

  Tunnel source 192.168.1.1, destination 192.168.1.2

  Tunnel protocol/transport GRE/IP, key disabled, sequencing disabled

  Tunnel TTL 255

  Checksumming of packets disabled,  fast tunneling enabled

  Last input never, output never, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/0 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     0 packets input, 0 bytes, 0 no buffer

     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

     0 packets output, 0 bytes, 0 underruns

     0 output errors, 0 collisions, 0 interface resets

     0 output buffer failures, 0 output buffers swapped out

HTH

Kishore

Bronze

GRE tunnel and ip address

Thanks Kishore.

What is the significance of using ip address configured under tunnel interface?

For example:

R1

interface Tunnel0
ip address 10.0.0.1 255.255.255.252

R2

interface Tunnel0
ip address 10.0.0.2 255.255.255.252

My question do we need to ensure the connectivity exist between the above mentioned ip addresses through igp or static routing?

My second question is do these ip addresses have to be on the same subnet?

thanks

Hall of Fame Super Bronze

GRE tunnel and ip address

Its significance is the same as any interface, to send/receive IP flows on via that interface.

A GRE tunnel is treated as a point-to-point interface, if you have a point-to-point circuit - do you assign the IP addresses at both ends under the same subnet? The answer is Yes.

Bronze

GRE tunnel and ip address

Thanks Edison. Long time no see.  How have you been ?

Hall of Fame Super Bronze

GRE tunnel and ip address

I'm fine, thanks for asking. How about you?

Bronze

GRE tunnel and ip address

I am fine too.

I hope to see quite often on the forum

2642
Views
0
Helpful
6
Replies