Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

GRE Tunnel Configuration ??????

Hi

I want to config the GRE Tunnel over my 7206 VXR running BGP on it,

I have read the DOC about GRE tunnel Config. on cisco site in tgis DOc the routing protocol is EIGRP ... this is the title of DOc

(GRE over IPSec with EIGRP to Route Through a Hub and Multiple Remote Sites Configuration Example )

i want to ask same config will work for BGP or not ??????

Thanks

5 REPLIES
Gold

Re: GRE Tunnel Configuration ??????

Not sure if I found the doc you are talking about.

In general BGP is far more forgiving that EIGRP or any IGP for that matter. BGP uses TCP to essablish it neighbors unlike EIGRP that uses multicast.

You should have no issues using the tunnel end points as your BGP neighbors.

With BGP it is possible with some careful IPSEC configuration to use only IPSEC and avoid the overhead of the GRE tunnel.

Bronze

Re: GRE Tunnel Configuration ??????

It should work. I would recommend using loopbacks for your BGP peers and then pointing to the tunnels for each of the neighbor loopbacks. My friends and I did this so we could run BGP with each other from our home connections.

New Member

Re: GRE Tunnel Configuration ??????

Hi

Can u provide me sample configuration of tunnel and also sample configuration with GRE over bgp

Thanks for the response

New Member

Re: GRE Tunnel Configuration ??????

http://www.cisco.com/en/US/tech/tk583/tk372/technologies_configuration_example09186a00800a43f6.shtml

That should be a good starting point. It is using OSPF, but if you replace it with BGP you should be able to accomplish what you are trying to do.

Re: GRE Tunnel Configuration ??????

Hi friend,

Here is a sample config

Router 1

interface Tunnel3

ip address 10.10.10.50 255.255.255.252

keepalive 10 3

tunnel source 192.168.172.30

tunnel destination 192.168.172.2

router bgp 64521

no synchronization

bgp log-neighbor-changes

network 172.16.119.0 mask 255.255.255.0

timers bgp 5 15

neighbor 192.168.172.29 remote-as 9730

neighbor 192.168.172.29 ebgp-multihop 2

no auto-summary

Router 2

interface Tunnel3

ip address 10.10.10.50 255.255.255.252

keepalive 10 3

tunnel source 192.168.172.2

tunnel destination 192.168.172.30

router bgp 64521

no synchronization

bgp log-neighbor-changes

network 172.16.100.0 mask 255.255.255.0

timers bgp 5 15

neighbor 192.168.172.1 remote-as 9730

neighbor 192.168.172.1 ebgp-multihop 2

no auto-summary

You can also use loopbacks as suggested in the earlier post. Make sure your loopbacks are reachable through the BGP cloud

HTH, rate if it does

Narayan

1825
Views
0
Helpful
5
Replies
CreatePlease login to create content