Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

GRE Tunnel Routing Problem

I created a GRE tunnel.  The tunnel is up and functioning fine.  I am having a routing issue on one side of the network.

Router 1

interface Tunnel5

ip address 10.255.111.2 255.255.255.252

ip mtu 1400

tunnel source 10.110.141.254

tunnel destination 10.87.5.2

S     192.168.21.0/24 [1/0] via 10.255.111.1

Router 2

interface Tunnel5

ip address 10.255.111.1 255.255.255.252

ip mtu 1400

tunnel source 10.87.5.2

tunnel destination 10.110.141.254

S    192.168.20.0/24 [1/0] via 10.255.111.2

From router 1 data travels correctly accross the tunnel:

Tracing the route to 192.168.21.254

VRF info: (vrf in name/id, vrf out name/id)

  1 10.255.111.1 12 msec 8 msec 8 msec

  2 10.87.5.9 8 msec *  8 msc

From router 2 it keeps bouncing between the tunnel and serial interface on the router:

traceroute 192.168.20.200

1 10.255.111.2 8 msec 8 msec 8 msec

2 10.110.11.46 16 msec 16 msec 16 msec

3 10.110.11.1 8 msec 8 msec 8 msec

4 10.255.111.2 12 msec 16 msec 12 msec

5 10.110.11.46 24 msec 24 msec 24 msec

6 10.110.11.1 12 msec 16 msec 12 msec 1 10.255.111.2 8 msec 8 msec 8 msec
2 10.110.11.46 16 msec 16 msec 16 msec
3 10.110.11.1 8 msec 8 msec 8 msec
4 10.255.111.2 12 msec 16 msec 12 msec
5 10.110.11.46  24 msec 24 msec 24 msec
6 10.110.11.1 12 msec 16 msec 12 msec

10.110.11.46 is the serial interface on the router where the 10.255.111.2 tunnel is created.  10.110.11.1 is an interface for MPLS.

1 ACCEPTED SOLUTION

Accepted Solutions

GRE Tunnel Routing Problem

Andy,

We'll, this 3560 switch has an SVI on it, so you should be able to put an IP address on R1 and make it a L3 link basically.

you can try that static route command.

23 REPLIES

GRE Tunnel Routing Problem

Andy,

Can you post the result of 'show ip route 192.168.20.200' on Router 1?

New Member

GRE Tunnel Routing Problem

Thanks for the quick repsonse. 

R1#show ip route | in 192.168.20.200

R1#

Nothing in the routing table for it.

GRE Tunnel Routing Problem

Andy,

What is the default route on R1?

New Member

GRE Tunnel Routing Problem

10.110.11.46

GRE Tunnel Routing Problem

Andy,

Do a 'show ip route 192.168.20.200' on the network device that 10.110.11.46 is on, as well as post what the default route is.

New Member

Re: GRE Tunnel Routing Problem

10.110.11.46 is bgp nei from the teleco company for the MPLS circuit.

GRE Tunnel Routing Problem

Andy,

1 10.255.111.2 8 msec 8 msec 8 msec

2 10.110.11.46 16 msec 16 msec 16 msec

3 10.110.11.1 8 msec 8 msec 8 msec

4 10.255.111.2 12 msec 16 msec 12 msec

5 10.110.11.46 24 msec 24 msec 24 msec

6 10.110.11.1 12 msec 16 msec 12 msec

It's sending the first round of UDP datagrams for 192.168.20.200 and R2 does a route lookup for 192.168.20.200 and finds that it's best route to 192.168.20.200 is 10.255.111.2. This UDP datagram is sent to a non-valid port, and with a TTL of 1. This process happens again, but with a TTL of 2, which goes to 10.110.11.46. Once again this process continus and a third round of UDP datagrams goes with a TTL of 3. It sounds like there is an issue at 10.110.11.1, when it received the fouth round of UDP datagrams with a TTL of 4, it sees the bst route is 10.255.1.2, which this obviously starts a loop.

Is thre anyway you can look at the routing table at 10.110.11.1, and find what the best route to 192.168.20.200 is from this router, including a default route if that's the best route?

New Member

Re: GRE Tunnel Routing Problem

10.110.11.1 is a physical interface on R2.

The default route on this router is 10.87.5.9 which is an svi core 6500:

sh ip route | in 192.168.20

D EX 192.168.20.0/24 via 10.87.5.2

GRE Tunnel Routing Problem

Andy,

I gotcha. So when it gets to 10.110.11.46 which is the bgp peer IP, it's hitting that interface and going back to 10.110.11.1. Do you know the route that this should be taking?

Because in an earlier post, you noted this.

R1#show ip route | in 192.168.20.200

R1#

Nothing in the routing table for it.

So it gets to R1, but it has no route for it, so takes it's default route to 10.110.11.46, which is your bgp peer IP.

New Member

Re: GRE Tunnel Routing Problem

Routing is not my strong suit so if I am not answering your last question that well I appologize.

So I want anything that is going to the 192.168.20.x network to travel over the GRE tunnel.  So when I ping from R2 shouldnt the route there get it to its destination hanging off of R1 with the static route that I defined on R2?  Or do I need to add another route to R1?

From R1 I can ping 192.168.20.200 with no issues.

Thanks

GRE Tunnel Routing Problem

Andy,

When you look at your traceroute output, you can see it is correctly getting across the tunnel (10.255.111.2 8 msec 8 msec 8 msec), but from R1, there is no route to this 192.168.20.0/24 network, so it uses the default route.

When it gets to R1, it's going to do a route lookup for 192.168.20.0./24, which as you noticed earlier, it can't find a route in it's routing table.

R1#show ip route | in 192.168.20.200

R1#

Are you running a routing protocol, or is everything static?

New Member

Re: GRE Tunnel Routing Problem

We are running BGP and EIGRP.  For this network I prefer to keep them static routes. 192.168.20.200 is a SVI I created on the switch hanging off of R1 for testing. 

What route would I create on R1 to get traffic to the 192.168.20.0 /24 network?

GRE Tunnel Routing Problem

Andy,

192.168.20.200 is a SVI I created on the switch hanging off of R1 for testing.

That's the missing link in our chain.

So it gets to R1, and it needs to get to the SVI off that switch, which is hanging off of R1.

Can you post how the interface is configured for the port, going to this switch with the SVI.

'show run int

Please post those results.

New Member

Re: GRE Tunnel Routing Problem

show run int vlan 333

interface vlan333

ip address 192.168.20.200 255.255.255.0

GRE Tunnel Routing Problem

Andy,

Ok, let me make sure I get this correct.

Is that 'show run int vlan 333' from the Switch or from R1?

If (interface vlan 333) is from R1, can you post the results from 'show int vlan333' ?

New Member

Re: GRE Tunnel Routing Problem

vlan333 is the switch hanging off of the router.

GRE Tunnel Routing Problem

Andy,

Ok, Cool. So on R1, there is a physical port that is connected to this switch. On R1, can you post the results from 'show run int X' where X is the port on Router 1 that is going to this SW.

New Member

Re: GRE Tunnel Routing Problem

R1

Show run int gi0/1

no ip address

ip flow ingress

ip flow egress

duplex full

speed 100

Here is the config on the switch that it hooks into as well:

interface GigabitEthernet0/1

description CISCO2911 Gig 0/1

switchport access vlan 141

switchport trunk encapsulation dot1q

switchport mode trunk

speed 100

duplex full

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape  10  0  0  0

queue-set 2

mls qos trust cos

auto qos voip trust

rmon collection stats 1 owner PMmonitor

rmon collection history 1 owner PMmonitor buckets 50 interval 1800

GRE Tunnel Routing Problem

Andy,

So when it gets to R1, it's going to do a route lookup, and obviously take the default route, since there is no default route.

On Gi0/1, on R1, configure the IP address of 192.168.20.x, X will be some number that you want to use. Once this happens, it will become a directly connected route.

On R1, after you do this, you will see 192.168.20.0 255.255.255.0, and it will ARP out for any host on 192.168.20.x/24.

Is this switch for testing purposes?

New Member

Re: GRE Tunnel Routing Problem

Its not for testing purposes but I can play with it a little.  The swtich is a 3560 and routing is not currently enabled on it.  Can I enable routing on the switch and then put a static route on the router?

Ip route 192.168.20.0 255.255.255.0  via 192.168.20.200?

GRE Tunnel Routing Problem

Andy,

We'll, this 3560 switch has an SVI on it, so you should be able to put an IP address on R1 and make it a L3 link basically.

you can try that static route command.

New Member

Re: GRE Tunnel Routing Problem

Disregard last post.  I created the interface and it is now routing correctly.  I really appreciate all of your help on this issue.

Thank you very much.

GRE Tunnel Routing Problem

Andy,

No problem glad I could help!

347
Views
0
Helpful
23
Replies
CreatePlease to create content