Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

GRE Tunnel - Traffic flow

Hi

I got an issue with reference to attach design.

Traffic from Loc_A designated to Loc_C passes Loc_B, but if link between Loc_B and Loc_A is down then it goes directly.

How do I influence traffic from Loc_A designated to Loc_C to go direct.

Loc_A is connected to Loc_B via Metro Ethernet   ( OSPF is the routing protocol )

Loc_A is connected to Loc_C via IPSEC_GRE Tunnel  ( EIGRP for tunnel interface )

Loc_B is connected to Loc_C via IPSEC_GRE Tunnel  ( Eigrp for Tunnel Interface )

On Loc_A / Loc_B / Loc_C there is mutual redistribution between EIGRP and OSPF

thnks

ST

5 REPLIES
Silver

Re: GRE Tunnel - Traffic flow

ST,

As a result of the mutual redistribution the subnets in question look better over the OSPF Metro E with an admin distance of 110.  Networks redistributed into EIGRP have an admin distance of 170.

Why not run a single routing protocol for one homogonous routing domain?

You could use then ‘distance’ command under EIGRP or OSPF to make specific routes in question look more attractive over the tunnel network.  You could also use the ‘distance eigrp’ command to change the admin distance for EIGRP globally.  These two options don’t generally scale well but they are effective.

http://conft.com/en/US/docs/ios/12_2/iproute/command/reference/1rfeigrp.html#wp1017590


Here’s a good admin distance doc:

http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a0080094195.shtml



Chris

New Member

Re: GRE Tunnel - Traffic flow

Hi Chris

thanks for replying, with distance command it doesnt work either. Initial config of Loc_A / Loc_B / Loc_C are attached.

In near future we plan to have more internet links with unequal bandwidth, so I selected EIGRP.

I also have plan to apply route-map to restrict the flow of subnet between GRE Tunel

Any help

Thanks

ST

New Member

Re: GRE Tunnel - Traffic flow

Hi

Distance command not working as expected.

Loc_A receives routes for Loc_C from Loc_B and Loc_C but prefers Loc_B.

Can I get help on influence the  traffic flow.


#sh ip route eigrp

D EX 192.168.88.0/24 [170/10496000] via 172.20.1.2, 00:06:51, Tunnel4

show ip route 192.168.88.0
Routing entry for 192.168.88.0/24
  Known via "ospf 1", distance 110, metric 20, type extern 2, forward metric 3
  Redistributing via eigrp 2
  Advertised by eigrp 2
  Last update from 172.16.1.1 on FastEthernet0/1, 00:07:23 ago
  Routing Descriptor Blocks:
  * 172.16.1.1, from 172.20.0.9, 00:07:23 ago, via FastEthernet0/1
      Route metric is 20, traffic share count is 1

Silver

Re: GRE Tunnel - Traffic flow

Try this config on the WAN routers where mutual redistribution occurs.

route-map eigrp2ospf deny 10
match tag 111
exit

route-map eigrp2ospf permit 20
set tag 222
exit

##

route-map ospf2eigrp deny 10
match tag 222
exit

route-map ospf2eigrp permit 20
set tag 111
exit


##

router ospf 1
redistribute eigrp 2 subnets type 1 route-map eigrp2ospf
exit

router eigrp 2
redistribute ospf 1 route-map ospf2eigrp
exit

##

This prevents routes from back feeding into the originating protocol.  It will also set OSPF external routes to type 1.  The metric of a type 1 route will increase as it’s propagated throughout the network.  This should be helpful in this topology.  If you still have sub-optimal pathing after this change adjusting the OSPF metrics should fix it.



Chris

New Member

Re: GRE Tunnel - Traffic flow

Hi Chris,

Route_Map didnt help.

Output is same as posted before.

thanks

ST

430
Views
0
Helpful
5
Replies
CreatePlease to create content