Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

GRE Up/Down on 192.168.0.0/30

Attached is a diagram and three router configurations. I am trying to build a gre tunnel from rtr3_ospf to rtr4_ospf.

My tunnel0 on both routers are down and I can not ping the remote address 192.168.0.0/30. Any assistance and insight into why it is not working would be greatly appreciated.

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Re: GRE Up/Down on 192.168.0.0/30

Hello David,

>> When I remove the keepalive 10 3, the tunnel comes up. I'm still not sure what I am doing wrong.

not all IOS images or platforms support GRE keepalive you may be using a release that allows you to configure it but it does not support it.

For example in real world you cannot use the above command on a C6500/C7600 they do not support it.

you are using GNS3 so you need to check if the loaded IOS image support GRE keepalive using feature navigator

Hope to help

Giuseppe

3 REPLIES
Hall of Fame Super Silver

Re: GRE Up/Down on 192.168.0.0/30

Hello David,

you cannot run the same routing protocol inside and outside the tunnel

router ospf 2020

log-adjacency-changes

network 10.16.0.0 0.0.0.3 area 0

network 172.15.1.0 0.0.0.255 area 0

network 172.15.2.0 0.0.0.255 area 0

network 172.15.3.0 0.0.0.255 area 0

>>>> network 192.168.0.0 0.0.0.3 area 0

!

you need to use a different protocol over the tunnel for example EIGRP or a different OSPF routing process
You are facing a recursive routing error: once the tunnel is up also the tunnel endpoint addresses are advertised over it and this is not good at all
remove the line network 192.168.0.0 0.0.0.3 area 0 on both routers R3 and R4
use a different process like
router ospf 123
network 192.168.0.0 0.0.0.3 area 0
network 192.168.123.3 0.0.0.0 area 0
to see everything is working well you need to advertise at least one IP subnet on each side
in loop3
ip address 192.168.123.3 255.255.255.255
no shut
a similar setup has to be done on R4:
router ospf 123
network 192.168.0.0 0.0.0.3 area 0
network 192.168.123.4 0.0.0.0 area 0
in loop3
ip address 192.168.123.4 255.255.255.255
no shut
Hope to help
Giuseppe

New Member

Re: GRE Up/Down on 192.168.0.0/30

Hi Giuseppe,

I removed the network statement "network 192.168.0.0 0.0.0.3 area 0" from under the router process id, then shutdown/no shutdown the tunnel interface.

After a few seconds the tunnel interface comes back down again. When I remove the keepalive 10 3, the tunnel comes up. I'm still not sure what I am doing wrong. Thanks.

Hall of Fame Super Silver

Re: GRE Up/Down on 192.168.0.0/30

Hello David,

>> When I remove the keepalive 10 3, the tunnel comes up. I'm still not sure what I am doing wrong.

not all IOS images or platforms support GRE keepalive you may be using a release that allows you to configure it but it does not support it.

For example in real world you cannot use the above command on a C6500/C7600 they do not support it.

you are using GNS3 so you need to check if the loaded IOS image support GRE keepalive using feature navigator

Hope to help

Giuseppe

548
Views
0
Helpful
3
Replies
CreatePlease to create content