Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Have two routers, one subinterface on each serial connected via Cloud using FR; cannot ping each other

First of all, this is the first time for me posting on these forums so I hope that my post abides by the rules.

I'm new to configuring Frame Relay and started off with a simple topology:

FR.png

Since I intend to extend this topology as soon as I've managed to get it working, I decided to use subinterfaces. s0/3/0.103 on R1 and s0/3/0.301 on R2.

R1#sh run

Building configuration...

Current configuration : 848 bytes

!

version 15.1

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname R1

!

!

!

!

!

!

!

!

!

!

!

!

license udi pid CISCO2911/K9 sn FTX15244W9S

!

!

!

!

!

spanning-tree mode pvst

!

!

!

!

interface GigabitEthernet0/0

no ip address

duplex auto

speed auto

shutdown

!

interface GigabitEthernet0/1

no ip address

duplex auto

speed auto

shutdown

!

interface GigabitEthernet0/2

no ip address

duplex auto

speed auto

shutdown

!

interface Serial0/3/0

no ip address

encapsulation frame-relay

!

interface Serial0/3/0.103 point-to-point

ip address 10.1.10.1 255.255.255.0

frame-relay interface-dlci 103

!

interface Serial0/3/1

no ip address

shutdown

!

interface Vlan1

no ip address

shutdown

!

ip classless

!

!

!

!

!

!

!

line con 0

!

line aux 0

!

line vty 0 4

login

!

!

!

end


R2#sh run

Building configuration...

Current configuration : 848 bytes

!

version 15.1

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname R2

!

!

!

!

!

!

!

!

!

!

!

!

license udi pid CISCO2911/K9 sn FTX1524PJ1P

!

!

!

!

!

spanning-tree mode pvst

!

!

!

!

interface GigabitEthernet0/0

no ip address

duplex auto

speed auto

shutdown

!

interface GigabitEthernet0/1

no ip address

duplex auto

speed auto

shutdown

!

interface GigabitEthernet0/2

no ip address

duplex auto

speed auto

shutdown

!

interface Serial0/3/0

no ip address

encapsulation frame-relay

!

interface Serial0/3/0.301 point-to-point

ip address 10.1.11.1 255.255.255.0

frame-relay interface-dlci 301

!

interface Serial0/3/1

no ip address

shutdown

!

interface Vlan1

no ip address

shutdown

!

ip classless

!

!

!

!

!

!

!

line con 0

!

line aux 0

!

line vty 0 4

login

!

!

!

end

Cloud has been configured as follows:

Serial0: DLCI 301 Name zuR2

Serial1: DLCI 103 Name zuR1

Frame Relay:

Serial0 - zuR2 <-> Serial1 - zuR1

Any advice I can get is greatly appreciated.

1 REPLY

Re: Have two routers, one subinterface on each serial connected

Hi Nicolas,

welcome at CSC!

You're using Frame-Relay, a layer-2 technology, to interconnect the router's subinterfaces.

Why are the subinterfaces in different IP-subnets when there's no routing instance in between?

Actually, due to the logic of FR P2P-interfaces, you could add static routes to make it work; but since you can't specify a next-hop IP-address, you would have to configure the exit-interface instead, which is not recommended:

R1#show ip interface brief s0/0.103

Interface                  IP-Address      OK? Method Status                Protocol

Serial0/0.103              10.1.10.1       YES manual up                    up

R1#show ip route static

S       10.1.11.0 is directly connected, Serial0/0.103

R1#ping 10.1.11.1

Sending 5, 100-byte ICMP Echos to 10.1.11.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 28/37/64 ms

Best regards

Rolf

475
Views
0
Helpful
1
Replies
CreatePlease to create content