Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Help break down of my qos config

This was written by some one else, just trying to get a better understanding..

Please help me break this config down and how it works..

This is on a 2821 using vrf

class-map match-all cos-map-pre-vo-1
match ip precedence 5

policy-map cos-po2-ifx-mfr1-140
class cos-map-pre-vo-1
  priority 317 3170
   police 317000 conform-action transmit  exceed-action drop

!
interface MFR1.140 point-to-point
description VRF IFX
bandwidth 3088
ip vrf forwarding ifx
ip address 10.202.24.50 255.255.255.252
ip flow ingress
frame-relay interface-dlci 140 IETF  
  class cos-frm-ifx-mfr1-140

route-map cos-map-ifx-1 permit 10

interface GigabitEthernet0/0.666
description VRF IFX Voice
bandwidth 1000000
encapsulation dot1Q 666
ip vrf forwarding ifx
ip address 172.19.171.1 255.255.255.192
ip flow ingress
ip policy route-map cos-map-ifx-1

Let me know if I am missing anything...

Thanks!

--Mike

1 ACCEPTED SOLUTION

Accepted Solutions
Bronze

Re: Help break down of my qos config

Let's break it down:



1. There's a class-map and policy-map, which is good.  But they need to be applied to an interface.

class-map match-all cos-map-pre-vo-1
match ip precedence 5

policy-map cos-po2-ifx-mfr1-140
class cos-map-pre-vo-1
  priority 317 3170
   police 317000 conform-action transmit  exceed-action drop

interface MFR1.140 point-to-point
description VRF IFX
bandwidth 3088
ip vrf forwarding ifx
ip address 10.202.24.50 255.255.255.252
ip flow ingress
frame-relay interface-dlci 140 IETF  
  class cos-frm-ifx-mfr1-140

2. When you use the class command under frame relay, it expects to see a matching "map-class frame-relay"  There is a policy-map with the same name, but it won't use that.

route-map cos-map-ifx-1 permit 10

3. Route-maps aren't used for QoS, they are used for Policy routing and Route filtering.

interface GigabitEthernet0/0.666
description VRF IFX Voice
bandwidth 1000000
encapsulation dot1Q 666
ip vrf forwarding ifx
ip address 172.19.171.1 255.255.255.192
ip flow ingress
ip policy route-map cos-map-ifx-1

4. "ip policy" is used for policy routing, but it's calling an empty route-map (see above), so I believe it will have no affect.  Packets could get punted to the CPU if this is a hardware based platform.

Take a look at the Frame-relay configuration guide for help in guiding you to the correct config.  If you need further help, let us know.

http://www.cisco.com/en/US/docs/ios/12_1/wan/configuration/guide/wcdfrely.html#wp1003412

Dan

1 REPLY
Bronze

Re: Help break down of my qos config

Let's break it down:



1. There's a class-map and policy-map, which is good.  But they need to be applied to an interface.

class-map match-all cos-map-pre-vo-1
match ip precedence 5

policy-map cos-po2-ifx-mfr1-140
class cos-map-pre-vo-1
  priority 317 3170
   police 317000 conform-action transmit  exceed-action drop

interface MFR1.140 point-to-point
description VRF IFX
bandwidth 3088
ip vrf forwarding ifx
ip address 10.202.24.50 255.255.255.252
ip flow ingress
frame-relay interface-dlci 140 IETF  
  class cos-frm-ifx-mfr1-140

2. When you use the class command under frame relay, it expects to see a matching "map-class frame-relay"  There is a policy-map with the same name, but it won't use that.

route-map cos-map-ifx-1 permit 10

3. Route-maps aren't used for QoS, they are used for Policy routing and Route filtering.

interface GigabitEthernet0/0.666
description VRF IFX Voice
bandwidth 1000000
encapsulation dot1Q 666
ip vrf forwarding ifx
ip address 172.19.171.1 255.255.255.192
ip flow ingress
ip policy route-map cos-map-ifx-1

4. "ip policy" is used for policy routing, but it's calling an empty route-map (see above), so I believe it will have no affect.  Packets could get punted to the CPU if this is a hardware based platform.

Take a look at the Frame-relay configuration guide for help in guiding you to the correct config.  If you need further help, let us know.

http://www.cisco.com/en/US/docs/ios/12_1/wan/configuration/guide/wcdfrely.html#wp1003412

Dan

196
Views
0
Helpful
1
Replies
CreatePlease login to create content