Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Help bundle two t1's for internet connection

Help!

I will be configuring a 2611 router with two t1 for internet connection. How do I configure the controller card and the serial interface? I intend to bundle the two t1?s for more speed. Please help with basic configuration

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Re: Help bundle two t1's for internet connection

Cecil

I believe that you are describing putting both of the T1s into a multilink bundle. This treats both physical links as part of a single logical interface. Part of the concept of this is that the physical interfaces do not get IP addresses and the IP address is configured on the single logical interface. Your config would look something like this (obviously with the address assigned to you by your provider and with interface numbering that matches your router). You might want the commands for fair-queue and mroute or you might not want them. They were part of the config from a router that I configured and they work for that installation. They might not be needed in your installation. Also note that the provider must configure their interfaces in a similar manner.

interface Multilink1

ip address 172.16.209.86 255.255.255.252

ppp multilink

ppp multilink fragment disable

ppp multilink group 1

!

interface Serial0/0

description connection to Internet

no ip address

encapsulation ppp

no ip mroute-cache

no fair-queue

service-module t1 timeslots 1-24

ppp multilink

ppp multilink group 1

!

interface Serial1/0

description connection to Internet

no ip address

encapsulation ppp

no ip mroute-cache

no fair-queue

service-module t1 timeslots 1-24

ppp multilink

ppp multilink group 1

!

HTH

Rick

15 REPLIES

Re: Help bundle two t1's for internet connection

hi

can you post the model of the T1 card here which can be useful to suggest the recommended config for the same.

are these lines connecting to the same end point device at the remote location ?

if its then you can have a logical bundle created by grouping the physical links.

regds

New Member

Re: Help bundle two t1's for internet connection

The 2611 came with 1 t1 WIC card installed with a single t1 port. I installed another WIC card in the other slot which also has 1 t1 port on it

I now have 2 t1 ports on the 2611. I will be connecting the 2 t1's into the 2 t1 interface port.

these lines are connecting to the same end point which is my ISP. the lines are for internet service

I hope this info will help.

New Member

Re: Help bundle two t1's for internet connection

I have a 2621XM router that's doing what you're trying to do. I have it configured with 2 T-1DSU WICs and below is part of my config that should get you started:

ip cef

ip cef accounting per-prefix non-recursive

interface Serial0/0

ip address x.x.x.x x.x.x.x

encapsulation ppp

service-module t1 timeslots 1-24

interface Serial0/1

ip address x.x.x.x x.x.x.x

encapsulation ppp

service-module t1 timeslots 1-24

2 Routes are setup:

ip route 0.0.0.0 0.0.0.0 Serial0/0

ip route 0.0.0.0 0.0.0.0 Serial0/1

New Member

Re: Help bundle two t1's for internet connection

Thanks for your reply.

it looks like you are using the 2 t1 separately. Correct me if am wrong. I?ll like to bundle my up for more bandwidth.

Your point-to-point or just internet lines?

Mine are just internet lines

Hall of Fame Super Silver

Re: Help bundle two t1's for internet connection

Cecil

I believe that you are describing putting both of the T1s into a multilink bundle. This treats both physical links as part of a single logical interface. Part of the concept of this is that the physical interfaces do not get IP addresses and the IP address is configured on the single logical interface. Your config would look something like this (obviously with the address assigned to you by your provider and with interface numbering that matches your router). You might want the commands for fair-queue and mroute or you might not want them. They were part of the config from a router that I configured and they work for that installation. They might not be needed in your installation. Also note that the provider must configure their interfaces in a similar manner.

interface Multilink1

ip address 172.16.209.86 255.255.255.252

ppp multilink

ppp multilink fragment disable

ppp multilink group 1

!

interface Serial0/0

description connection to Internet

no ip address

encapsulation ppp

no ip mroute-cache

no fair-queue

service-module t1 timeslots 1-24

ppp multilink

ppp multilink group 1

!

interface Serial1/0

description connection to Internet

no ip address

encapsulation ppp

no ip mroute-cache

no fair-queue

service-module t1 timeslots 1-24

ppp multilink

ppp multilink group 1

!

HTH

Rick

New Member

Re: Help bundle two t1's for internet connection

I have a similar situation. Two T1 lines are from the same ISP.

Will the second T1 line be up if the first T1 line goes down?

If this will work then I don't need BGP.

Re: Help bundle two t1's for internet connection

hi

in case of redundancy you dont need to use bgp since you can achieve the same using static routes.

but the similar setup has to be done at sp end too to have the fallback triggered.

regds

Re: Help bundle two t1's for internet connection

HI Rick and Prem,

Urgent Requirement:

--------------------------

Hello All,

Router 1<----------->Router 2

Currently i have a E1 circuit between R1 and R2 Routers.

I am purchasing a new E1 circuit for Load Sharing and High availaibility.

I wish to Bundle the both the E1 Circuits as Single Virtual Link.

Please help me with the Sample Configuration of "Multi Link PPP"

Note: Both the E1 Circuits belongs to two different Service Providers.

Thanks in Advance for Help

Best Regards,

Guru Prasad R

Re: Help bundle two t1's for internet connection

hi

Are you availing normal TDM Point to Point circuits from the Telco if yes then the config posted by Rick is enough except the timeslot command.

Also do make sure that you are doing a proper tests for errors/reliability of both the links before putting them in the bundle.

You will experience degraded performance if anyone of the circuit contains errors.

regds

Re: Help bundle two t1's for internet connection

HI Prem,

Thanks for Info. Yes, its a dedicated Point-to-Point Circuit only.

Question: In this Multilink PPP Environment, what will happen in a Situation if one of the Circuit goes DOWN.

Whether the traffic will automatically carried forward by the Second Link ?

Thanks in Advance for Help

Best Regards,

Guru Prasad R

Re: Help bundle two t1's for internet connection

Yes you are rite the traffic will go via multilink (logical link) which will be up based on the status of active link.

Thats where it becomes difficult in finding out whether both the links are up since you will have reachability even with a single link (which is a member of the bundle).

regds

Re: Help bundle two t1's for internet connection

HI Prem & Rick,

Thanks for Help and Have Rated your Post.

Best Regards,

Guru Prasad R

New Member

Re: Help bundle two t1's for internet connection

Then what's the benefit of BGP? My ISP wanted to set up BGP to route both inbound and outbound traffic.

Is there any security risk in implementing multilink?

New Member

Re: Help bundle two t1's for internet connection

Thanks to everyone especially you Rick. My multilink is up

Hall of Fame Super Silver

Re: Help bundle two t1's for internet connection

Cecil

I am glad that your multilink is up. Thank you for posting back to indicate that the suggested solution did work. And thank you for using the rating system to indicate that your issue was resolved (and thanks for the rating). It makes the forum more useful when people can read about an issue and can know that they will read a solution that resolved the issue. I encourage you to continue your participation in the forum.

HTH

Rick

515
Views
6
Helpful
15
Replies