Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Community will be in read-only mode on 12/14/2017 from 12:00 am pacific to 11:30 am.

During this time you will only be able to see content. Other interactions such as posting, replying to questions, or marking content as helpful will be disabled for few hours.

We apologize for the inconvenience while we perform important updates to the Community.

New Member

Help Confi guring Router

I am having some problems configuring a router, and I was hoping for

some help. I do not configure router very ofter, and usually, I use the GUI web tool that is provided. I this case I am trying to configure using the IOS, and I sure that I am missing something simple.

Basically, I have a Cisco 2600 with a CSU/DSU (Serial 0/0) and a

FastEthernet (FastEthernet0/0) port. All I want to do is to hook a PC into the Fast Ethernet Port and have that computer connect to the Internet. I have a bank of 20 or so IP address (The range 67.133.225.127/27 Mask 255.255.255.224) and do mind using the public IP address for the computer connected to the Fast Ethernet port.

I have configure the Serial0/0 port with the T1 information provided to

me from our service povider. The Serial is 67.133.224.14/30, and it is a full T1. I have configured the FastEhternet port

and the computer connected to the FastEthernet port with public IP

addresses that were also provided to me from our T1 provider.

The only other thing that have have done is added the following route

to the router

ip route 0.0.0.0 0.0.0.0 Serial0/0

On the router, I am able to ping external websites like google (using google's IP address),

however, from the computer on the ethernet port I can only ping the

FastEthernet port.

I know I am missing something simple, as this is the first time I have

configured a router. Thanks for any help.

11 REPLIES

Re: Help Confi guring Router

Hi

Two thing i would suggest to check out here is ip classless command in ur router config and also default gateway in ur PC.

also about the port status on both PC and router.since u r hooking up ur pc directly on the etherenet port of the router u need to use a cross cable to bring the link up.

If all is well would suggest to post the config of the router.

you can very well logon thru the console port of the router for troubleshooting purpose.

finally do check up the route for ur internal network (local lan subnet) on the SP side...

regds

Hall of Fame Super Silver

Re: Help Confi guring Router

While ip classless is a good thing to have configured, I do not believe that there is much in the description of the symptoms that suggests that this is the problem. The suggestion about using crossover cable is certainly a good point. But the fact that the PC can ping the interface suggests that it is already using crossover cable.

I believe that the suggestion that there is a problem with the configuration of default-gateway on the PC is the most likely cause of the problem.

There is another possibility that should also be checked. The fact that the router can ping Internet destinations successfully tells us that the subnet of the serial is working properly. There is a possibility that the subnet of the FastEthernet is not working (not yet properly routed by the provider). The easy way to check that is to do an extended ping on the router. In the extended ping specify the destination as some valid Internet address and specify the source of the ping as the FastEthernet interface. If the extended ping works it shows that the provider is properly routing the LAN subnet. If the extended ping fails then the provider is not properly routing the LAN subnet.

Also the fact that the router can ping by address but not by name probably reflects the fact that the router has not been configured with a DNS server. If you configure an appropriate name server on the router then it should be able to ping by name.

HTH

Rick

Re: Help Confi guring Router

What is the IP address you are using for the PC? Also could you post the Config?

Mike

New Member

Re: Help Confi guring Router

Thanks to everyone for the help thus far. If this doesn't help, I will post the config file, as the router not accessable at the moment.

The LAN IP block that I was give was 67.133.225.192/27 Which they say the subnet mask is 255.255.255.224

On the FastEthernet port, I have assigned the IP address of 67.133.225.192. On the PC I assigned the IP address of 67.133.225.193 with the gateway of 67.133.225.192. (I have also tried the Serial IP of 67.133.224.14 but that did seem to work)

Side question, I am intrested in what someo ne said about the subnet mask. If I do not have the right subnet mask on either my PC or on the router, will my connection work. For example If my subnet 255.255.255.224, and I used 255.255.255.0, would traffic still route correctly?

New Member

Re: Help Confi guring Router

Hi,

You MUST use the same mask, if you don't use the same mask you will have routing problems.

Also, what I see is that you are using in the FastEthernet port the Subnet Address. Try this, use in the FastEthernet port the IP 67.133.225.193/27, and in your PC the next IP 67.133.225.194/27 with gateway 67.133.225.193.

Usually the service provider gives you the whole subnet.

I hope this helps,

regards,

Ricardo

New Member

Re: Help Confi guring Router

Here is the dump of my configuration. On my PC connected to the Fasternet card, I can ping the FastEthernet port, the Serial port. On the router I am able to ping Web sites, and I am able to resolved DNS addresses.

Also, I have turned ip classless both on and off to not effect. Also, I have used the ip routing command, to no effect.

Current configuration : 759 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname NexGenDulles

!

boot-start-marker

boot-end-marker

!

enable secret xxxx

enable password xxxx

!

no network-clock-participate slot 1

no network-clock-participate wic 0

no aaa new-model

ip subnet-zero

ip cef

!

!

!

ip name-server 205.171.3.65

no ftp-server write-enable

!

!

!

!

interface FastEthernet0/0

ip address 67.133.225.193 255.255.255.224

speed auto

full-duplex

no mop enabled

!

interface Serial0/0

ip address 67.133.224.14 255.255.255.252

!

no ip classless

ip route 0.0.0.0 0.0.0.0 Serial0/0

no ip http server

!

!

line con 0

line aux 0

line vty 0 4

password xxxx

login

!

!

!

end

On my PC I have the following

67.133.225.194 IP

255.255.255.224 SUBNET

67.133.225.193 GATEWAY

205.171.3.65 DNS

205.171.2.65 DNS

Thanks

New Member

Re: Help Confi guring Router

Hi,

Please do a tracert from the pc to google.com or any ip, incase you are not able to resolve, please try to ping 4.2.2.1 (a route server IP) from your PC and also do a tracert to that IP. Note where your packet gets dropped. Also if you are not able to figure out, then please post the tracert 4.2.2.1 output.

FYI, I tried pinging 67.133.225.193 from internet, and I was able to ping, this suggests that this subnet is reachable from internet and hence suggests a problem on your desktop. Also pls note not to post the password along with the configuration, especially in this case as anyone can access your router from internet.

rgds,

Naveen B

Hall of Fame Super Silver

Re: Help Confi guring Router

Jeff

Thanks for posting the config. I believe that it is helpful. I believe that the config is fairly servicable as it is. I would ask you to change one thing and that is the ip classless/no ip classless. You may not see a difference yet (probably because of your other problem) but you will be much better off to configure ip classless. Also you commented that you have experimented with ip routing/no ip routing. I am glad that you have gone back to ip routing. With no ip routing you would certainly have had problems. (In fact no ip routing would be one thing that would produce the symptoms that you are currently having.)

Like Naveen I checked for Internet connectivity to the address that you gave as the FastEthernet address and find it reachable. But when I do a traceroute to it the next hop address before this address is not the address of your router. I am not sure whether you have altered your real address (to protect your identity) or whether this is your real address. If this is your real address, I believe that the provider is not routing that subnet block to you (which was one of my suggestions in a previous post) and that is why you are having the problem. If it is not your real address then we need to investigate a bit more. As I suggested in my previous post I believe that you should do an extended ping from the router. In the extended ping specify some Internet address that is reachable as the destination and specify the address of the FastEthernet as the source. If the extended ping succeeds it proves that the provider is routing that address block to you and suggests that the problem is in the PC. If the extended ping fails it confirms that the problem is in the address block that you are using and that the provider is not routing it to you.

And to go back to a previous part of this thread: your question about the subnet mask matching between the PC and the router, I would say that you "should" have them match (not "must" make them match) and that you "may" have problems if they do not match (not that you "will" have problems). If the router has enabled proxy arp (and it is enabled by default - and you have not turned it off in this config) then proxy arp will compensate for the mismatch between the PC config and the router config. I have worked with a customer where they always configured the PCs with mask 255.255.0.0 (because it makes the PC config easier for the administrator) and let the router proxy arp - and it worked just fine.

HTH

Rick

Re: Help Confi guring Router

Hi

Would you try adding a route

"ip route 0.0.0.0 0.0.0.0 67.133.224.13"

which will be a route to your next hop.

secondry, have you considered using another PC with same config?

Regards

JD

Bronze

Re: Help Confi guring Router

Funny thing happens, when you do a traceroute to the ip 67.133.225.193 and 67.133.225.194.

http://www.jellybaby.net/tr/tr.pl?host=67.133.225.193

http://www.jellybaby.net/tr/tr.pl?host=67.133.225.194

How come the last hop (no. 15) are two different IP's? shouldn't it have been either 67.133.225.193 or 67.133.224.14 on both traces?

What is the IP 67.129.148.154 used for?

Maybe your ISP are routing the host address 67.133.225.194 to another custoner on the same PE router.

Try and ask Qwest if they can explain this behavior.

New Member

Re: Help Confi guring Router

Thanks to everyone for the help! Your help really help to clarify that my router configuration was correct (with a few small tweeks mentioned in this thread), and that the problem is most likely with Verizon/Qwest.

I have not gotten anywhere with them yet, but I hope to resolve this soon.

Thanks again for the help.

297
Views
0
Helpful
11
Replies
CreatePlease to create content