Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

help default-network not being distributed over eigrp

Hi All, i need help i have Router 1 conecting to router 2 and 3 and router 2 and 3 to each other. I already have eigrp running and it is already distributing route. but for some reason a static route that i made defualt-network is still not being distributed. to router 2 and 3. just wondering because im following a video tutorial and it said that EIGRP should automatically distribute that default-network.

on router 1

     ip route 192.168.1.0 255.255.255.0 f0/0

     ip default-network 192.168.1.0

if i now do a sh ip route on router 1 it shows the static route for 192.168.1.0 already have * on it

but on router 2 and 3 the route for 192.168.1.0 is still not showing in the routing table.

All setting is still on default but i did try to supply the comand "default-information out" on rotuer 1 and even "default-information allowed out" still nothing. i also did the "default-information in" in router 2 and 3 and nothing and those commands is not showing in the running config so i would assume it is the default anyway.

can anyone shed some light on this as i just want to understand what is wrong incase i encoutner this real life.

anyway my lab is on GNS3 with a 2621XM Version 12.4(25d) iso

Everyone's tags (3)
3 REPLIES

Re: help default-network not being distributed over eigrp

Hi Robert,

Have you tried using the redistribute static command under the EIGRP process on R1?

router eigrp x

redistribute static

Sent from Cisco Technical Support iPhone App

New Member

help default-network not being distributed over eigrp

Hi johnlloyd, thank you for your response but my problem is i want to understand why my lab is not distributing default-network information. basically my question right now is, that eigrp on default setting, to distribute a static route using default-network is just supply the defult-network "network" command and no other configuration is needed? then if thats the case i would just peg this issue as GNS3 problem unless some one gives me a better explination on to why the default-network is not being distributed.

New Member

help default-network not being distributed over eigrp

Ah I figured it out! I need to supply a network command for the 192.168.1.0 network under eigrp on router 1. I dint think I needed to add a network command for it since its only a static route and not an actual network directly connected to router 1 if you get my drift. anyway ill consider this thread closed.

779
Views
0
Helpful
3
Replies
CreatePlease to create content