Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

help me configure NAT from outside to inside

hy,

i have in my LAN networl a server that i want to access it from outside.

i have configued the NAT to support this access, but it does not work.

i send you configuration of the router :

Router#sh run

Building configuration...

Current configuration : 1108 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

enable secret xxx

!

no aaa new-model

ip cef

!

!

!

!

multilink bundle-name authenticated

!

!

voice-card 0

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

archive

log config

hidekeys

!

!

!

!

!

!

interface FastEthernet0/0

ip address 10.100.100.17 255.255.254.0

ip nat inside

ip virtual-reassembly

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

!

interface FastEthernet0/1.1

encapsulation dot1Q 2338

ip address 84.x.x.172 255.255.255.248

ip nat outside

ip virtual-reassembly

!

ip route 0.0.0.0 0.0.0.0 84.16.28.169

!

!

ip http server

ip nat inside source list 1 interface FastEthernet0/1.1 overload

ip nat inside source static tcp 10.100.100.10 443 84.16.28.172 443 extendable

!

access-list 1 permit any

!

!

!

control-plane

!

!

!

!

!

!

!

!

!

gatekeeper

shutdown

!

!

line con 0

line aux 0

line vty 0 4

password test

login

!

scheduler allocate 20000 1000

end

Router#

1 REPLY
New Member

Re: help me configure NAT from outside to inside

Hi,

I have noticed that your nat outside interface belongs to a VLAN 2338, make sure that

the next hop and outside part of the network can reach this interface.

in a lab environment i reproduced almost the same topology

on NAT device:

------------------

interface FastEthernet0/0

ip address 84.16.28.172 255.255.255.0

ip nat outside

ip virtual-reassembly

duplex full

!

interface FastEthernet1/0

ip address 10.100.100.101 255.255.255.0

ip nat inside

ip virtual-reassembly

duplex full

speed auto

!

ip nat source list 1 interface FastEthernet0/0

ip nat source static tcp 10.100.100.10 443 84.16.28.172 443 extendable

ip nat inside source static 10.100.100.100 84.16.28.172

!

ip route 0.0.0.0 0.0.0.0 84.16.28.172

-------------

Take a look at the enclosed document for the results.

97
Views
0
Helpful
1
Replies
CreatePlease to create content