cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
486
Views
0
Helpful
10
Replies

Help on IP SLA configuration

Hi all,

On the 1841 router (site Lot210) I would like to configure IP SLA for my WAN secondary line which is using ADSL.

Existing primary line is using BGP and connect to the HQ.

Now i want if the BGP interface is down, the secondary ADSL line take over.

Please see below,

1- Configure an IP SLA:
ip sla 1
  icmp-echo 58.139.x.x
  threshold 2000
  timeout 2000
  frequency 5
ip sla schedule 1 start now life forever
 
2- Create a track object:
track 1 ip sla 1 reachability
 
Then how about the route? i dont know what to config.
The router default route 0.0.0.0 0.0.0.0 is to the firewall (internet)

10 Replies 10

Tagir Temirgaliyev
Spotlight
Spotlight

I think it is better to configure second BGP neibor throw adsl line 

if you can share config I will do detailed instructions

is that possible?

here i attached the existing running-config without the IP SLA

=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=~=
sh run
Building configuration...

Current configuration : 4019 bytes
!
version 12.4
!
!
interface FastEthernet0/0
 description ADSL WAN Interface
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 no ip mroute-cache
 duplex auto
 speed auto
 pppoe enable group global
 pppoe-client dial-pool-number 1
 no cdp enable
!
interface FastEthernet0/1.3
 description $ETH-LAN$
 encapsulation dot1Q 10 native
 ip address 172.7.100.254 255.255.0.0
!
interface FastEthernet0/1.4
 description VLAN for Naraya
 encapsulation dot1Q 400
 ip address 172.47.100.254 255.255.0.0
!
interface Serial0/1/0
 description Primary Line IPVPN
 ip address 58.139.x.x 255.255.255.252
 no fair-queue
!
interface Dialer1
 ip address negotiated
 encapsulation ppp
 shutdown
 dialer pool 1
 ppp authentication pap callin
 ppp pap sent-username ise@com.my password 7 055A545C7519
!
router bgp 65322
 no synchronization
 bgp log-neighbor-changes
 network 172.7.0.0
 network 172.17.0.0
 network 172.27.0.0
 network 172.47.0.0
 network 172.57.0.0
 network 172.67.0.0
 neighbor 58.139.x.xy remote-as 23736
 no auto-summary
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 172.27.17.100
!

probably BGP must be like this

router bgp 65322
 no synchronization
 bgp log-neighbor-changes
 network 172.7.0.0 mask 255.255.0.0
 network 172.17.0.0  mask 255.255.0.0
 network 172.27.0.0 mask 255.255.0.0
 network 172.47.0.0 mask 255.255.0.0
 network 172.57.0.0 mask 255.255.0.0
 network 172.67.0.0 mask 255.255.0.0

and your advertised networks only 2 now

network 172.7.0.0 mask 255.255.0.0
network 172.47.0.0 mask 255.255.0.0

 

is this provider AS 23736 ?

you need to ask provider to give you static ip address on adsl link

and BGP neibor address on adsl link

 

and you will configure second BGP neighbor a.b.x.xy remote-as 23736

after that make

sh bgp nei det

I will do next config

Thanks for the response,

Please see below for the static IP of the Dialer 1, it is 114.133.141.63   

LOT_10#sh ip int brie
Interface                          IP-Address         OK? Method Status         Protocol
FastEthernet0/0            unassigned          YES NVRAM  up                up      
FastEthernet0/1            unassigned          YES NVRAM  up                up      
FastEthernet0/1.1          172.17.100.254  YES NVRAM  up                 up      
FastEthernet0/1.2          172.27.100.254  YES NVRAM  up                 up      
FastEthernet0/1.3          172.7.100.254    YES NVRAM  up                  up      
FastEthernet0/1.4          172.47.100.254  YES NVRAM  up                  up      
FastEthernet0/1.5          172.57.100.254  YES NVRAM  up                  up      
FastEthernet0/1.6          172.67.100.254  YES NVRAM  up                  up      
Serial0/1/0                      58.139.168.170  YES NVRAM  up                  up      
Virtual-Access1              unassigned         YES unset  up                    up      
Virtual-Access2              unassigned         YES unset  up                    up      
Dialer1                           114.133.141.63  YES IPCP   up                    up 

only provider knows is it static or dynamic ip address 114.133.141.63

and they can do it static

after that they can use it as bgp neidbor

Hi,

yes,it is confirm static address.

so does below config OK? 

How it should know preference primary and secondary?

router bgp 65322
 no synchronization
 bgp log-neighbor-changes
 network 172.7.0.0
 network 172.17.0.0
 network 172.27.0.0
 network 172.47.0.0
 network 172.57.0.0
 network 172.67.0.0
 neighbor 58.139.168.169 remote-as 23736
 neighbor 114.133.141.63 remote-as 23736
 no auto-summary

no. it is not.

 

this is yours address 114.133.141.63

provider should give you corresponding peering BGP neigbor addres

just like

Serial0/1/0                      58.139.168.170  (your side)

neighbor 58.139.168.169 remote-as 23736  (provider side)

 

preference primary and secondary can be made by weight from your side and provider side

 

 

and dont forget to rate posts

How about the routing?

Should I put routing as below,

 

ip route 0.0.0.0 0.0.0.0 58.139.168.169 210

ip route 0.0.0.0 0.0.0.0 Dialer 1 230

now you have

ip route 0.0.0.0 0.0.0.0 172.27.17.100

I think you dont need

ip route 0.0.0.0 0.0.0.0 58.139.168.169 210

ip route 0.0.0.0 0.0.0.0 Dialer 1 230

 

 

and you will get routes to 172.9.0.0/16 throw BGP (serial or adsl)

 

copy paste here

sh ip route

sh ip bgp

 

Ok, no need the route 

ip route 0.0.0.0 0.0.0.0 58.139.168.169 210

ip route 0.0.0.0 0.0.0.0 Dialer 1 230

because route will go through BGP

but because the dialer 1 is ip negotiated, is it possible to configure BGP on using interface dialer?? 

 

by the way, attached is the log.

 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card