Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Help! OSPF over Frame-Relay Problems...

I have three routers connected to a central router I am using as a frame-relay switch.

Like so:

64.53.18.1

ISP

|

|

(Frame-Switch)

/ \

64.53.18.3 ....................64.53.18.2

West..............................East

I am also running NAT. Before I had the interfaces as int s0/0.DLCI point-to-point and ip ospf network broadcast. That worked fine until I rebooted my routers. I have tried many different things, but finally I am trying the configs below. It still doesn't work now.

I can't even ping the 64.53.18.1,2,3 interfaces!

Here are my configs:

ISP:

!

interface Serial0/0

no ip address

encapsulation frame-relay

no fair-queue

frame-relay lmi-type ansi

!

interface Serial0/0.101 multipoint

description PVC to West, DLCI 101

ip address 64.53.18.1 255.255.255.248

ip ospf network point-to-multipoint

frame-relay interface-dlci 101

!

interface Serial0/0.102 multipoint

description PVC to East, DLCI 102

ip address 64.53.18.1 255.255.255.248

ip ospf network point-to-multipoint

frame-relay interface-dlci 102

!

East:

!

interface Serial0/0

no ip address

ip nat outside

encapsulation frame-relay

frame-relay lmi-type ansi

!

interface Serial0/0.301 multipoint

ip address 64.53.18.2 255.255.255.248

ip ospf network point-to-multipoint

frame-relay interface-dlci 301

!

interface Serial0/0.302 multipoint

description PVC to East, DLCI 302

ip address 64.53.18.2 255.255.255.248

ip ospf network point-to-multipoint

frame-relay interface-dlci 302

!

interface Serial0/1

no ip address

shutdown

clockrate 2000000

!

router ospf 1

log-adjacency-changes

network 24.83.68.0 0.0.0.127 area 61

network 64.53.18.0 0.0.0.7 area 0

West:

!

interface Serial0/0

no ip address

ip nat outside

encapsulation frame-relay

no fair-queue

frame-relay lmi-type ansi

!

interface Serial0/0.201 multipoint

description PVC to ISP, DLCI 201

ip address 64.53.18.3 255.255.255.248

ip ospf network point-to-multipoint

frame-relay interface-dlci 201

!

interface Serial0/0.202 multipoint

description PVC to East, DLCI 202

ip address 64.53.18.3 255.255.255.248

ip ospf network point-to-multipoint

frame-relay interface-dlci 202

!

router ospf 1

log-adjacency-changes

network 64.53.18.0 0.0.0.7 area 0

network 161.73.29.0 0.0.0.63 area 51

!

................

Whenever I try to ping, I either get no ping or something that looks like this:

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 64.53.18.3, timeout is 2 seconds:

.!.!.

Also when I do "sh ip route" I get the following:

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

64.0.0.0/8 is variably subnetted, 3 subnets, 2 masks

O 64.53.18.3/32 [110/64] via 64.53.18.3, 00:05:02, Serial0/0.302

O 64.53.18.1/32 [110/64] via 64.53.18.1, 00:05:02, Serial0/0.302

C 64.53.18.0/29 is directly connected, Serial0/0.301

is directly connected, Serial0/0.302

both "O" paths go through DLCI 302. One should go tru 302 and the other through 301, however.

Please help!

5 REPLIES

Re: Help! OSPF over Frame-Relay Problems...

Hi Asha,

1. I would recommend you to use point-to-point subinterfaces like this:

interface Serial0/0.201 point-to-point

description PVC to ISP, DLCI 201

ip address 64.53.18.1 255.255.255.252

ip ospf network point-to-point

frame-relay interface-dlci 201

2. You ip addresses should be different on each subinterface:

interface Serial0/0.202 point-to-point

description PVC to ISP, DLCI 202

ip address 64.53.18.5 255.255.255.252

ip ospf network point-to-point

frame-relay interface-dlci 202

3. You should reconfigure all three routers similarly.

Don't forget to apply /30 subnets to each point-to-point connection.

Cheers:

Istvan

New Member

Re: Help! OSPF over Frame-Relay Problems...

I am doing a lab and the interfaces must be all kept in the same subnet since I am using ospf... hence the 64.53.18.1, 64.53.18.2, 64.53.18.3 for the three respective routers.

Re: Help! OSPF over Frame-Relay Problems...

In this case you need only one multipoint subinterface in each router with an ip address within the same subnet.

You will need to use the "frame-relay map" command on the multipoint subinterface to manually configure the next-hop - to - DLCI mappings.

Cheers:

Istvan

New Member

Re: Help! OSPF over Frame-Relay Problems...

After I posted I ended up making a point to multipoint interface with both DLCIs like so:

interface Serial0/0.1 multipoint

description PVC to East, DLCI 201 - 202

ip address 64.53.18.3 255.255.255.248

ip ospf network point-to-multipoint

frame-relay interface-dlci 201

frame-relay interface-dlci 202

I don't have the "frame map" command, but now I can ping the other FR interfaces. However, I can't ping the connected LANs. Since I can ping the serial interfaces, do I still need the "frame map" command? Also anyone have any ideas why my NAT doesn't work now. Earlier it did. I don't know if changing to multipoint could have affected it.

(24.83.68.0/25 is the IP block I am using for NAT, 192.168.10.0/23 is the internal IPs)

interface Loopback10

ip address 24.83.68.1 255.255.255.128

ip ospf network point-to-point

!

interface FastEthernet0/0.1

encapsulation dot1Q 1 native

ip address 192.168.11.1 255.255.255.192

ip nat inside

!

interface FastEthernet0/0.10

encapsulation dot1Q 10

ip address 192.168.10.1 255.255.255.0

ip nat inside

!

interface FastEthernet0/0.20

encapsulation dot1Q 20

ip address 192.168.11.65 255.255.255.192

ip nat inside

!

interface FastEthernet0/0.30

encapsulation dot1Q 30

ip address 192.168.11.129 255.255.255.224

ip nat inside

!

!

router ospf 1

log-adjacency-changes

network 24.83.68.0 0.0.0.127 area 61

network 64.53.18.0 0.0.0.7 area 0

!

ip nat pool V1 24.83.68.33 24.83.68.46 netmask 255.255.255.240

ip nat pool Admin 24.83.68.2 24.83.68.30 netmask 255.255.255.224

ip nat inside source list 1 pool V1

ip nat inside source list 10 interface Loopback10 overload

ip nat inside source list 20 interface Loopback10 overload

ip nat inside source list 30 pool Admin

!

access-list 1 permit 192.168.11.0 0.0.0.63

access-list 10 permit 192.168.10.0 0.0.0.255

access-list 20 permit 192.168.11.64 0.0.0.63

access-list 30 permit 192.168.11.128 0.0.0.31

!

!

!

Hall of Fame Super Silver

Re: Help! OSPF over Frame-Relay Problems...

Hello Asha,

you actually have two FR NBMA networks here you need:

a) to use two different IP subnets or the second serial will be a simple backup: this is done on the field but with the idea of moving the cable to the backup interface so the second interface should be configured as the first one but left unconnected.

What you did shouldn't be a correct config even in a lab.

b)

you need the frame-relay map in order to successfully build OSPF adjacencies because that command allows you to add the broadcast keyword that implies the capability to send OSPF multicast hellos out the interface.

If you do you will be able to see the LAN segments

use

sh ip ospf interface

sh ip ospf neighbors

Hope to help

Giuseppe

359
Views
0
Helpful
5
Replies
CreatePlease to create content