Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Help regarding QoS

Hi....

I am new to QoS and need help on configuring the same for 7206 VXR.

My test topology is as follows :

The Emulated router is configured using IXIA traffic generator using the GUI with one port sending the marked and classified traffic and the other port receving this traffic (which is as good as a CE router). 7206 VXR which is my Device under test acts as PE router here. THERE'S NO MPLS COMING INTO PICTURE RIGHT NOW. It's plain QoS Configuration wherein the Tx Port of IXIA is connected to one of the interfaces of 7206 VXR and Rx Port to the other interface of VXR.

CE(Transmitting port of Emulated router sending traffic marked with EF,AF11,AF43 and default)---7206VXR---CE(Receving port of Emulated router receving traffic). On the receving port I should be able to see the statistics of classified traffic which is not happening properly.

As mentioned earlier, I have a CE device(an emulated IXIA traffic generator) marked with EF, AF11, AF43 and Default codepoints. I have classifed and mapped this traffic on my PE router-7206 VXR. But I don't get the expected result i.e. I should be able to receive 100% of EF traffic, low drop in AF11, high drop in AF43 and loss in Default codepoints on the receiving port of Traffic Generator. Instead of this I get loss as equal w.r.t all the codepoints. I think my VXR configuration is going wrong somewhere. Following is my configuration. Would need some help on this as to reckon where exactly I am going wrong??? Would welcome some configuration tips for DSCP based QoS.

My PE Config is as follows :

!

class-map match-all video-broadcast

match ip dscp af43

class-map match-all premium-video

match ip dscp af31

class-map match-all voip-dscp

match ip dscp ef

class-map match-all DefaulTraffic

match ip dscp default

!

!

policy-map voip-n-be

class voip-dscp

priority percent 70

class premium-video

priority percent 5

!

!

!

!

interface GigabitEthernet0/1

ip address 10.1.1.1 255.255.255.0

duplex auto

speed auto

media-type gbic

negotiation auto

!

interface GigabitEthernet0/2

ip address 20.1.1.1 255.255.255.0

duplex auto

speed auto

media-type gbic

negotiation auto

!

interface GigabitEthernet0/3

ip address 30.1.1.1 255.255.255.0

service-policy output voip-n-be

duplex auto

speed auto

media-type gbic

negotiation auto

Regards,

MITHIL

4 REPLIES

Re: Help regarding QoS

Just curious,

you do have CEF configured , right?

ip cef

Vlad

Re: Help regarding QoS

Hi,

some comments:

1) You are not using class video-broadcast in your policy-map. So the traffic will be placed into class class-default and treated as best effort.

2) in the text you write AF11 in the config you match AF31, which one is correct?

3) "priority" comes with a policer. so in case you overload the interface all traffic in class premium-video above 5% will be dropped.

So I would suggests to repeat the test with the following config:

class-map match-all video-broadcast

match ip dscp af43

class-map match-all voip-dscp

match ip dscp ef

class-map match-all premium-video

match ip dscp af11

!class-map match-all class-default

!match any

!-- this is predefined and I just wrote it down to visualize it in the post --

policy-map voip-n-be

class voip-dscp

priority percent 60

class premium-video

bandwidth percent 10

class video-broadcast

bandwidth percent 5

class class-default

fair-queue

random-detect

Adjust the bandwidth percentages to values suitable to support the expected traffic.

"bandwidth" will enable CBWFQ (Class Based Weighted Fair Queueing), which will queue and not drop packets.

All remaining traffic will get fair-queued with WRED, which is usually OK for all applications in the default class.

Hope this helps! Please rate all posts.

Regards, Martin

New Member

Re: Help regarding QoS

HI Martin...

Thanks for ur reply. It helped me a lot.

But even after doing the configuration, I faced some strange problem. The VXR behaved very strange for the load (emulated traffic) from IXIA for different frame sizes. The VXR was passing only the high frame sized traffic of IXIA (say frame size with 1518) and was dropping the low frame size traffic (with frame size of 128 or lower). Hence I changed the approach a bit and used priority queuing. And I got the desired results. Following is the configuration.

access-list 101 permit ip any any dscp ef

access-list 102 permit ip any any dscp af11

access-list 103 permit ip any any dscp af13

access-list 104 permit ip any any dscp default

priority-list 1 protocol ip high list 101

priority-list 1 protocol ip medium list 102

priority-list 1 protocol ip low list 104

priority-list 1 protocol ip normal list 103

interface GigabitEthernet0/3

ip address 30.1.1.1 255.255.255.0

priority-group 1

This is fine for IPv4. But how do I do this for IPv6??? I am not really sure whether u can follow the same approach for IPv6. How do I set priority for a particular traffic class in IPv6. I was highly disppointed reading Section 7 under RFC 2460.

Would be highly thankful for any guidelines on this.

Would make sure that I rate this post with 5 stars :)

Regards,

MITHIL

Re: Help regarding QoS

Hi,

in case you can use the class based approach dscp would be matched in IPv6 packets also. The config for IPv4 and IPv6 is the same, because both use DSCP in the same manner.

Maybe you need another IOS if you have problems with the current one installed. There should be no problems with the config I posted above. But finally it is hard to judge, what went wrong without detailed knowledge about your test setup and further investigation. You did turn on CEF as already posted above?

I would suggest to test the config above for IPv6 and try to get an IOS supporting all the features you need without probs.

Hope this helps! Please rate all posts.

Regards, Martin

193
Views
11
Helpful
4
Replies
CreatePlease to create content