Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Community will be in read-only mode on 12/14/2017 from 12:00 am pacific to 11:30 am.

During this time you will only be able to see content. Other interactions such as posting, replying to questions, or marking content as helpful will be disabled for few hours.

We apologize for the inconvenience while we perform important updates to the Community.

New Member

Help Required for Multiple IP Addresses on Single Interface

Hi,

I want to know can i configure Multiple Public IP's with Secondary command on a Single Interface. Both the IP's are of different ISP's.

Thanks.

9 REPLIES

Re: Help Required for Multiple IP Addresses on Single Interface

Haris,

Yes you can,but its depends upon how you are controlling the traffic.

Goutam

New Member

Re: Help Required for Multiple IP Addresses on Single Interface

Well here's the overview of my scenario. Basicially i have two ADSL WAN connections both with Public IP's. Both the ISP's have given me Public IP pools. Now I want to utilize my Public IP's by Publishing my Webserver, but I want it Published on both the IP Pools. Can you guide me how to configure it?

Re: Help Required for Multiple IP Addresses on Single Interface

Haris,

Are you thinking to publish the Web server Live? Suggesting you to put the server after any security device (ASA/PIX etc.) by NATing with private IP. Also you have two deferent ISP with live IP pool. If you terminate both in a single router (deff interface and/or same interface) and if some how the router starting malfunctioning then you will be in a big trouble. Think redundancy always.

Best of Luck.

Goutam

New Member

Re: Help Required for Multiple IP Addresses on Single Interface

Well the problem is that I have tried NAT but its not working. I have also posted another problem with the topic Problem with NAT in Cisco 2811. Due to that problem I want to do this as an alternative. Further more I have a backup ADSL Modems, and I am terminating both the ADSL Connection on Different ADSL Cards. If my NAT problem is resolved if wouldn't need to publish them with the Public IPs.

Thanks.

New Member

Re: Help Required for Multiple IP Addresses on Single Interface

Here is the actual post.

Hi,

I have a cisco 2811 with two HWIC-1ADSL cards. I have configured Static Nat / Port Forwarding on my Router. The port is forwarded to the Local Webserver. The problem is that the Mapping works fine until the my Webserver redirects the traffic to another Port. Once my Internal Webserver redirects the traffic to some other port the mapping stops working. Here is the running configuration of my router.

interface FastEthernet0/0

ip address 192.168.0.200 255.255.255.0

ip nat inside

ip virtual-reassembly

ip route-cache flow

ip tcp adjust-mss 1452

ip policy route-map CYBER-ROUTE

duplex auto

speed auto

!

interface ATM0/1/0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

pvc 0/35

encapsulation aal5snap

pppoe-client dial-pool-number 2

!

!

interface Dialer2

ip address negotiated

ip mtu 1492

ip nat outside

ip virtual-reassembly

encapsulation ppp

shutdown

dialer pool 2

ppp pap sent-username habib1 password 0 habib1

!

ip route 0.0.0.0 0.0.0.0 Dialer2

!

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

ip nat inside source list 1 interface Dialer2 overload

ip nat inside source static tcp 192.168.0.2 8888 202.38.58.54 8888 extendable

ip nat inside source static tcp 192.168.0.2 9080 202.38.58.54 9080 extendable

!

access-list 1 permit 192.168.0.0 0.0.0.255

Thanks.

Silver

Re: Help Required for Multiple IP Addresses on Single Interface

you have commands pointing to your Dialer 2 interface and it is shutdown?

Silver

Re: Help Required for Multiple IP Addresses on Single Interface

ethernet 0/0

ip address 10.1.1.1 255.255.255.0

ip address 10.2.2.1 255.255.255.0 secondary

This will give you both subnets on the interface.

If your server has 2 nic's then assign an IP on both public's as well as DNS entries for both.

As mentioned in previous posts this is not the recommended method but is a direct answer to your question.

New Member

Re: Help Required for Multiple IP Addresses on Single Interface

Can your resolve the problem that I have posted in my last post regarding NAT?

Thanks.

New Member

Re: Help Required for Multiple IP Addresses on Single Interface

Sorry I posted the configuration with the interface shutdown. But I have checked it with interface up, the Webserver is opening but the redirection is not working. Here is the correct Running Config.

interface FastEthernet0/0

ip address 192.168.0.200 255.255.255.0

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1452

duplex auto

speed auto

!

interface ATM0/1/0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

pvc 0/35

encapsulation aal5snap

pppoe-client dial-pool-number 2

!

interface Dialer2

ip address negotiated

ip mtu 1492

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 2

ppp pap sent-username xx password xxx

!

ip route 0.0.0.0 0.0.0.0 Dialer2

!

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

ip nat inside source static tcp 192.168.0.2 8888 202.38.58.54 8888 extendable

ip nat inside source static tcp 192.168.0.2 9080 202.38.58.54 9080 extendable

!

access-list 1 permit 192.168.0.0 0.0.0.255

The 9080 is the port on which the webserver is running. The 8888 port is the one on which the Webserver redirects when opening some reports. I am getting the problem that when Request from the Internet comes to port 9080 the router redirect the traffic perfectly, however, when my Internal Webserver redirects specific requests to port 8888, the router fails to redirect the traffic to port 8888.

Thanks.

216
Views
0
Helpful
9
Replies
CreatePlease to create content