Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Help setting up my network

Hi everyone,

I am attempting a hands on project to cement several concepts for my CCNA and my MCSA and i am stuck at a certain point. I am implementing this setup within my own network for added functionality and practice. Furthur more i will be using this setup as my lab.

Here is what i have going on: 

ISP---Modem---Cisco 2800 Router---Catalyst 3560G Switch

connected to the switch is a Windows 2012 DHCP ADDS server and all of my client systems.

The intended goal is to make it so the Windows server supplies my DHCP addresses through 3 scopes

10.227.10.1 255.255.255.0 - 10.227.10.100 255.255.255.0

10.227.20.1 255.255.255.0 - 10.227.20.100 255.255.255.0

10.227.30.1 255.255.255.0 - 10.227.30.100 255.255.255.0

I want to split my switch into 3 vlans 

Vlan10 - 10.227.10.1

Vlan20 - 10.227.20.1

Vlan30 - 10.227.30.1

I also need to program the router to so that it works with my modem and the switch in order to access the internet, basically i want to make it so when i try and access the internet from one of my client computers, everything goes through like it should.

The issue i am having is that i know bits and pices of it like for example i need to put the IP helper address on the vlans after i give them an ip address in order to forward the DHCP packets. But the problem is i do not have all the info i need to see the picture as a whole.

My question, is there a guide or walkthrough or can someone wip up a quick config that i can follow to acomplish what im trying to do? I learn best buy following someones instructions and working through them line by line.

Thanks for your help,

Donnie

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Donald,What you need is to

Donald,

What you need is to create a NAT. For that you plug your modem on port Fast 0/0 on your 2800. Configure the port like this:

interface fas 0/0

ip address dhcp

ip nat outside

no shutdown

Then you plug your switch on port Fas 0/1, and use this config:

int fas 0/1

no shutdown

int fas 0/1.10

encapsulation dot 10 [native] (if this will be your native vlan)

ip address 10.227.10.1 255.255.255.0

ip nat inside

interface fas 0/1.20

encapsulation dot 20

ip address 10.227.20.1 255.255.255.0

ip nat inside

interface 0/1.30

encapsulation dot 30

ip address 10.227.30.1 255.255.255.0

ip nat inside

Now configure static routes:

config t

ip route 0.0.0.0 0.0.0.0 fas 0/0

ip access-list extended DONALD

permit ip 10.227.10.0 0.0.0.255

permit ip 10.227.20.0 0.0.0.255

permit ip 10.227.30.0 0.0.0.255

now configure the overload

ip nat source list DONALD inteface fas 0/0 overload

 

Now go on your switch and configure:

conf t

vlan 10

exit

vlan 20

exit

vlan 30

exit

interface vlan 10

ip nat inside

exit

interface vlan 20

ip nat inside

exit

interface vlan 30

ip nat inside

exit

Configure your trunk port on switch:

conf t

interface fas x/x

switchport trunk encapsulation dot1q

switchport mode trunk

switchport trunk native vlan 10 (if you chose to use 10 as the native vlan on Router config)

 

 

Now configure your ports for phones and data:

conf t

int fas x/x

switchport host

switchport access vlan XX (where XX is the VLAN number for Data)

switchport voice vlan XX

 

3 REPLIES

Hi Donnie ,  Below are the

Hi Donnie , 

 Below are the things you need to ensure , before you try to access internet from your Vlans 10 , Vlans 20,Vlan 30

1) DHCP scope with appropriate gateway, GW IP address must be your SVI interface IP address of your switch  , DNS server for your providers . 

2) if you keep your DHCP server on VLAN 10 , use IP-helper address for another two vlan 20 & vlan 30

3) Use L3 connectvity between L3 switch to your router . Like 10.10.10.0/28 . Router with ip address 10.10.10.1 and on your L3 switch use one switch port as L3 port by (no switch port command ) or you can create SVI VLAN 100 and you can use as switch port as access port for VLan 100 , assign IP address either on L3 port or on SVI VLAN 10.10.10.2

4) Point Default route from your L3 Switch to your router ( ip route 0.0.0.0 0.0.0.0 10.10.10.1)

5) From your router point reverse point  for

Vlan 10 , Vlan 20, Vlan 30

ip route 10.227.10.0 255.255.255.0 10.10.10.2

ip route 10.227.20.0 255.255.255.0 10.10.10.2

ip route 10.227.30.0 255.255.255.0 10.10.10.2

6) Configuring PAT overloading to the interface connecting to your internet modem , along with IP nat inside and IP nat outisde command 

 

Let me know if you need any help on this . 

HTH

Sandy

New Member

Donald,What you need is to

Donald,

What you need is to create a NAT. For that you plug your modem on port Fast 0/0 on your 2800. Configure the port like this:

interface fas 0/0

ip address dhcp

ip nat outside

no shutdown

Then you plug your switch on port Fas 0/1, and use this config:

int fas 0/1

no shutdown

int fas 0/1.10

encapsulation dot 10 [native] (if this will be your native vlan)

ip address 10.227.10.1 255.255.255.0

ip nat inside

interface fas 0/1.20

encapsulation dot 20

ip address 10.227.20.1 255.255.255.0

ip nat inside

interface 0/1.30

encapsulation dot 30

ip address 10.227.30.1 255.255.255.0

ip nat inside

Now configure static routes:

config t

ip route 0.0.0.0 0.0.0.0 fas 0/0

ip access-list extended DONALD

permit ip 10.227.10.0 0.0.0.255

permit ip 10.227.20.0 0.0.0.255

permit ip 10.227.30.0 0.0.0.255

now configure the overload

ip nat source list DONALD inteface fas 0/0 overload

 

Now go on your switch and configure:

conf t

vlan 10

exit

vlan 20

exit

vlan 30

exit

interface vlan 10

ip nat inside

exit

interface vlan 20

ip nat inside

exit

interface vlan 30

ip nat inside

exit

Configure your trunk port on switch:

conf t

interface fas x/x

switchport trunk encapsulation dot1q

switchport mode trunk

switchport trunk native vlan 10 (if you chose to use 10 as the native vlan on Router config)

 

 

Now configure your ports for phones and data:

conf t

int fas x/x

switchport host

switchport access vlan XX (where XX is the VLAN number for Data)

switchport voice vlan XX

 

New Member

Hi aedamasceno,Just a few

Hi aedamasceno,

Just a few things i need to clarify

"Configure your trunk port on switch: conf t interface fas x/x switchport trunk encapsulation dot1q switchport mode trunk switchport trunk native vlan 10 (if you chose to use 10 as the native vlan on Router config)"


Just to make sure i am getting this part i am suppose to pick an interface on the switch that is connected to the routers fa 0/1 interface and i need to set that as a trunk port?


"Now configure your ports for phones and data:

conf t

int fas x/x

switchport host

switchport access vlan XX (where XX is the VLAN number for Data)

switchport voice vlan XX"

And with these instructions the FAS x/x is the switch port that i picked to connect to the router correct?

102
Views
0
Helpful
3
Replies
CreatePlease login to create content