cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
398
Views
0
Helpful
3
Replies

Help - Want to pass data from 1 ATM port to another, same Router

bhimebauch
Level 1
Level 1

Hello,

I am trying to send data from GigE1 to ATM1/0 to ATM2/0 to GigE2. My real intent is to send Multicast data, but have since backed out the Mulitcast commands, just focusing on getting ICMP pings to pass. My configuration is as follows:

Current configuration : 1776 bytes

!

version 12.3

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname NGN_ROUTER

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

!

resource policy

!

ip subnet-zero

!

!

ip cef

no ip dhcp use vrf connected

!!

!

no crypto isakmp ccm

!

!!

interface GigabitEthernet0/1

ip address 70.10.0.1 255.0.0.0

ip policy route-map GigE-2-ATM-Forced-Video

duplex auto

speed auto

media-type rj45

no negotiation auto

!

interface GigabitEthernet0/2

no ip address

ip pim sparse-dense-mode

duplex auto

speed auto

media-type rj45

no negotiation auto

!

interface GigabitEthernet0/3

ip address 80.10.0.1 255.0.0.0

duplex auto

speed auto

media-type rj45

no negotiation auto

!

interface ATM1/0

ip address 100.10.0.1 255.0.0.0

no ip redirects

no ip proxy-arp

ip policy route-map ATM-2-ATM-Forced-Video

atm clock INTERNAL

atm sonet stm-1

no atm ilmi-keepalive

pvc 1/32

protocol ip 100.10.0.1

encapsulation aal5snap

!

!

interface ATM2/0

ip address 90.10.0.1 255.0.0.0

no ip redirects

no ip proxy-arp

ip policy route-map ATM-2-GigE-Forced-Video

atm clock INTERNAL

atm sonet stm-1

no atm ilmi-keepalive

pvc 1/32

protocol ip 90.10.0.1

encapsulation aal5snap

!

!

ip classless

!

no ip http server

no ip http secure-server

!

!

!

route-map GigE-2-ATM-Forced-Video permit 10

match interface GigabitEthernet0/1

set ip next-hop 100.10.0.1

!

route-map ATM-2-GigE-Forced-Video permit 10

match interface ATM2/0.1

set ip next-hop 80.10.0.1

!

route-map ATM-2-ATM-Forced-Video permit 10

match interface ATM1/0.1

set ip next-hop 90.10.0.1

!

!

!

!

control-plane

!

!

!

!

!

!

!

line con 0

stopbits 1

line aux 0

stopbits 1

line vty 0 4

login

!

!

end

I'm trying ot force the data from the GigE1 to ATM1/0, then force from ATM1/0 to ATM2/0, then ATM2/0 to GigE2. With this configuration, I am not seeing any data using the show atm traffic.

Can anybody help?

Thanks,

Bruce

3 Replies 3

bhimebauch
Level 1
Level 1

Sorry, all references to GigE2 is actually GigE3

There are some obvious errors in your config.

Firstly, under the ATM interfaces, you have to use the 'protocol ip' command to specify addresses of other devices reachable through the interface, not the local IP address.

Secondly, the 'match interface' command is not required in your route-maps - it will match on packets that are routed out of the specified interface which is not what you want.

Thirdly, in your route-maps, use the 'set ip next-hop' command to specify the IP of a router reachable through the interface, not a local interface IP.

Hope that helps - pls rate the post if it does.

Paresh

Thanks, will try in the morning.

Review Cisco Networking products for a $25 gift card