Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Help with 871w

Wondering if someone can help me out....fairly new to Cisco and I'm trying to do something without knowing if it can actually be done.

I've got a Dlink router that is connected to my ISP. I recently got a Cisco 871w router and want to connect that to the Dlink via the WAN port.

So I've got a network on the DLINK at 192.168.0.x and the Wan port on the Cisco device (F4) has an IP address on this networ via DHCP. What I would like to do is setup the wireless piece on the Cisco router/swich on a separate network, 192.168.1.x and be able to talk to the other network on the Dlink. So far, I've got the wireless piece working but 192.168.0.x doesn't talk to 192.168.1.x. Not sure what I need here...a static route? I've posted the current config:

Current configuration : 3840 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable secret 5

!
no aaa new-model
!
crypto pki trustpoint TP-self-signed-1241142470
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-1241142470
revocation-check none
rsakeypair TP-self-signed-1241142470
!
!
crypto pki certificate chain TP-self-signed-1241142470
certificate self-signed 01
  30820253 308201BC A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 31323431 31343234 3730301E 170D3038 30313230 31333335
  34345A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 32343131
  34323437 3030819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100C8E9 A43AD7B1 1A77D806 1F3387B9 DE9AF20D CC4AB2BD BB2B8B74 CA05D166
  C1DFD084 86771EC2 816E374B 8CE3CE48 292247EE 267DB5CC E4594450 809F714E
  9A37C660 63391F71 4430ABEE E3B1AF52 13C7339C 0B22B4BF 142727F3 288A619E
  794C23EC E9F442B1 B8DE01BE 9BFA1A65 6D1B153C 5F8F26B0 F71E5834 5C1B7388
  93D90203 010001A3 7B307930 0F060355 1D130101 FF040530 030101FF 30260603
  551D1104 1F301D82 1B526F75 7465722E 68736431 2E67612E 636F6D63 6173742E
  6E65742E 301F0603 551D2304 18301680 146527E6 74F6FD07 127EF210 7D4A65B3
  20741A58 4E301D06 03551D0E 04160414 6527E674 F6FD0712 7EF2107D 4A65B320
  741A584E 300D0609 2A864886 F70D0101 04050003 818100C6 A3FF3B0B 8E60480F
  FD008AEE 13F38EA8 14A27889 CE2CB715 C15C5622 A50CB313 D9335866 8083A413
  5F3111A4 D0FF77B2 A6E6A72C A4B326EF 07528AB6 A4081DEC 740C6375 0A859649
  7ED9EA9B 00B87B01 AD001D38 12E2AF93 71AA84F0 AD7F28EF 15532FF2 B5717A2B
  ADF66A84 3C476BA7 EF5C386D A847436C 0081679E B28250
        quit
!
!
!
dot11 ssid CISCOHOME
   vlan 1
   authentication open
   authentication key-management wpa
   wpa-psk ascii 7

!
ip cef
!
!
ip dhcp relay information option
no ip dhcp use vrf connected
!
ip dhcp pool test
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.1
   dns-server 4.2.2.2
!
!
!
multilink bundle-name authenticated
!
!
username bill privilege 15 secret 5
archive
log config
  hidekeys
!
!
!
bridge irb
!
!
interface FastEthernet0
!
interface FastEthernet1
duplex full
speed 10
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
ip address dhcp
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface Dot11Radio0
no ip address
!
encryption vlan 1 mode ciphers tkip
!
ssid CISCOHOME
!
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
channel 2437
station-role root
!
interface Dot11Radio0.1
encapsulation dot1Q 1 native
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Vlan1
no ip address
bridge-group 1
!
interface Vlan100
ip address 192.168.2.1 255.255.255.0
!
interface Vlan2
no ip address
!
interface BVI1
ip address 192.168.1.1 255.255.255.0
!
ip default-gateway 192.168.0.249
ip forward-protocol nd
!
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 600 life 86400 requests 10000
!
!
!
!
!
control-plane
!
bridge 1 protocol ieee
bridge 1 route ip
banner motd ^CEnter and you die^C
!
line con 0
password 7
logging synchronous
login
no modem enable
line aux 0
line vty 0 4
password 7
login
!
scheduler max-task-time 5000

!
webvpn cef
end

1 REPLY
Cisco Employee

Re: Help with 871w

Hello,

The simplest way to make 192.168.0.x and 192.168.1.x to talk to each other is to add a static route on the DLINK for 192.168.1.x subnet and point it to the 871's IP address. While this will enable communication between 192.168.0.x and 192.168.1.x, I am not sure if it will allow your wireless clients to go to internet as the DLINK may not support multiple subnets (for NAT). One option is to interchange the 871 and DLINK (put the 871 in place of DLINK and have it get an IP from the ISP). In that case, the configuration of FastEthernet 4 will remain pretty much the sam except the NAT configuration.

interface FastEthernet4
ip address dhcp
ip nat outside
ip virtual-reassembly
duplex auto
speed auto

Then you can configure the VLAN inteface for 192.168.0x subnet and assign one of the ports on the VLAN.

interface vlan 2

ip address 192.168.0.1 255.255.255.0

ip nat inside

exit

interface Fastethernet 0

switchport access vlan 2

exit

Now you can connect the DLINK's WAN port to the Fastethernet 0 of the 871 and will be able to connect rest of the clients to other ports of the DLINK. If you do not want to disturb the current settings (DLINK is connected to internet), then you can do the following:

interface FastEthernet4
ip address dhcp
ip nat outside
ip virtual-reassembly
duplex auto
speed auto

interface BVI1
ip address 192.168.1.1 255.255.255.0

ip nat inside

access-list 10 permit 192.168.1.0 0.0.0.255

ip nat inside source list 1 interface FastEthernet4 overload

This will ensure that all the wireless clients can initiate communication to 192.168.0.x and will be able to have successful communication. However, 192.168.0.x cannot initiate communication to any wireless clients. All traffic from 192.168.1.x will be NATTED to FastEthernet4 interface IP when exiting 871.

Hope this helps.

Regards,

NT

186
Views
0
Helpful
1
Replies
CreatePlease to create content