Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

help with adsl/wirless config

Hi,

please help.

I am trhing to configure the wireless on my cisco 877w router. the wired lan side of it is working perfectly I just need to get the wireless working. currenty the users can not see the ssid.

how does my config look?

thanks a mill

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Gold

Re: help with adsl/wirless config

From console connection, configure as follows:

no ip dhcp excluded-address 10.10.20.1 10.10.20.10

no ip dhcp pool wireless-pool

no interface Dot11Radio0.1

interface Dot11Radio0

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

interface vlan 1

no ip address

no ip nat inside

no ip virtual-reassembly

interface bvi1

ip address 10.10.10.1 255.255.255.0

ip nat inside

ip tcp adjust-mss 1452

no interface dialer 0

interface dialer 1

no ip tcp adjust-mss 1452

no dialer-group 1

ppp ipcp default route

ip access-list extended 101

no 20

no dialer-list 1

no ip route 0.0.0.0 0.0.0.0 Dialer1

interface range fa0 - 3

switchport portfast

Hope this helps, please rate post if it does!

19 REPLIES
Hall of Fame Super Gold

Re: help with adsl/wirless config

Please specify if you want the wireless PCs on a different subnet as your config seems to indicate, or you're fine with them being in the same subnet as the wired PCs.

Community Member

Re: help with adsl/wirless config

I dont want them to get a different IP. I want them to get an address from the dhcp pool lan-pool if possible.

thanks

Hall of Fame Super Gold

Re: help with adsl/wirless config

From console connection, configure as follows:

no ip dhcp excluded-address 10.10.20.1 10.10.20.10

no ip dhcp pool wireless-pool

no interface Dot11Radio0.1

interface Dot11Radio0

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

interface vlan 1

no ip address

no ip nat inside

no ip virtual-reassembly

interface bvi1

ip address 10.10.10.1 255.255.255.0

ip nat inside

ip tcp adjust-mss 1452

no interface dialer 0

interface dialer 1

no ip tcp adjust-mss 1452

no dialer-group 1

ppp ipcp default route

ip access-list extended 101

no 20

no dialer-list 1

no ip route 0.0.0.0 0.0.0.0 Dialer1

interface range fa0 - 3

switchport portfast

Hope this helps, please rate post if it does!

Community Member

Re: help with adsl/wirless config

if I apply this config it will break my wired clients?

here is the current config. the users can now associate but can not get an IP?

Hall of Fame Super Gold

Re: help with adsl/wirless config

Nothing will break. Please apply *in full* the configuration per my previous, from a console connection.

In addition to that, also configure:

no ip dhcp-server 10.10.10.1

Community Member

Re: help with adsl/wirless config

I dont have console access I am telnet on and also have http access

Hall of Fame Super Gold

Re: help with adsl/wirless config

Then you have to apply configuration changes with an editor to your configuration file.

for the "no" commands, just remove the whole line.

After that copy said file in the router as startup-config via tftp, http, or ftp server, once you verify the correct file is in there, reload router.

Community Member

Re: help with adsl/wirless config

is there no other way of getting this working?

Hall of Fame Super Gold

Re: help with adsl/wirless config

No, the problem is that you may active nat translations preventing you from changing the addresses as required.

You can try "clear ip nat" commands, but the sure way is the one I've described before.

Community Member

Re: help with adsl/wirless config

there is not nat translations.

from your config how will wired clients get an ip address and how will the router nat for those?

Hall of Fame Super Gold

Re: help with adsl/wirless config

Then you can apply the config changes straight from telnet.

Both vlan1 and radio interface are bridged under BVI1 and get addresses per dhcp pool that matches router address for said interface

Community Member

Re: help with adsl/wirless config

i dont have the option

ppp ipcp default route

under int dialer 1 interface config?

and how will the router know how to route to default gateway by doing

no ip route 0.0.0.0 0.0.0.0 Dialer1

and with a no dialer list command what will allow IP out?

Hall of Fame Super Gold

Re: help with adsl/wirless config

Leave the defaulr route change out. It is not essential and your IOS may be too old to support that.

No dialer list is needed for PPPoE connections. The connection is open all the time.

Community Member

Re: help with adsl/wirless config

this is the current config now so you think this should work now for wireless and wired clients?

439
Views
0
Helpful
19
Replies
CreatePlease to create content