Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Help with EIGRP and 2 routers.

I need help with this connection as i cannot get it to work even when i have entered the correct commands or so i think i have.

I cannot get the routers EDGE and REMOTE to PING each other. When i configured frame relay they worked fine. But when i setup EIGRP it stopped them from communicating. Can anyone help please ive been at this for around 8 hours now and im about to give up as i dont know were else to turn.

Im getting this error also know when i setup EIGRP on both routers

%DUAL-5-NBRCHANGE: IP-EIGRP 100: Neighbor 205.100.80.2 (Serial0/2/0) is down: retry limit exceeded

%DUAL-5-NBRCHANGE: IP-EIGRP 100: Neighbor 205.100.80.2 (Serial0/2/0) is up: new adjacency

Here is my network.network.PNG

Here are the IP addresses

configs.PNG

configs 2.PNG

Please help

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Help with EIGRP and 2 routers.

Paul,

You have an incorrect mapping on the remote router:

Edge:

Serial0/2/0 (up): ip 205.100.80.2 dlci 102, static, broadcast, CISCO, status defined, active

Remote:

Serial0/0/0 (up): ip 200.100.80.1 dlci 201, static, broadcast, CISCO, status defined, active

On the remote router, remove your mapping and add this:

int s0/0/0

no frame-relay map ip 200.100.80.1 201 broadcast

frame-relay map ip 205.100.80.1.2 201 broadcast

That should fix it...

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
13 REPLIES

Help with EIGRP and 2 routers.

Please post the configs of the Edge and remote routers...

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
Hall of Fame Super Blue

Help with EIGRP and 2 routers.

Paul

Can you ping between the routers ?

Can you post the EIGRP config from both routers ?

Jon

New Member

Help with EIGRP and 2 routers.

EDGE Router Config

Router#sho

Router#show ru

Router#show running-config

Building configuration...

Current configuration : 950 bytes

!

version 12.4

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname Router

!

!

!

!

!

!

!

!

!

!

!

!

ip ssh version 1

!

!

spanning-tree mode pvst

!

!

!

!

interface FastEthernet0/0

ip address 200.100.90.1 255.255.255.252

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

shutdown

!

interface Serial0/0/0

ip address 172.18.20.10 255.255.255.252

clock rate 64000

!

interface Serial0/0/1

no ip address

shutdown

!

interface Serial0/2/0

bandwidth 64

ip address 205.100.80.1 255.255.255.252

encapsulation frame-relay

frame-relay map ip 205.100.80.2 102 broadcast

!

interface Serial0/2/1

no ip address

shutdown

!

interface Vlan1

no ip address

shutdown

!

router eigrp 100

network 172.18.20.0 0.0.0.255

network 205.100.80.0 0.0.0.3

auto-summary

!

ip classless

!

!

!

!

!

!

!

line con 0

!

line aux 0

!

line vty 0 4

login

!

!

!

end

Router#

%DUAL-5-NBRCHANGE: IP-EIGRP 100: Neighbor 205.100.80.2 (Serial0/2/0) is down: retry limit exceeded

%DUAL-5-NBRCHANGE: IP-EIGRP 100: Neighbor 205.100.80.2 (Serial0/2/0) is up: new adjacency


REMOTE Router config

Router#

Router#

Router#show

Router#show ru

Router#show running-config

Building configuration...

Current configuration : 846 bytes

!

version 12.4

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname Router

!

!

!

!

!

!

!

!

!

!

!

!

ip ssh version 1

!

!

spanning-tree mode pvst

!

!

!

!

interface FastEthernet0/0

ip address 172.18.24.1 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 205.100.100.2 255.255.255.252

duplex auto

speed auto

!

interface Serial0/0/0

bandwidth 64

ip address 205.100.80.2 255.255.255.252

encapsulation frame-relay

frame-relay map ip 200.100.80.1 201 broadcast

frame-relay interface-dlci 201

!

interface Serial0/0/1

no ip address

shutdown

!

interface Vlan1

no ip address

shutdown

!

router eigrp 100

network 205.100.80.0 0.0.0.3

auto-summary

!

ip classless

!

!

!

no cdp run

!

!

!

!

!

line con 0

!

line aux 0

!

line vty 0 4

login

!

!

!

end

Router#

%DUAL-5-NBRCHANGE: IP-EIGRP 100: Neighbor 205.100.80.1 (Serial0/0/0) is down: retry limit exceeded

%DUAL-5-NBRCHANGE: IP-EIGRP 100: Neighbor 205.100.80.1 (Serial0/0/0) is up: new adjacency

%DUAL-5-NBRCHANGE: IP-EIGRP 100: Neighbor 205.100.80.1 (Serial0/0/0) is down: retry limit exceeded

Help with EIGRP and 2 routers.

Paul,

You're missing your dlci on interface Serial0/2/0 on your edge router. Can you put "frame-relay interface-dlci 102" under that interface and try again?

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
New Member

Help with EIGRP and 2 routers.

Sorry for not being that good as Cisco but how do i actually do that, my brain has had it today after 9 hours of this.

Thanks

Help with EIGRP and 2 routers.

Under your edge router:

int s0/2/0

frame-rela interface-dlci 102

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
New Member

Re: Help with EIGRP and 2 routers.

Ok i did that before you actually posted but thanks for helping as i requested.

Anyhow here are my configs again and i still cannot ping from EDGE to REMOTE

I have also attached my packet tracer file to my original thread starting post if anybody would like to take alook at it for me please. I have a serious headache after 11 hours trying to get this to work. I have to go to bed now as i can hardly look at the screen anymore. Thankyou for helping.

EDGE

Router#show run

Router#show running-config

Building configuration...

Current configuration : 982 bytes

!

version 12.4

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname Router

!

!

!

!

!

!

!

!

!

!

!

!

ip ssh version 1

!

!

spanning-tree mode pvst

!

!

!

!

interface FastEthernet0/0

ip address 200.100.90.1 255.255.255.252

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

shutdown

!

interface Serial0/0/0

ip address 172.18.20.10 255.255.255.252

clock rate 64000

!

interface Serial0/0/1

no ip address

shutdown

!

interface Serial0/2/0

bandwidth 64

ip address 205.100.80.1 255.255.255.252

encapsulation frame-relay

frame-relay map ip 205.100.80.2 102 broadcast

frame-relay interface-dlci 102

!

interface Serial0/2/1

no ip address

shutdown

!

interface Vlan1

no ip address

shutdown

!

router eigrp 100

network 172.18.20.0 0.0.0.255

network 205.100.80.0 0.0.0.3

auto-summary

!

ip classless

!

!

!

!

!

!

!

line con 0

!

line aux 0

!

line vty 0 4

login

!

!

!

end

Router#

%DUAL-5-NBRCHANGE: IP-EIGRP 100: Neighbor 205.100.80.2 (Serial0/2/0) is down: retry limit exceeded

%DUAL-5-NBRCHANGE: IP-EIGRP 100: Neighbor 205.100.80.2 (Serial0/2/0) is up: new adjacency

REMOTE

Router#en

Router#enable

Router#show

Router#show ru

Router#show running-config

Building configuration...

Current configuration : 846 bytes

!

version 12.4

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname Router

!

!

!

!

!

!

!

!

!

!

!

!

ip ssh version 1

!

!

spanning-tree mode pvst

!

!

!

!

interface FastEthernet0/0

ip address 172.18.24.1 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 205.100.100.2 255.255.255.252

duplex auto

speed auto

!

interface Serial0/0/0

bandwidth 64

ip address 205.100.80.2 255.255.255.252

encapsulation frame-relay

frame-relay map ip 200.100.80.1 201 broadcast

frame-relay interface-dlci 201

!

interface Serial0/0/1

no ip address

shutdown

!

interface Vlan1

no ip address

shutdown

!

router eigrp 100

network 205.100.80.0 0.0.0.3

auto-summary

!

ip classless

!

!

!

no cdp run

!

!

!

!

!

line con 0

!

line aux 0

!

line vty 0 4

login

!

!

!

end

Router#

%DUAL-5-NBRCHANGE: IP-EIGRP 100: Neighbor 205.100.80.1 (Serial0/0/0) is down: retry limit exceeded

%DUAL-5-NBRCHANGE: IP-EIGRP 100: Neighbor 205.100.80.1 (Serial0/0/0) is up: new adjacency



Re: Help with EIGRP and 2 routers.

How do you have your frame-relay switch set up? The port that the edge router connect to needs to have a mapping for port 102 and the remote router port should be configured for 201. I can't tell from your pic above if that's the case. Otherwise, the config of both routers look correct now...

Can you post from both routers:

show frame-relay pvc

show frame-relay map

Most of us don't use packet tracer, so I won't be able to help you with that unfortunately.

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
New Member

Help with EIGRP and 2 routers.

EDGE

show frame-relay pvc

Router#show frame-relay pvc

PVC Statistics for interface Serial0/2/0 (Frame Relay DTE)

DLCI = 102, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/2/0

input pkts 14055       output pkts 32795        in bytes 1096228

out bytes 6216155      dropped pkts 0           in FECN pkts 0

in BECN pkts 0         out FECN pkts 0          out BECN pkts 0

in DE pkts 0           out DE pkts 0

out bcast pkts 32795   out bcast bytes 6216155



show frame-relay map

Router#show frame-relay map

Serial0/2/0 (up): ip 205.100.80.2 dlci 102, static, broadcast, CISCO, status defined, active

REMOTE

show frame-relay pvc

Router#show frame-relay pvc

PVC Statistics for interface Serial0/0/0 (Frame Relay DTE)

DLCI = 201, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0/0

input pkts 14055       output pkts 32795        in bytes 1096228

out bytes 6216155      dropped pkts 0           in FECN pkts 0

in BECN pkts 0         out FECN pkts 0          out BECN pkts 0

in DE pkts 0           out DE pkts 0

out bcast pkts 32795   out bcast bytes 6216155



show frame-relay map

Router#show frame-relay map

Serial0/0/0 (up): ip 200.100.80.1 dlci 201, static, broadcast, CISCO, status defined, active

Thankyou, i am going to bed now.

Re: Help with EIGRP and 2 routers.

Paul,

You have an incorrect mapping on the remote router:

Edge:

Serial0/2/0 (up): ip 205.100.80.2 dlci 102, static, broadcast, CISCO, status defined, active

Remote:

Serial0/0/0 (up): ip 200.100.80.1 dlci 201, static, broadcast, CISCO, status defined, active

On the remote router, remove your mapping and add this:

int s0/0/0

no frame-relay map ip 200.100.80.1 201 broadcast

frame-relay map ip 205.100.80.1.2 201 broadcast

That should fix it...

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
New Member

Re: Help with EIGRP and 2 routers.

Ok what are you actually doing there? Are you placing one on a sub interface ie:

frame-relay map ip

205.100.80.1.2 201 broadcast.

The remote serial 0/0/0 is showing an IP address of 205.100.80.2 in the GUI so were is the 200.100.80.1 coming from? I do not remember putting that in?

My Apologies as im quite new to this and sometimes having an explanation off somebody like yourself helps me more to understand better than any video could explain.

Thankyou Jon.

(The bold button is not working btw)

Re: Help with EIGRP and 2 routers.

Take a look at this:

http://www.ciscopress.com/articles/article.asp?p=170741&seqNum=4

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
New Member

Re: Help with EIGRP and 2 routers.

Ok thanks Jon, i also went back and tried another way, i got it working also by using No auto summary in Core Edge and Remote routers.

392
Views
0
Helpful
13
Replies