Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Help with load balance

Dear All,

First i want first to thank you for all support you give us over this wonderful website

second i am having a problem of load balance traffic over two WAN links connecting our 2 cisco 7600 routers,

as i just knew that 7600 is not supporting per packet load sharing only per destination and as per our monitoring tools that one link is underutulized the other is overutilized

i tried per port load balance and it does not work as we hope.

please help , thanks

Ali

10 REPLIES
Purple

Help with load balance

Hi,

which routing protocol are you using  and what type of WAN links are these ?

Regards.

Alain

Don't forget to rate helpful posts.
New Member

Help with load balance

Dear Cadet

thanks for your reply

i am not using routing protocol i am using static routing and the interface type is ethernet with subinterfaces .

Regards

Ali

Hall of Fame Super Silver

Help with load balance

Ali

I am not clear what you describe as per port load  balance. Perhaps you can show us the details of what you tried and we  might then be able to give suggestions of other things to try?

With static routes it should be possible to have load balancing, if there is sufficient variety of source addresses and of destination addresses. If we saw the specifics of what you have configured we might be able to make suggestions about this also.

HTH

Rick

New Member

Help with load balance

Dear Richard,

what i meant by per port load balane is to use below command

ip cef load-sharing algorithm include-ports source destination

to allow hash to include port number in it is calculation

and the configuration on both 7600 are simple

7600_A

interface GigabitEthernet1/1

no ip address

!

interface GigabitEthernet1/1.55

encapsulation dot1Q 55

ip address 10.0.0.1 255.255.255.252

!

interface GigabitEthernet1/2

no ip address

!

interface GigabitEthernet1/2.66

encapsulation dot1Q 66

ip address 10.0.0.5 255.255.255.252

!
ip route 192.168.10.0 255.255.255.0 10.0.0.2

ip route 192.168.10.0 255.255.255.0 10.0.0.6

7600_B

interface GigabitEthernet1/1

no ip address

!

interface GigabitEthernet1/1.83

encapsulation dot1Q 83

ip address 10.0.0.2 255.255.255.252

!

interface GigabitEthernet1/2

no ip address

!

interface GigabitEthernet1/2.104

encapsulation dot1Q 104

ip address 10.0.0.6 255.255.255.252

!

ip route 0.0.0.0 0.0.0.0 10.0.0.1

ip route 0.0.0.0 0.0.0.0 10.0.0.5

Hall of Fame Super Silver

Help with load balance

Ali

Thank you for the additional information. I do not see any particular problem with the parts of the configuration that you posted. Assuming that the interfaces are up I would expect that both static routes should be in the routing table. Could you post the output of show ip interface brief and of show ip route so that we can verify that both default routes have been put into the routing table?

If there is some diversity of source address and some diversity of destination address then I would expect some traffic on each interface. Can you tell us how many source addresses and how many destination addresses are being used?

HTH

Rick

New Member

Help with load balance

Dear Richard,

the problem i has that my users open there application for whole day which make them use one socket address all the day

and as you know 7600 are not supporting per packet load balance that result in one of the wan links are always overutilized and the other is underutilized preventing us from using all available bandwidth and also has congestion although we have link that is not untilized

what i am looking for is better way to load balance traffic without need to use PBR,

Hall of Fame Super Silver

Help with load balance

Ali

If CEF is enabled then load balancing should be per flow. And this should allow use of both links if there is not some issue. So please answer my questions in the previous response and post the outputs that I requested. This might help us to identify why only one interface is being used.

HTH

Rick

New Member

Help with load balance

Dear Richard,

both interfaces are working my issue is not one interface is working and other is idle my problem that there is sometimes first link is congested with full bandwidth 4M and in the same time the second link is reading 355K and users start to feel slow and other time the second reach 4M and first is less than 1M my problem is how to load balance over two link to allow better use of bandwidth

sorry for inconvince

Hall of Fame Super Silver

Help with load balance

Ali

Thank you for the additional explanation. This is a very different issue from what I thought it was in the original post. I thought that you were saying that load balancing was not working. But you are saying that load balance does work but not quite the way in which you want it to do.

With IP CEF the load balancing is by flow. And some flows might carry heavier traffic than some others. So it is normal that with CEF load balancing the balance may not be equal on  both links. Cisco does have a feature that does load balancing where it can consider the load on each link. It is called Performance Routing. It is a bit complex and I do not know how well it would work in a simple topology such as you have described with two routers and two links. But you might take a look at it and see if it is worth thring in your situation.

HTH

Rick

New Member

Help with load balance

Dear Richard,

thank you very much for your support in this case and i knew this feature but i have no idea how it could be implemented on my situation and also i feel it is complicated but any way i will have a look on what this feature could help me

thank you again for your support

Ali

473
Views
0
Helpful
10
Replies
CreatePlease login to create content