Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Help with T1 p2p issue

We are having problem getting our point-to-point T1 connection up and running for a while now. Our service provider ran test on the circuit, but found nothing wrong. The two routers we are using are Cisco 2821 (Site A) and Cisco 2610XM (Site B). Below are the configuration and relevant information:

Site A: Cisco 2821

!

controller T1 0/1/0

framing esf

linecode b8zs

channel-group 0 timeslots 1-24

!

!

interface Multilink1

ip address 192.168.0.103 255.255.255.0

ip tcp header-compression iphc-format

no cdp enable

ppp multilink

ppp multilink fragment delay 10

ppp multlink interleave

ppp multilink group 1

ppp service-policy output voice_policy

ip rtp header-compression iphc-format

!

!

interface Serial0/1/0:0

bandwidth 1540

no ip address

encapsulation ppp

fair-queue

ppp multilink

ppp multilink group 1

!

Site B: Cisco 2610XM

!

controller T1 0/0

framing esf

linecode b8zs

channel-group 0 timeslots 1-24

!

!

interface Multilink1

ip address 192.168.0.102 255.255.255.0

ip tcp header-compression iphc-format

no cdp enable

ppp multilink

ppp multilink fragment delay 10

ppp multlink interleave

ppp multilink group 1

ppp service-policy output voice_policy

ip rtp header-compression iphc-format

!

!

interface Serial0/0:0

bandwidth 1540

no ip address

encapsulation ppp

fair-queue

ppp multilink

ppp multilink group 1

!

The output for 'show interface' on Serial0/1/0:0 is:

Serial0/1/0:0 is up, line protocol is down

Hardware is GT96K Serial

MTU 1500 bytes, BW 1540 Kbit, DLY 20000 usec,

reliability 128/255, txload 1/255, rxload 1/255

Encapsulation PPP, LCP REQsent, multilink Closed, loopback not set

Keepalive set (10 sec)

Last input 1d18h, output 00:00:01, output hang never

Last clearing of "show interface" counters 1w0d

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: weighted fair

Output queue: 0/1000/64/0 (size/max total/threshold/drops)

Conversations 0/1/256 (active/max active/max total)

Reserved Conversations 0/0 (allocated/max allocated)

Available Bandwidth 1155 kilobits/sec

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

2680 packets input, 61640 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

1611885 input errors, 1611881 CRC, 787474 frame, 437505 overrun, 0 ignored, 1181161 abort

137393 packets output, 4104436 bytes, 0 underruns

0 output errors, 0 collisions, 13612 interface resets

0 output buffer failures, 0 output buffers swapped out

14 carrier transitions

Timeslot(s) Used:1-24, SCC: 0, Transmitter delay is 0 flags

The output for 'show interface' on Serial0/0:0 is:

Serial0/0:0 is up, line protocol is down

Hardware is PowerQUICC Serial

MTU 1500 bytes, BW 1540 Kbit, DLY 20000 usec,

reliability 184/255, txload 1/255, rxload 1/255

Encapsulation PPP, LCP Listen, multilink Closed, loopback not set

Keepalive set (10 sec)

Last input never, output 00:00:28, output hang never

Last clearing of "show interface" counters 1d16h

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: weighted fair

Output queue: 0/1000/64/0 (size/max total/threshold/drops)

Conversations 0/1/256 (active/max active/max total)

Reserved Conversations 0/0 (allocated/max allocated)

Available Bandwidth 1155 kilobits/sec

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

0 packets input, 0 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 8952 giants, 0 throttles

11807 input errors, 667 CRC, 4867 frame, 0 overrun, 0 ignored, 6273 abort

29180 packets output, 875400 bytes, 0 underruns

0 output errors, 0 collisions, 7819 interface resets

0 output buffer failures, 0 output buffers swapped out

3 carrier transitions

Timeslot(s) Used:1-24, SCC: 0, Transmitter delay is 0 flags

13 REPLIES
Silver

Re: Help with T1 p2p issue

You have one side running IP TCP Header compression and also IP RTP header compression and the other side is not. Try setting both sides identical to each other....

New Member

Re: Help with T1 p2p issue

Both sides are running the tcp header compression and rtp header compression.

Re: Help with T1 p2p issue

yes your both side configuration looks identical... will you check the debug output for the same...but debug is very resource utilization process so keep this in mind

devang

Silver

Re: Help with T1 p2p issue

Yes, sorry missed that one.. I also see that both sides are taking excessive errirs. Is this T-1 a fully provisioned T-1 with 24 DS0's? Or should you only be using a few timeslots on it. Possibly the need to scale back the timeslots to what the T-1 may be provisioned for. You can do a show controller T1 for further details on the line...

New Member

Re: Help with T1 p2p issue

It's a full T-1 line. I did a show controller T1 and it is showing

T1 0/0 is up.

Applique type is Channelized T1

Cablelength is long gain36 0db

No alarms detected.

alarm-trigger is not set

Soaking time: 3, Clearance time: 10

AIS State:Clear LOS State:Clear LOF State:Clear

Version info Firmware: 20051006, FPGA: 20, spm_count = 0

Framing is ESF, Line Code is B8ZS, Clock Source is Line.

CRC Threshold is 320. Reported from firmware is 320.

Data in current interval (109 seconds elapsed):

0 Line Code Violations, 0 Path Code Violations

0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

.

.

.

Total Data (last 24 hours)

2 Line Code Violations, 188 Path Code Violations,

5 Slip Secs, 0 Fr Loss Secs, 2 Line Err Secs, 4 Degraded Mins,

9 Errored Secs, 0 Bursty Err Secs, 2 Severely Err Secs, 0 Unavail Secs

New Member

Re: Help with T1 p2p issue

Could all these errors caused by faulty hardware? If so, how would I go about testing what's faulty?

Silver

Re: Help with T1 p2p issue

Yes you may have faulty hardware. Try providing a loopback to each side. If the routers see the loops good the line should come up up looped. Also I see that the LBO on one T-1 is long. How far away is the router from telco demarcation point? Plus you only showed one side of SHOW CONTROLLER T1. What does the other side look like? Another thing to try is to strip the configuration down. Do not use Multilink , just use a straight serial link with HDLC encapsulation. If the T-1 is a point to point then stripping the config will not matter for now. Just see if the line comes up. If it does then start to change the configs and make them PPP then start adding your compression and attributes to the interfaces.....Good Luck...

New Member

Re: Help with T1 p2p issue

I just put it into loopback on each side and the line is still down and looped. The SHOW CONTROLLER T1 on the other side looks similar, it has a bunch of path code violations. AT&T hasn't been much help with this problem either.

Silver

Re: Help with T1 p2p issue

If both sides see the loop then the show interface serial will show you looped... If they do not see the loop then you probably have an issue with the hardware on the router. Try looping the T-1 towards the carrier to the remote site and see if the loop is good. Do the same for the other side as well. Also try what I mentioned about stripping the config down...

New Member

Re: Help with T1 p2p issue

I tried stripping the config down to bare minimum with no luck. Seems like only one of the sides is not seeing the loop and it just my luck that it's the remote side. Is there anything else I can try to narrow down what's faulty?

Thanks for all your help so far.. it's been very helpful.

Silver

Re: Help with T1 p2p issue

At this stage in the game the only thing you can do is reverify the cabling from the telco demark to the router at the remote end. If that is OK then you probably have faulty eq. at the remote end. You will need to have it repaired or replaced...Good Luck..

New Member

Re: Help with T1 p2p issue

I maybe missing something, but i don't see any indication if one side of the t-1 is providing clock. i.e. clock source (line or internal) In our implementation the router at the main office the t-1 is set to internal and the remote office t-1 set to line.

New Member

Re: Help with T1 p2p issue

Both sides are set to line as the clock source. There was nothing wrong with configuration, it was just a bad router on the other end. We ended up swapping out the router at the remote side and it's back up and running again.

192
Views
0
Helpful
13
Replies
CreatePlease login to create content