Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
Bronze

Help with Tunneling over Private MPLS Cloud

Hey All,

There's a design requirement in our carrier-provided MPLS mesh to have certain sites tunnel IP traffic to other sites to make traffic flow transparent to the mesh. My initial line of thinking is just a basic GRE tunnel between the two sites, with static routing to route the required data over the tunnel. I've used GRE before but for the life of me I cannot get a basic tunnel to work. Here's a basic config:

Node 1:

interface Tunnel0

ip address 192.168.93.1 255.255.255.252

no ip route-cache

no ip mroute-cache

keepalive 5 4

tunnel source Vlan250 (has IP of 10.150.250.2)

tunnel destination 192.168.92.1

Node 2:

interface Tunnel0

ip address 192.168.93.2 255.255.255.252

no ip route-cache

no ip mroute-cache

keepalive 5 4

tunnel source FastEthernet0/0.2 (has IP of 192.168.92.1)

tunnel destination 10.150.250.2

But unfortunately my Tunnel0 interfaces show as Up/Down under "sh ip int brief." I've attempted changing MTU sizes on both ends to 1440 to see if that cleared the issue. It did not and I'm still not able to pass IP traffic over the Tunnel interface. Does anyone know how to get this basic GRE tunneling functional?

Thanks,

-Mike

http://cs-mars.blogspot.com

2 REPLIES

Re: Help with Tunneling over Private MPLS Cloud

Sorry I can't give you commands to enter, but I was just reviewing GRE this morning and found a good link on setting it up. I hope it helps.

PS Your blog is excellent, I ran across it a few weeks ago.

New Member

Re: Help with Tunneling over Private MPLS Cloud

Presumably, 192.168.92.1 and 10.150.150.2 know how to get to one another? And there's no ACL denying GRE traffic either on your hardware or your provider's WAN? And what happens if you drop the keepalive statement? Is it possible that the keepalive traffic is dying somewhere, so the router is incorrectly marking down the tunnel interface?

113
Views
0
Helpful
2
Replies
CreatePlease to create content