Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

High CPU utilization by show run

Hi,

I have a 7613 with redundant RSP720-3C-GE. It worked normaly.I run OSPF and when enter "show run" the process cpu raise to 99 percent. In "show proc cpu" I see "Virtual Exec" up to 99%.

This is "sh ver":

Cisco IOS Software, c7600rsp72043_rp Software (c7600rsp72043_rp-ADVIPSERVICES-M)
, Version 12.2(33)SRD2a, RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2009 by Cisco Systems, Inc.
Compiled Fri 17-Jul-09 19:13 by prod_rel_team

ROM: System Bootstrap, Version 12.2(33r)SRD2, RELEASE SOFTWARE (fc1)
BOOTLDR: Cisco IOS Software, c7600rsp72043_rp Software (c7600rsp72043_rp-ADVIPSE
RVICES-M), Version 12.2(33)SRD2a, RELEASE SOFTWARE (fc2)

Router uptime is 28 weeks, 2 days, 22 hours, 32 minutes
Uptime for this control processor is 28 weeks, 2 days, 22 hours, 31 minutes
System returned to ROM by  power cycle (SP by power on)
System restarted at 10:30:55 UTC Wed Feb 3 2010
System image file is "sup-bootdisk:c7600rsp72043-advipservices-mz.122-33.SRD2a.b
in"
Last reload type: Normal Reload

Cisco CISCO7613 (M8500) processor (revision 1.1) with 851968K/65536K bytes of me
mory.
Processor board ID SAL1318PE5X
BASEBOARD: RSP720
CPU: MPC8548_E, Version: 2.0, (0x80390020)
CORE: E500, Version: 2.0, (0x80210020)
CPU:1200MHz, CCB:400MHz, DDR:200MHz,
L1:    D-cache 32 kB enabled
        I-cache 32 kB enabled

Last reset from power-on
1 SIP-200 controller (2 ATM)(2 POS)(1 Channelized OC3/STM-1).
62 Virtual Ethernet interfaces
92 FastEthernet interfaces
100 Gigabit Ethernet interfaces
8 Ten Gigabit Ethernet interfaces
2 ATM interfaces
2 Packet over SONET interfaces
1 Channelized STM-1 port
3964K bytes of non-volatile configuration memory.

507024K bytes of Internal ATA PCMCIA card (Sector size 512 bytes).
Configuration register is 0x2102

This is "show mem":

                    Head        Total(b)        Used(b)        Free(b)        Lowest(b)     Largest(b)
Processor    ED077E8   758089752   222822380   535267372   522767284   524208272
      I/O        3C000000    67108864    37129500    29979364    25888112    29903612

And no debuging on.

This is "show run" output:

Building configuration...

Current configuration : 29906 bytes
!
! Last configuration change at 08:54:44 UTC Sat Aug 21 2010 by admin
! NVRAM config last updated at 19:15:16 UTC Tue Aug 17 2010 by admin
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service counters max age 10
!
hostname Router
!
boot-start-marker
boot system flash sup-bootdisk:c7600rsp72043-advipservices-mz.122-33.SRD2a.bin
boot-end-marker
!
no logging console
enable secret 5 $1$rRu8$VDmoiBeHUsuF4p4yP4Ha4.
!
no aaa new-model
ip subnet-zero
ip source-route
ip vrf L3MPLS
rd 65171:110
route-target export 65171:110
route-target import 65171:110
!
ip vrf bahma
rd 65171:602
route-target export 65171:602
route-target import 65171:602
!
!
!
ip multicast-routing
no ip domain lookup
!
!
ipv6 unicast-routing
ipv6 mfib hardware-switching replication-mode ingress
!
!
mls ip multicast flow-stat-timer 9
mls flow ip interface-full
no mls flow ipv6
mls qos
mls cef error action reset
multilink bundle-name authenticated
mpls label protocol ldp
!
!
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree vlan 1-1000 priority 4096
module clear-config
!
module provision 1 first-insert
diagnostic cns publish cisco.cns.device.diag_results
diagnostic cns subscribe cisco.cns.device.diag_commands
username admin privilege 15 password 0 omited
!
redundancy
main-cpu
  auto-sync running-config
mode sso
!
controller SONET 6/2/0
ais-shut
framing sonet
clock source line
!
vlan internal allocation policy ascending
vlan dot1q tag native
vlan access-log ratelimit 2000
!
!
!
class-map match-all AnyTrafficCM
  match access-group 101
!
policy-map 4M
  class AnyTrafficCM
    police cir 4096000
     exceed-action drop
!
pseudowire-class MPLS
encapsulation mpls
!
l2 vfi Blue autodiscovery
vpn id 701
!
l2 vfi PTMP autodiscovery
vpn id 702
!
!
!
!
!
!
interface Loopback0
ip address 192.168.110.1 255.255.255.255
ip router isis
!
interface Loopback111
ip address 192.168.111.111 255.255.255.255
!


!
router ospf 98
log-adjacency-changes
redistribute connected subnets
redistribute isis level-1-2 subnets
passive-interface Vlan20
network 192.168.176.236 0.0.0.0 area 11
distribute-list route-map OSPFilter in
distance 120
!
router isis
net 49.0001.0000.0000.0001.00
domain-password omited
redistribute connected
redistribute static ip metric 10
default-information originate
mpls traffic-eng router-id Loopback0
!
router bgp 65171
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 192.168.110.2 remote-as 65171
neighbor 192.168.110.2 update-source Loopback0
neighbor 192.168.110.11 remote-as 65171
neighbor 192.168.110.11 update-source Loopback0
neighbor 192.168.110.12 remote-as 65171
neighbor 192.168.110.12 update-source Loopback0
neighbor 192.168.110.13 remote-as 65171
neighbor 192.168.110.13 update-source Loopback0
neighbor 192.168.110.14 remote-as 65171
neighbor 192.168.110.14 update-source Loopback0
neighbor 192.168.110.15 remote-as 65171
neighbor 192.168.110.15 update-source Loopback0
!
address-family ipv4
  no synchronization
  redistribute connected
  no auto-summary
exit-address-family
!
address-family vpnv4
  neighbor 192.168.110.2 activate
  neighbor 192.168.110.2 send-community both
  neighbor 192.168.110.11 activate
  neighbor 192.168.110.11 send-community both
  neighbor 192.168.110.11 route-reflector-client
  neighbor 192.168.110.12 activate
  neighbor 192.168.110.12 send-community both
  neighbor 192.168.110.12 route-reflector-client
  neighbor 192.168.110.13 activate
  neighbor 192.168.110.13 send-community both
  neighbor 192.168.110.13 route-reflector-client
  neighbor 192.168.110.14 activate
  neighbor 192.168.110.14 send-community both
  neighbor 192.168.110.14 route-reflector-client
  neighbor 192.168.110.15 activate
  neighbor 192.168.110.15 send-community both
  neighbor 192.168.110.15 route-reflector-client
exit-address-family
!
address-family l2vpn vpls
  neighbor 192.168.110.2 activate
  neighbor 192.168.110.2 send-community both
  neighbor 192.168.110.11 activate
  neighbor 192.168.110.11 send-community both
  neighbor 192.168.110.11 route-reflector-client
  neighbor 192.168.110.12 activate
  neighbor 192.168.110.12 send-community both
  neighbor 192.168.110.12 route-reflector-client
  neighbor 192.168.110.13 activate
  neighbor 192.168.110.13 send-community both
  neighbor 192.168.110.13 route-reflector-client
  neighbor 192.168.110.14 activate
  neighbor 192.168.110.14 send-community both
  neighbor 192.168.110.14 route-reflector-client
  neighbor 192.168.110.15 activate
  neighbor 192.168.110.15 send-community both
  neighbor 192.168.110.15 route-reflector-client
exit-address-family
!
address-family ipv4 vrf L3MPLS
  no synchronization
  redistribute connected
exit-address-family
!
address-family ipv4 vrf bahma
  no synchronization
  redistribute connected
  redistribute static
exit-address-family
!
ip classless
ip route 192.168.76.0 255.255.255.248 192.168.110.101
ip route 192.168.76.8 255.255.255.248 192.168.110.102
ip route 192.168.77.32 255.255.255.224 192.168.110.102
ip route 192.168.77.64 255.255.255.224 192.168.110.102
ip route 192.168.96.224 255.255.255.224 192.168.110.102
ip route 192.168.99.64 255.255.255.192 192.168.110.102
ip route 192.168.99.128 255.255.255.192 192.168.110.102
ip route 192.168.109.0 255.255.255.128 192.168.110.101
ip route 192.168.109.128 255.255.255.128 192.168.110.102
ip route 192.168.111.0 255.255.255.128 192.168.110.101
ip route 192.168.111.128 255.255.255.128 192.168.110.102
ip route 192.168.192.0 255.255.255.0 192.168.110.101
ip route 192.168.193.0 255.255.255.0 192.168.110.101
ip route 192.168.194.0 255.255.255.0 192.168.110.102
ip route 192.168.195.0 255.255.255.0 192.168.110.102
ip route 192.168.20.0 255.255.255.192 10.20.61.226
ip route 192.168.21.0 255.255.255.0 10.20.61.226
ip route 192.168.26.0 255.255.255.0 10.20.61.242
ip route 192.168.27.0 255.255.255.0 10.20.62.82
ip route 192.168.29.0 255.255.255.0 10.20.61.238
ip route 192.168.30.0 255.255.255.0 10.20.62.30
ip route 192.168.31.0 255.255.255.0 10.20.62.134
ip route 192.168.34.0 255.255.255.0 10.20.62.38
ip route 192.168.35.0 255.255.255.0 10.20.62.42
ip route 192.168.36.0 255.255.255.0 10.20.62.46
ip route 192.168.41.0 255.255.255.0 10.20.62.66
ip route 192.168.42.0 255.255.255.0 10.20.62.70
ip route 192.168.51.0 255.255.255.192 192.168.110.101
ip route 192.168.51.64 255.255.255.224 192.168.110.102
!
no ip http server
ip pim send-rp-announce Vlan704 scope 5
!
ip access-list standard FILT
permit 172.20.1.0 0.0.0.255
permit 172.20.2.0 0.0.0.255
!
ip access-list extended Input
deny   ip 172.20.0.0 0.0.3.255 any
permit ip any any
!
logging history informational
logging trap warnings
logging source-interface Vlan20
logging 192.168.110.244
access-list 1 permit 192.168.32.104
access-list 1 permit 192.168.63.163
access-list 1 permit 172.20.1.0 0.0.0.255
access-list 1 permit 172.20.2.0 0.0.0.255
access-list 1 permit 192.168.110.240 0.0.0.15
access-list 1 permit 192.168.7.0 0.0.0.255
access-list 101 permit icmp any host 192.168.32.1
access-list 101 permit ip any any
!
route-map OSPFilter deny 10
match ip address FILT
!
route-map OSPFilter permit 20
!
snmp-server community omited RW
snmp-server source-interface informs Loopback0
!
mpls ldp router-id Loopback0
!
control-plane
!
!
line con 0
line vty 0 4
access-class 1 in
password cisco
login local
transport input lat pad udptn telnet rlogin
telnet speed 115200 38400
line vty 5 15
access-class 1 in
password cisco
login local
transport input lat pad udptn telnet rlogin
telnet speed 115200 38400
!
exception crashinfo buffersize 80
process cpu extended history 50
ntp master
ntp server 81.168.77.149
!
end

I have an ANA that it login to my router every 15 minutes. therefore cpu usage is very high every 15 minutes.

Best Regards

1 REPLY
Cisco Employee

Re: High CPU utilization by show run

Hi Farhad,

What you have observed is normal, it shouldn't cause any impact to your traffic. Virtual EXEC process is low priority process, and it uses the available cpu when possible. So that said, both traffic been processed in interrupt level and traffic been processed by ip input process will be processed first by CPU.

Here is the document that explain the behavior of EXEC process.

http://www.cisco.com/en/US/products/hw/switches/ps708/products_tech_note09186a00804916e0.shtml#understand

HTH,

Lei Tian

1648
Views
0
Helpful
1
Replies
CreatePlease to create content