Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

High Utilization on Router CPU (IP Input)

Hi all,

I'm currently having a high CPU utilization problem. I have used "show processed cpu" command and I found that the highest CPU usage is on IP input.

The router in question also have its CEF and Fast switching feature enabled. But unlike the explanation on the documentation, it doesn't solve the problem.

Attached is the config and show command on that router. Could anyone help to point out if I have forgotten to input some command or should I just upgrade this router to the newer version ? 

Any advice would be greatly appreciated

Regards,

Adiputra.

Everyone's tags (4)
2 REPLIES

High Utilization on Router CPU (IP Input)

Hi Adiputra,

I had a similar issue in the past.

Since you have ip cef enabled, plese also check that your traffic is also ip cef forwared - e.g

sh interfaces fastEthernet 0/0 switching

Protocol  IP                 

          Switching path    Pkts In   Chars In   Pkts Out  Chars Out

                 Process   19303316 2574167687    2613648  228138569

            Cache misses        364          -          -          -

                    Fast  276569047 2748504719  192249004 2855311097

               Auton/SSE          0          0          0          0

.

Check if the counter with the process switched packets increases with a very high rate.

Finally, check if you have many small sized packets (not only unicast but also multicast/broadcast) to router interfaces. This affect the IP input process and this was the root cause of my similar problem with high IP input process. The LAN interface received many small sized packets due to a problem to an end user.

HTH,

Vasilis

Hall of Fame Super Silver

Re: High Utilization on Router CPU (IP Input)

Hello Adiputra,

first of all, remove usernames / password pairs in the attached file for safety.

I see this is a lab router but these forums are public.

In order to correctly advertise your loopback in OSPF that has a network mask /24 you need to add ip ospf network point-to-point in interface loop1 configuration.

>> Could anyone help to point out if I have forgotten to input some command or should I just upgrade this router to the newer version ?

I would point out that there are too much commands in interface gi0/0 and gi0/1 configuration that might be the result of a previous lab.

More specifically your router is only performing NAT currently for all internal addresses between the two LAN interfaces.

interface GigabitEthernet0/0

ip address 192.168.4.50 255.255.255.252

ip nat inside

ip virtual-reassembly

ip ospf network point-to-point

duplex auto

speed auto

!

interface GigabitEthernet0/1

ip address 172.16.0.5 255.255.255.0

ip nbar protocol-discovery

ip nat outside

ip virtual-reassembly

load-interval 60

duplex auto

speed auto

!

ip nat inside source list 1 interface GigabitEthernet0/1 overload

!

access-list 1 permit 192.168.0.0 0.0.255.255

Taking in account this I would suggest to remove the folllowing commands

interface GigabitEthernet0/1

no  ip virtual-reassembly

no ip nbar protocol-discovery

interface GigabitEthernet0/0

no  ip virtual-reassembly

+

interface loop1

ip ospf network point-to-point

After removing these commands you should check switching modes on gi0/1 and gi0/0.

IF this is a lab router you could even try to reload the router if you don't see changes in router behaviour.

Edit:

from the show commands that you have put in the log file we see roughly 290 pkts/sec RX and TX on gi0/1 and gi0/0 and very few broadcast on both LAN interfaces (in percentage compared to total received packets on gi0/0) so the router doesn't look like to be process switching a lot of broadcast or multicast packets that could be a possible root cause as suggested.

Hope to help

Giuseppe

12374
Views
0
Helpful
2
Replies