Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

How do I configure port forwarding?

I am trying to do the simplest of configurations (I think, anyway) and I can't get it to work.  A little router with a cellular interface (working) and overloading the inside hosts on VLAN1 to hit the internet.  That is working.

I want place a host on vlan1 with IP 192.168.1.102 that has a built in webserver and hit it from the outside.  Not sure what I am doing incorrectly, but it isn't working.  Also want to RDP into a host at 192.168.1.100 - and can't do that either.

I'm stumped.  Any idea what I'm missing?

no service pad

service tcp-keepalives-in

service tcp-keepalives-out

service timestamps debug datetime msec localtime show-timezone

service timestamps log datetime msec localtime show-timezone

service password-encryption

service sequence-numbers

!

hostname sprint-3g

!

boot-start-marker

boot-end-marker

!

!

logging buffered 51200

logging console critical

!

no aaa new-model

!

clock timezone PCTime -8 0

clock summer-time PCTime date Apr 6 2003 2:00 Oct 26 2003 2:00

crypto pki token default removal timeout 0

!

no ip source-route

ip cef

!

!

!

ip dhcp excluded-address 192.168.1.1 192.168.1.200

!

ip dhcp pool Inside-IP-Pool

import all

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1

dns-server 8.8.4.4 8.8.8.8

lease 45

!

!

no ip bootp server

ip domain name yourdomain.com

no ipv6 cef

!

!

multilink bundle-name authenticated

chat-script cdma "" "ATDT#777" TIMEOUT 60 "CONNECT"

license udi pid C819G-S-K9 sn FTX155865LZ

!

!

username cisco privilege 15 secret cisco

!

!

!

controller Cellular 0

!

ip tcp synwait-time 10

!

!

interface Cellular0

ip address negotiated

no ip redirects

no ip unreachables

no ip proxy-arp

ip flow ingress

ip nat outside

ip virtual-reassembly in

encapsulation ppp

dialer in-band

dialer string cdma

dialer-group 1

!

interface FastEthernet0

no ip address

spanning-tree portfast

!

interface FastEthernet1

no ip address

spanning-tree portfast

!

interface FastEthernet2

no ip address

spanning-tree portfast

!

interface FastEthernet3

no ip address

spanning-tree portfast

!

interface GigabitEthernet0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip flow ingress

shutdown

duplex auto

speed auto

!

interface Serial0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

shutdown

clock rate 2000000

!

interface Vlan1

description VLAN1

ip address 192.168.1.1 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip flow ingress

ip nat inside

ip virtual-reassembly in

ip tcp adjust-mss 1452

!

ip forward-protocol nd

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

!

ip nat inside source list PrivateIP interface Cellular0 overload

ip route 0.0.0.0 0.0.0.0 Cellular0

!

ip access-list extended PrivateIP

permit ip 192.168.1.0 0.0.0.255 any

ip access-list extended WebPorts

permit tcp any host 192.168.1.102 eq www

permit tcp any host 192.168.1.102 eq 443

permit tcp any host 192.168.1.100 eq 3389

!

ip sla 1

icmp-echo 4.2.2.2 source-interface Cellular0

frequency 5

ip sla schedule 1 life forever start-time now

logging trap debugging

access-list 1 permit any

dialer-list 1 protocol ip list 1

no cdp run

!

!

!

!

!

control-plane

!

line con 0

login local

line aux 0

line 3

exec-timeout 0 0

script dialer cdma

modem InOut

no exec

speed 144000

line vty 0 4

privilege level 15

login local

transport input telnet ssh

!

scheduler allocate 20000 1000

scheduler interval 500

end

  • WAN Routing and Switching
5 REPLIES

How do I configure port forwarding?

It looks like you need to add:

ip nat inside source static tcp 192.168.1.102 80 interface cell0 80

ip nat inside source static tcp 192.168.1.100 3389 interface cell0 3389

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
New Member

How do I configure port forwarding?

Looks like I am still missing something.  Was just reading up on that command as I got your reply, and you seem to be correct, however it still is not working.

The way I see it, I should be able to browse to the external IP address of the cellular router on my smartphone and bring up the webpage.

I know the webpage is working since I can browse to it from a laptop that is on the inside of the network.

New Member

How do I configure port forwarding?

Question:...

Do I need to kill these on the router for it to work?

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

New Member

How do I configure port forwarding?

Our https decided to start working!  Thanks for the help.

http isn't working, and we are not sure why, but I think we can deal with that since https work.

Thanks again for your help!

Silver

How do I configure port forwarding?

Yes, you need to do:

#no ip http server

#no ip http-secure server

189
Views
0
Helpful
5
Replies
This widget could not be displayed.