Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

How i advertise this Pool in BGP.

hi

How i advertise this bl, in my bgp X.X.X.0/21

waiting for ur pesponse

Thanks

11 REPLIES

Re: How i advertise this Pool in BGP.

Hello,

one way of doing it (assuming 10.1.0.0/21):

router bgp 65000

network 10.1.0.0 mask 255.255.224.0

neighbor 1.1.1.1 remote-as 64646 !ISP

neighbor 1.1.1.1 filter-list 1 out

no auto-summary

ip as-path access-list 1 permit ^$

ip route 10.1.0.0 255.255.224.0 Null0 250

The static route "organizes" the entry in the IP routing table exactly matching the network statement in BGP. Routing will use longest match, so your subnetted official IP addresses will be reachable.

The as-path list assures, that you only announce networks originated in your AS.

Hope this helps! Please rate all posts.

Regards, Martin

Silver

Re: How i advertise this Pool in BGP.

network x.x.x.0 mask 255.255.248.0

This will advertise x.x.x.0/21 provided the router knows this network (through either static route, dynamic routing protocols, or a connected interface).

New Member

Re: How i advertise this Pool in BGP.

Hi,

Thanks alot

i was missing the words mask ????

thanks alot.

Re: How i advertise this Pool in BGP.

OOps,

255.255.248.0 off course! Sorry for the miscalculation, it has been a long day at work...

Please make sure also to adjust the static route to the correct mask! The correct version is:

router bgp 65000

network 10.1.0.0 mask 255.255.248.0

neighbor 1.1.1.1 remote-as 64646 !ISP

neighbor 1.1.1.1 filter-list 1 out

no auto-summary

ip as-path access-list 1 permit ^$

ip route 10.1.0.0 255.255.248.0 Null0 250

Regards, Martin

New Member

Re: How i advertise this Pool in BGP.

hi,

i ant to conform that that it shuld be/

192.168.202.0 mask 255.255.255.248.0

and

ip route 192.168.202.0 255.255.248.0 null0

why we use static routes..???? for its definations

Thanks

Silver

Re: How i advertise this Pool in BGP.

BGP would not advertise a route, unless the route is in the IGP. Often times, you would have more specific routes in the IGP, but you would need to advertise the aggregate route via BGP.

By configuring the static route, BGP can advertise the route, since it is now known to IGP. Pointing to null interface, will have little effects, since there should be more specific routes in the IGP. However, if there are no more specific routes, the static route could point to the appropriate interface.

New Member

Re: How i advertise this Pool in BGP.

Hi,

Thanks for the Ans,,

I have advertise my suppernet blocK of /21 as mention earlier e.g.

router Bgp 65551

network x.x.x.0 mask 255.255.248.0

!

!

!

ip route X.X.X.0 255.255.248.0 null0

Is ok ??? i have chked it is working

i want to ask is there any other method to adverise such block not with static route.

Thanks

Silver

Re: How i advertise this Pool in BGP.

If you do not want to add a static route, then the router will need to know the route via another routing protocol like OSPF, ISIS or EIGRP.

New Member

Re: How i advertise this Pool in BGP.

Hi,

Thanks for the Ans

Than its is via another routing protocol, and we redistribute it in to bpg with redistributons commonds

can i you send any detial or link about the resdistribution of IGP;s in to BGp

regards

Silver

Re: How i advertise this Pool in BGP.

Silver

Re: How i advertise this Pool in BGP.

Well, you could either redistribute using the redistribute command or use the network command. Both will make BGP advertise the route. However, if you use redistribute, the origin code for the BGP route is incomplete while if you use the network command, the origin code is IGP.

see

http://www.cisco.com/en/US/products/sw/iosswrel/ps1826/products_configuration_guide_chapter09186a00800877b5.html#xtocid10

466
Views
14
Helpful
11
Replies
CreatePlease login to create content