Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

How to adjust QoS settings?

Hi,

I'm playing with QoS and trying to test my configuration. My goal is prioritization traffic on 5060 port.

I have:

1) Cisco 3750x with SVI

2) 2 PC in vlan 26 (as clients)

3) 1 PC in vlan 25 (as server)

Here is my config on 3750x:

!

ip access-list extended voice_acl

permit udp any any range 5060 5061

permit udp any range 5060 5061 any

!

!

class-map match-any voice_cm

match access-group name voice_acl

!

!

policy-map traffic

class voice_cm

  set dscp ef

!

!

interface Vlan25

description -= Server =-

ip address 172.25.35.1 255.255.255.0

ip helper-address 172.25.0.5

ip helper-address 172.25.10.5

service-policy input traffic

!

!

interface Vlan26

description -=Clients=-

ip address 172.25.61.1 255.255.255.0

ip helper-address 172.25.0.5

ip helper-address 172.25.10.5

service-policy input traffic

!

interface GigabitEthernet1/0/11

switchport access vlan 26

switchport mode access

mls qos vlan-based

!

!

interface GigabitEthernet1/0/12

switchport access vlan 26

switchport mode access

mls qos vlan-based

!

!

interface GigabitEthernet1/0/13

switchport access vlan 25

switchport mode access

mls qos vlan-based

!

After configuration I tried to test prioritization. I used iperf tool to generate huge amount of traffic to make loaded network scenario.

Testing steps(see attached picture):

I - with QoS

1. On PC 3 I started iperf in server mode to listen 5001 port

2. On PC 2 I started iperf in client mode to PC 3

- steps 1 and 2 just for loading network

- then, under loaded network, I am sending/recieving packets on 5060 port.

3. On PC 3 I started iperf in server mode to listen 5060 port.

4. On PC 1 I started iperf in client mode to PC 3.

- got results(bandwidth, jitter, lost)

II - without QoS

5. Remove string service-policy input traffic on SVIs

6. Repeated steps 1-4.

- got results(bandwidth, jitter, lost)

I've attached the picture of the network with the test result. Unfortunatelly, there are the same results with and without QoS.

Please suggest where I am wrong in configuration and how could I adjust settings?

Thanks.





Everyone's tags (2)
116
Views
0
Helpful
0
Replies
CreatePlease to create content