Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

how to advertise /32 on bgp

hi guys,

i dont know if this is possible to advertise just a number of /32 on my provider. we will do some testing on our link and they want me to advertise only 3 ip address's.

tnx

jeff

1 ACCEPTED SOLUTION

Accepted Solutions

Re: how to advertise /32 on bgp

If this is just for testing you could add 3 new loopback interfaces using the /32 and use the commands on the previous post. (dont forget to turn auto-summary off, with no auto-summary) and you are good to go!

Vlad

13 REPLIES
Silver

Re: how to advertise /32 on bgp

You can advertise /24 or larger subnets (/23 /22 ...), since IPS filter the small subnets updates. If you are sure that your ISP accepts smaller you can do with the aggregate command or with the network command and ip route "IP" "mask" null...

bye

FCS

Please rate me if I helped.

New Member

Re: how to advertise /32 on bgp

If for example, the three IP addr which you want advertised are 192.168.1.1 to 192.168.1.3, then configure the following commands on our ISP-facing BGP router:

router bgp 25

network 192.168.1.1 mask 255.255.255.255

network 192.168.1.2 mask 255.255.255.255

network 192.168.1.3 mask 255.255.255.255

If your eBGP peering with the ISP is working correctly, then these routes will be automatically added to the IP route table of the remote eBGP peer on ISP end.

HTH,

Ahsan M

Re: how to advertise /32 on bgp

If this is just for testing you could add 3 new loopback interfaces using the /32 and use the commands on the previous post. (dont forget to turn auto-summary off, with no auto-summary) and you are good to go!

Vlad

New Member

Re: how to advertise /32 on bgp

tnx to all.

jeff

New Member

Re: how to advertise /32 on bgp

Hi dear ,

Just make a loopback and advertise that network ip to bgp ...

http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a00800945fe.shtml

!

interface Loopback0

ip address 20.20.20.20 255.255.255.255

!

interface Ethernet0/0

ip address 172.16.1.1 255.255.255.0

!

interface Serial8/0

ip address 192.168.16.2 255.255.255.252

!

=================================

example.

router bgp 2

no synchronization

bgp log-neighbor-changes

network 20.20.20.20 mask 255.255.255.255

network 172.16.1.0 mask 255.255.255.0

neighbor 10.10.10.10 remote-as 1

neighbor 10.10.10.10 ebgp-multihop 2

neighbor 10.10.10.10 update-source Loopback0

no auto-summary

!

ip route 10.10.10.0 255.255.255.0 192.168.16.1

==================================

TC / rate if works

prs

New Member

Re: how to advertise /32 on bgp

Hi,

How do we advertise a /32 to one particular neighbor only. Please help.

Thanks in advance

Silver

Re: how to advertise /32 on bgp

Hello,

You can filter your advertisements with prefix-list or route-map

Example:

ip prefix-list PL permit 192.168.0.1/32

router bgp 65001

neighbor 10.0.0.1 remote-as 65002

neighbor 10.0.0.1 prefix-list PL out

Only 192.168.0.1 is advertised to peer 10.0.0.1. Also if you don't want to advertise this prefix to other peers another prefix-list is needed which denies this prefix and permits all others.

ip prefix-list PL1 deny 192.168.0.1/32

ip prefix-list PL1 permit 0.0.0.0/0 le 32

neighbor 10.10.10.2 prefix-list PL1 out

Bye

FCS

New Member

Re: how to advertise /32 on bgp

Hi,

Thanks for the Input. I tried and for some reason I dont get it in the advertised-routes. Here is the config below:

----------------------

router bgp 65555

no synchronization

bgp log-neighbor-changes

neighbor 191.151.81.20 remote-as 1

neighbor 191.151.81.20 soft-reconfiguration inbound

neighbor 191.151.81.20 distribute-list 30 in

neighbor 191.151.81.20 prefix-list test out

no auto-summary

----------------------

sh ip prefix-list

ip prefix-list test: 3 entries

seq 5 permit 192.174.129.2/32

seq 10 permit 192.174.129.253/32

seq 15 permit 192.174.129.254/32

sh ip bgp neighbors 191.151.81.20 advertised-routes

Total number of prefixes 0

Note: I did clear bgp soft out - no change and I did Clear ip bgp * - still nochange.

What am i missing here. Please help.

Thanks in advance

Silver

Re: how to advertise /32 on bgp

Hello,

Do you have routes for your /32 newtorks on the router where BGP runs. You should have exactly the same networks in it, all with /32 mask since no auto-summary.

Bye

FCS

New Member

Re: how to advertise /32 on bgp

Hi,

Thanks for the quick response. I added routes /32 and still no luck. What else to be checked.

Thanks in advance.

Silver

Re: how to advertise /32 on bgp

Could you please change the distribute-list to a prefix-list? what does "show ip bgp" show on your box?

Bye

FCS

New Member

Re: how to advertise /32 on bgp

Hi Jeff,

it's most likely that your ISP block your /32 prefixes, because the most internet service provider protect the internet against prefixes which are bigger than /24.

Michael

New Member

Re: how to advertise /32 on bgp

Thanks mate. It was the case. I got it working after they allowed it.

2989
Views
17
Helpful
13
Replies