Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

How to change Local BGP id

Hi,

We have a rtr with loopback set to 10.10.10.10/24. The router has EBGP peering with ISP router via serial link. No bgp router-id configured for the rtr.

SHOW IP BGP SUMMARY:

Local BGP identifier as Lo address (10.10.10.10).

I removed the Lo0 and clear the neighbor , still the SHOW IP BGP SUMMARY showing the BGP identifier as :lo0 (which is no longer existing).

Any reason...?

Also, removing the Lo0 will cause any issue to BGP peering..?

Please suggest..

Thank you in advance

MS

7 REPLIES

Re: How to change Local BGP id

HI MS, [Pls Rate if Helps]

Normally, Prefer the route that comes from the BGP router with the lowest router ID.

The router ID is the highest IP address on the router, with preference given to loopback addresses. Also, you can use the bgp router-id command to manually set the router ID.

Please try: "clear bgp session"

PLS RATE if HELPS

Best Regards,

Guru Prasad R

Re: How to change Local BGP id

If your neighbor has peered with you over the loopback address (or if you have used neighbor x.x.x. update-source loopback0), it will affect the peering relationship and the remote end router may be required to reconfigure the peer address

Narayan

New Member

Re: How to change Local BGP id

router-id just like name,an ID,it is chosen from an address but no an address

New Member

Re: How to change Local BGP id

Thank you for the replies , but the rtr has simple config like this...

!

interface Loopback0

ip address 10.10.10.10 255.255.255.0

!

!

router bgp 3333

bgp log-neighbor-changes

network 10.10.10.0 mask 255.255.255.0

neighbor 23.53.53.17 remote-as 8426

neighbor 23.53.53.17 next-hop-self

neighbor 23.53.53.17 soft-reconfiguration inbound

!

interface Serial0

ip address 23.53.53.18 255.255.255.252

!

TEN-1700-R1#sh ip bgp sum

BGP router identifier 10.10.10.10 , local AS number 3333

--> Even after removing Lo0 i/f and clearing the BGP session....

TEN-1700-R1#sh ip bgp sum

BGP router identifier 10.10.10.10 , local AS number 3333

Any clues..? Do I need to reboot the rtr..??

Thanks in advance

MS

Cisco Employee

Re: How to change Local BGP id

Hi,

The BGP route ID is choosen when BGP (the process) is started or when a new ID is configured. Then it is kept, even if the loopback from which the ID was choosen is deleted. If you clear a neighbor, it will terminate the TCP session to that neighbor, but will not terminate the BGP process locally on the router.

To change the BGP ID use

router BGP 3333

bgp router-id A.B.C.D

After that you might have to clear BGP.

Hope this helps! Please rate all posts.

Regards, Martin

Cisco Employee

Re: How to change Local BGP id

MS,

I tried to replicate your issue and though the router ID was the same even after removing the loopback interface, it changed after I cleared the BGP process.

R1#sh ip bgp s

BGP router identifier 10.10.10.10, local AS number 3333

BGP table version is 3, main routing table version 3

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

23.53.53.17 4 8426 4 6 3 0 0 00:01:27 0

R1#sh ip bgp s

BGP router identifier 10.10.10.10, local AS number 3333

BGP table version is 3, main routing table version 3

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

23.53.53.17 4 8426 4 6 3 0 0 00:01:28 0

R1#clear ip bgp *

R1#

*Mar 1 00:08:18.799: %BGP-5-ADJCHANGE: neighbor 23.53.53.17 Down User reset

R1#

R1#

R1#

R1#sh ip bgp s

*Mar 1 00:08:20.323: %BGP-5-ADJCHANGE: neighbor 23.53.53.17 Up

R1#sh ip bgp s

BGP router identifier 23.53.53.18, local AS number 3333

BGP table version is 1, main routing table version 1

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

23.53.53.17 4 8426 8 11 1 0 0 00:00:02 0

R1#

R1#sh run | b r b

router bgp 3333

no synchronization

bgp log-neighbor-changes

network 10.10.10.0 mask 255.255.255.0

neighbor 23.53.53.17 remote-as 8426

no auto-summary

interface Serial1/0

ip address 23.53.53.18 255.255.255.252

---------

What IOS are you running?

-Vaibhav

New Member

Re: How to change Local BGP id

Hi all,

Thank you for the replies and tests.

The IOS : Version 12.1(6) rtr:1700

Thank you

MS

582
Views
0
Helpful
7
Replies