Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

How to configure 857w to a dumb ADSL2+ modem?

Can someone please show me how to configure a cisco 857w adsl router to function as a dumb adsl2+ modem only?

I have been trying to do this at home following few of those what I've found after searching forums in google and I am not successful.

Many thanks

7 REPLIES
Hall of Fame Super Gold

Re: How to configure 857w to a dumb ADSL2+ modem?

You need first to know VPI/VCI values.

New Member

Re: How to configure 857w to a dumb ADSL2+ modem?

hello p.bevilacqua

its 8/35

New Member

Re: How to configure 857w to a dumb ADSL2+ modem?

Hi...

You need to upgrade your IOS to advance service and then in Dialer 0, it has to be dsl operating mode adsl2+ or dsl operating mode auto

Thanks

Tabrez

New Member

Re: How to configure 857w to a dumb ADSL2+ modem?

Can someone just show me a config please?

Below is the current configurations:

SHOW VERSION

Cisco857w#show version
Cisco IOS Software, C850 Software (C850-ADVSECURITYK9-M), Version 12.4(11)T2,
LEASE SOFTWARE (fc4)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Tue 01-May-07 08:56 by prod_rel_team

ROM: System Bootstrap, Version 12.3(8r)YI4, RELEASE SOFTWARE

Cisco857w uptime is 16 weeks, 4 days, 9 hours, 55 minutes
System returned to ROM by power-on
System image file is "flash:c850-advsecurityk9-mz.124-11.T2.bin"


This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

Cisco 857W (MPC8272) processor (revision 0x300) with 59392K/6144K bytes of mem
y.
Processor board ID FHK125125T9
MPC8272 CPU Rev: Part Number 0xC, Mask Number 0x10
4 FastEthernet interfaces
1 ATM interface
1 802.11 Radio
128K bytes of non-volatile configuration memory.
20480K bytes of processor board System flash (Intel Strataflash)

Configuration register is 0x2102

SHOW RUNNING-CONFIG

Cisco857w#show run
Building configuration...

Current configuration : 6038 bytes
!
version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
no service password-encryption
service sequence-numbers
!
hostname Cisco857w
!
boot-start-marker
boot-end-marker
!
logging buffered 16000
no logging console
enable secret 5 $1$MlGU$kfvuUUGSI6EO8ohAcTkt1.
!
no aaa new-model
no ip source-route
no ip dhcp use vrf connected
ip dhcp excluded-address 10.10.10.1
!
ip dhcp pool CUSTOMER_LAN_POOL
   network 10.10.10.0 255.255.255.0
   default-router 10.10.10.1
   dns-server A.B.C.D X.Y.Z.W
!
!
ip cef
no ip bootp server
ip domain name direct.telstra.net
ip name-server A.B.C.D
ip name-server X.Y.Z.W
ip ssh version 2
!
!
crypto pki trustpoint TP-self-signed-3974344100
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-3974344100
revocation-check none
rsakeypair TP-self-signed-3974344100
!
!
crypto pki certificate chain TP-self-signed-3974344100
certificate self-signed 01
  3082025C 308201C5 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 33393734 33343431 3030301E 170D3032 30333031 30303037
  32345A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 39373433
  34343130 3030819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100A90E D7505FE0 4CFBDA7C E9CCF763 DCEB5F39 33491CC8 6A76A2D1 97390DE3
  688F549A 05BF017A 7DB89D77 39CB06D2 914AD696 A5789AD4 2DC51F44 75F3D59B
  15F982A6 55DDEFEB 5485BFD1 B618270E CC59B360 4783C06E 319C2E89 E8535DD4
  B483F905 8DE4E3AB 16FA5239 90D527D3 A5FA51CD D1DBFE14 409B9512 388143B4
  B5970203 010001A3 81833081 80300F06 03551D13 0101FF04 05300301 01FF302D
  0603551D 11042630 24822254 425F4242 5F416476 616E7461 67652E64 69726563
  742E7465 6C737472 612E6E65 74301F06 03551D23 04183016 8014C907 2C24D981
  D5A7E5F9 CD485C38 921C8719 E836301D 0603551D 0E041604 14C9072C 24D981D5
  A7E5F9CD 485C3892 1C8719E8 36300D06 092A8648 86F70D01 01040500 03818100
  6C1B9027 EB330206 F954A340 5CCA0157 7F6AD0B5 9F8BEEB9 D02585C7 BD5981B9
  96850F56 1336AF92 A53267FC C449F99E 18CE6712 BA376AC4 0D9179A5 5EB6E50F
  FF864B3F 39F3F116 3DB8472C 9C08EDA1 B5F14834 BBDE3644 BFEBEB51 763DE552
  70F8995E A947923C 7A48410B 803CA3A5 4692BCA2 CBDACCFA 893D337A 3048FCF3
  quit
!
!
username UserName privilege 15 secret 5 $1$WTVe$AxGuNNZhkwNRUYanptSkF/
!
!
!
!
!
!
interface ATM0
no ip address
no ip route-cache cef
no ip route-cache
load-interval 30
no atm ilmi-keepalive
pvc 8/35
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
!
dsl operating-mode auto
!
interface FastEthernet0
spanning-tree portfast
!
interface FastEthernet1
spanning-tree portfast
!
interface FastEthernet2
spanning-tree portfast
!
interface FastEthernet3
spanning-tree portfast
!
interface Dot11Radio0
no ip address
shutdown
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0                                                                              54.0
station-role root
!
interface Vlan1
description CUSTOMER_LOCAL_LAN
ip address 10.10.10.1 255.255.255.0
ip nat inside
ip virtual-reassembly
no ip route-cache cef
!
interface Dialer0
description ADSL Link FNN xxxxxxx
ip address negotiated
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip route-cache flow
dialer pool 1
no cdp enable
ppp authentication chap callin
ppp chap hostname UserName@ISP
ppp chap password 7 15465F54577E7C
!
ip route 0.0.0.0 0.0.0.0 Dialer0
!
ip http server
ip http access-class 22
ip http authentication local
ip http secure-server
ip nat source static esp 10.10.10.2 interface Dialer0
ip nat source static udp 10.10.10.2 500 interface Dialer0 500
ip nat source static udp 10.10.10.2 5500 interface Dialer0 5500
ip nat source static udp 10.10.10.2 1701 interface Dialer0 1701
ip nat source static udp 10.10.10.2 4500 interface Dialer0 4500
ip nat source static tcp 10.10.10.2 51 interface Dialer0 51
ip nat source static tcp 10.10.10.2 10000 interface Dialer0 10000
ip nat source static udp 10.10.10.2 10000 interface Dialer0 10000
ip nat source static udp 10.10.10.2 10001 interface Dialer0 10001
ip nat source static tcp 10.10.10.2 10001 interface Dialer0 10001
ip nat inside source list 22 interface Dialer0 overload
ip nat inside source static tcp 10.10.10.2 1723 interface Dialer0 1723
!
access-list 22 permit 10.10.10.0 0.0.0.255
no cdp run
!
control-plane
!
banner login ^C

***********************************************************************
* Access to this computer system is limited to authorised users only. *
* Unauthorised users may be subject to prosecution under the Crimes   *
*                       Act or State legislation                      *
*                                                                     *
* Please note, ALL CUSTOMER DETAILS are confidential and must         *
*                         not be disclosed.                           *
***********************************************************************
^C
!
line con 0
no modem enable
transport output all
line aux 0
transport output all
line vty 0 2
exec-timeout 20 0
password 7 045A0F100E2F584F0E1C
login
transport input telnet
line vty 3 4
exec-timeout 20 0
password 7 045A0F100E2F584F0E1C
login
transport input ssh
!
scheduler max-task-time 5000
end

Many thanks guys!!!

Hall of Fame Super Silver

Re: How to configure 857w to a dumb ADSL2+ modem?

Hello Rock,

you need also to understand the type of encapsulation to be implemented:

when you say you would like to configure the router to behave like a dumb DSL modem do you mean like a bridge?

in this case, the modem should take ethernet frames and should put them inside an AAL5 ATM PDU to send over the DSL link.

That is:

IPV4/Ethernet/AAL5/ATM/DSL

This is called RFC1483 bridging mode because the original ip packet is bridged and not routed.

You can find an example of this configuration here:

https://www.cisco.com/en/US/products/hw/routers/ps380/products_configuration_example09186a0080093e50.shtml

But there are other possible encapsulations /service models for DSL services:

Classic IP over ATM: unlikely for home use

in this case the protocol stack is:

IPV4/AAL5/ATM/DSL

here the IPv4 packet is routed this is called RFC 1483 routed.

other very comon services are (they introduce authentication and allows the provider to account for non flat services)

PPP over ATM

PPPoE over ATM.

To be noted that an RFC 1483 bridging supports PPPoE if it it is the PC to run PPPoE client, because PPPoE frames are ethernet frames.

So it  is wise to consult your provider to find out what type of service you have. Configuration will follow.

Hope to help

Giuseppe

New Member

Re: How to configure 857w to a dumb ADSL2+ modem?

Hi...

interface ATM0

no ip address

no ip route-cache cef

no ip route-cache

load-interval 30

no atm ilmi-keepalive

pvc 8/35

  encapsulation aal5mux ppp dialer

  dialer pool-member 1

!

dsl operating-mode adsl2+

It has to be on interface ATM0 and not on dialer0, kindly ensure your ISP has changed your line to support this feature or it is recommended to keep on auto.

New Member

Re: How to configure 857w to a dumb ADSL2+ modem?

thank you guys for the quick replies.

ill get back to you once I get how

2514
Views
7
Helpful
7
Replies
CreatePlease to create content