cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
545
Views
0
Helpful
4
Replies

How to configure better of EIGRP.

cisco_fun_4899
Level 1
Level 1

Hi,

I have a quiestion about design of EIGPR.

Here is the topology.

******************************************************************************

Neatnet_Network_Topology.gif

[Router_A]

interface Serial0/0
bandwidth 64
ip address 172.19.0.2 255.255.0.0
no fair-queue
!
interface Serial0/1
bandwidth 64
ip address 172.16.0.1 255.255.0.0
clock rate 64000
!
router eigrp 1
network 172.16.0.0
network 172.19.0.0
auto-summary

[Router_B]

interface Serial0/0
ip address 172.16.0.2 255.255.0.0
no fair-queue
!
interface Serial0/1
bandwidth 64
ip address 172.17.0.1 255.255.0.0
clock rate 64000
!
router eigrp 1
network 172.16.0.0
network 172.17.0.0
auto-summary
!

[Router_C]

interface Serial0/0
ip address 172.17.0.2 255.255.0.0
!
interface Serial0/1
bandwidth 64
ip address 172.18.0.1 255.255.0.0
clock rate 64000
!
router eigrp 1
network 172.17.0.0
network 172.18.0.0
auto-summary

[Router_D]

interface Serial0/0
ip address 172.18.0.2 255.255.0.0
no fair-queue
!
interface FastEthernet0/1
ip address dhcp
duplex auto
speed auto
!
interface Serial0/1
bandwidth 64
ip address 172.19.0.1 255.255.0.0
clock rate 64000
!
router eigrp 1
network 172.18.0.0
network 172.19.0.0
no auto-summary
!

******************************************************************************

And, here is the behavior.

******************************************************************************

Router_A#show ip route
Gateway of last resort is not set

D    172.17.0.0/16 [90/41024000] via 172.16.0.2, 1d17h, Serial0/1
C    172.16.0.0/16 is directly connected, Serial0/1
C    172.19.0.0/16 is directly connected, Serial0/0
D    172.18.0.0/16 [90/41024000] via 172.19.0.1, 1d17h, Serial0/0

Router_D#show ip route
Gateway of last resort is not set

D    172.17.0.0/16 [90/2681856] via 172.18.0.1, 1d17h, Serial0/0
D    172.16.0.0/16 [90/3193856] via 172.18.0.1, 1d17h, Serial0/0
C    172.19.0.0/16 is directly connected, Serial0/1
C    172.18.0.0/16 is directly connected, Serial0/0

******************************************************************************

I tried following command to Router_A's S0/1 from Router_D.

Then Router_D selected farther route.

******************************************************************************

Router_D#traceroute 172.16.0.1

Type escape sequence to abort.
Tracing the route to 172.16.0.1

  1 172.18.0.1 12 msec 12 msec 12 msec
  2 172.17.0.1 28 msec 28 msec 28 msec
  3 172.16.0.1 24 msec 24 msec *
******************************************************************************

How can I configure so that Router_D can select shortest route.

Regards,

Okumura

3 Accepted Solutions

Accepted Solutions

chinkevi_2
Level 1
Level 1

make all your interface consistent in bandwidth value.  the metric should prefer the shortest path.  i do not remember the bandwidth value if you leave serial interface to default.

i see that only router D has no auto-summary.  Not sure if it does anything in this case.

View solution in original post

altheb_5
Level 1
Level 1

Hi

As you know metric in EIGRB depend on BW, Delay...
First us command no auto-summary for all Routers (has noting to do for calulate pest path)
,,,,,
Second use commanded show ip eigrp topology you will see only feasible successors
and use show ip eigrp topology all-links or show ip eigrp topology summary
for show all update and why EIGRP choose the path
,,,,,,
if you don’t understand output you can copy it here to discuss it

View solution in original post

Good luck

That’s it

View solution in original post

4 Replies 4

chinkevi_2
Level 1
Level 1

make all your interface consistent in bandwidth value.  the metric should prefer the shortest path.  i do not remember the bandwidth value if you leave serial interface to default.

i see that only router D has no auto-summary.  Not sure if it does anything in this case.

altheb_5
Level 1
Level 1

Hi

As you know metric in EIGRB depend on BW, Delay...
First us command no auto-summary for all Routers (has noting to do for calulate pest path)
,,,,,
Second use commanded show ip eigrp topology you will see only feasible successors
and use show ip eigrp topology all-links or show ip eigrp topology summary
for show all update and why EIGRP choose the path
,,,,,,
if you don’t understand output you can copy it here to discuss it

Hi, chinkevi and Khaled Al Homaidhi.

Thank you so much for your nice advise.

I improved my configuration as you said about bandwidth and this question has resolved.

Here is the result.

*************************************************************************

[Before improvement]

Router_D#show ip eigrp topology all-links
IP-EIGRP Topology Table for AS(1)/ID(172.18.0.2)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 172.16.0.0/16, 1 successors, FD is 3193856, serno 49
        via 172.18.0.1 (3193856/2681856), Serial0/0, serno 31
        via 172.19.0.2 (41024000/40512000), Serial0/1
P 172.17.0.0/16, 1 successors, FD is 2681856, serno 48
        via 172.18.0.1 (2681856/2169856), Serial0/0
        via 172.19.0.2 (41536000/41024000), Serial0/1
P 172.18.0.0/16, 1 successors, FD is 2169856, serno 47
        via Connected, Serial0/0
P 172.19.0.0/16, 1 successors, FD is 40512000, serno 12
        via Connected, Serial0/1

[After improvement]

Router_D#show ip eigrp topology all-links
IP-EIGRP Topology Table for AS(1)/ID(172.18.0.2)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 172.16.0.0/16, 1 successors, FD is 41024000, serno 55
        via 172.19.0.2 (41024000/40512000), Serial0/1
        via 172.18.0.1 (41536000/41024000), Serial0/0, serno 56
P 172.17.0.0/16, 1 successors, FD is 41024000, serno 58
        via 172.18.0.1 (41024000/40512000), Serial0/0
        via 172.19.0.2 (41536000/41024000), Serial0/1
P 172.18.0.0/16, 1 successors, FD is 40512000, serno 51
        via Connected, Serial0/0
P 172.19.0.0/16, 1 successors, FD is 40512000, serno 12
        via Connected, Serial0/1

Router_D#show ip eigrp topology
IP-EIGRP Topology Table for AS(1)/ID(172.18.0.2)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 172.16.0.0/16, 1 successors, FD is 41024000
        via 172.19.0.2 (41024000/40512000), Serial0/1
P 172.17.0.0/16, 1 successors, FD is 41024000
        via 172.18.0.1 (41024000/40512000), Serial0/0
P 172.18.0.0/16, 1 successors, FD is 40512000
        via Connected, Serial0/0
P 172.19.0.0/16, 1 successors, FD is 40512000
        via Connected, Serial0/1

Router_D#show ip route
Gateway of last resort is not set

D    172.17.0.0/16 [90/41024000] via 172.18.0.1, 00:04:40, Serial0/0
D    172.16.0.0/16 [90/41024000] via 172.19.0.2, 00:04:40, Serial0/1
C    172.19.0.0/16 is directly connected, Serial0/1
C    172.18.0.0/16 is directly connected, Serial0/0


*************************************************************************

And show the configuration below.

*************************************************************************

Router_A#show run | b int
interface Serial0/0
bandwidth 64
ip address 172.19.0.2 255.255.0.0
no fair-queue
!
interface Serial0/1
bandwidth 64
ip address 172.16.0.1 255.255.0.0
clock rate 64000
!
router eigrp 1
network 172.16.0.0
network 172.19.0.0
no auto-summary
!

Router_B#show run | b int
interface Serial0/0
bandwidth 64
ip address 172.16.0.2 255.255.0.0
no fair-queue
!
interface Serial0/1
bandwidth 64
ip address 172.17.0.1 255.255.0.0
clock rate 64000
!
router eigrp 1
network 172.16.0.0
network 172.17.0.0
no auto-summary
!

Router_C#show run | b int
interface Serial0/0
bandwidth 64
ip address 172.17.0.2 255.255.0.0
!
interface Serial0/1
bandwidth 64
ip address 172.18.0.1 255.255.0.0
clock rate 64000
!
router eigrp 1
network 172.17.0.0
network 172.18.0.0
no auto-summary
!

Router_D#show run | b int
interface Serial0/0
bandwidth 64
ip address 172.18.0.2 255.255.0.0
no fair-queue
!
interface Serial0/1
bandwidth 64
ip address 172.19.0.1 255.255.0.0
clock rate 64000
!
router eigrp 1
network 172.18.0.0
network 172.19.0.0
no  auto-summary
!

*************************************************************************

Thank you.

Regards,

Okumura

Good luck

That’s it

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Innovations in Cisco Full Stack Observability - A new webinar from Cisco