Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

How to Configure Cisco 7204 for the Internet

Dear Cisco Fans

Today we got a new cisco 7204 with NPE-G2 , so we wanna to configure to root for the internet so here is my scenerio

1- Public Ip address -- 155.155.155.20

2 Private Ip Address - 192.168.2.0 /24

3- Gateway =           155.155.155.1

4-DNS Server =          194.155.12.133

Interfaces

--------------

1- Gigabite 0/1  - We put this for Public ip address

2- Gigabite 0/2 - and this for Private Ip address

so can any one help me how to route this for the internet . after routed we want our client computers to get internet from Gigabite 0/2 Interface

thank you very Much

1 ACCEPTED SOLUTION

Accepted Solutions

Re: How to Configure Cisco 7204 for the Internet

Thomas, this router is in boot mode, its kind of a mini IOS with limited functionality...

As Rupert mentioned, you need to reload the router so that MAIN IOS can boot up, or atleast see what is happening why its not booting the main IOS file. Do change the config register value as Rupert mentioned in his post and when the router boots up completely, you should not see this (boot) in front of your prompt

8 REPLIES

How to Configure Cisco 7204 for the Internet

Try the following config, fill all the x's mentioned below:

config t

ip name-server 194.155.12.133

access-list 100 permit ip 192.168.2.0 0.0.0.255 any

int gig0/1

description ISP/Internet facing link

ip address 155.155.155.20 255.255.255.x

ip nat outside

int gig0/2

description Inside LAN

ip address 192.168.2.1 255.255.255.0

ip nat inside

ip route 0.0.0.0 0.0.0.0 155.155.155.1

ip nat inside source list 100 interface gig0/1 overload

Connect a switch to gig0/2 and then connect your clients to that switch, assign ip address to these clients and use default gateway as 192.168.2.1, configure DNS server as mentioned. Internet should work on them

Hope it helps

Neeraj

New Member

How to Configure Cisco 7204 for the Internet

thank You very much for your quick answer Narej aror

but the problem

ip route : this command is not recongised by Cisco 7204 .so what is problem please.

How to Configure Cisco 7204 for the Internet

Thomas I seriously doubt that a 7204 router does not recognise "ip route" command

I think you need to check which prompt are you typing this command...lemme give you the above config with some changes so that prompt is not an issue:

router#config t

ip routing

ip name-server 194.155.12.133

access-list 100 permit ip 192.168.2.0 0.0.0.255 any

int gig0/1

description ISP/Internet facing link

ip address 155.155.155.20 255.255.255.x

ip nat outside

no shut

exit

int gig0/2

description Inside LAN

ip address 192.168.2.1 255.255.255.0

ip nat inside

no shut

exit

ip route 0.0.0.0 0.0.0.0 155.155.155.1

ip nat inside source list 100 interface gig0/1 overload

exit

* I have added few exit & "ip routing" commands in the config, now try and see if you are able to add the ip route command. In case it still does not work, provide the snippet for that, what exact error do you get

New Member

How to Configure Cisco 7204 for the Internet

Dear Neeraj thank you very much for you respond

i try to figure out the command Ip route

missing commands

- ip route :  Not recongised command

-ip nat outside /inside : Not recogised command

we have other routers like cisco 2801 , i configured the same you gave me , they are working fine and recongised all commands you posted .

cisco(boot)config#

so i doubte (boot) what that means , is that denying this commands

thank you

Re: How to Configure Cisco 7204 for the Internet

Thomas, this router is in boot mode, its kind of a mini IOS with limited functionality...

As Rupert mentioned, you need to reload the router so that MAIN IOS can boot up, or atleast see what is happening why its not booting the main IOS file. Do change the config register value as Rupert mentioned in his post and when the router boots up completely, you should not see this (boot) in front of your prompt

New Member

Re: How to Configure Cisco 7204 for the Internet

conf t

Config-register 0x2102

Exit

Reload

Now try

Sent from Cisco Technical Support iPhone App

New Member

How to Configure Cisco 7204 for the Internet

Thank you for your help

conf t

Config-register 0x2102

Exit

Reload

has no change at all

so do i need to change the IOS image of the router

How to Configure Cisco 7204 for the Internet

when the router is booting up, do you see any error message while the IOS is decompressing?

can you paste the output of following commands:

- sh file system

- sh flash

- sh disk0

- sh run | in boot

- sh ver

- boot capture of the screen, if possible through console connection

1025
Views
0
Helpful
8
Replies
CreatePlease to create content