Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

How to configure Multilink PPP over Frame-relay?

We currently have 2 frame T1s on the host-end (Mackie) and 2 frame T1s on the remote-end (Yorkville). I am wondering how we can use MLPPP to aggregate these 2 links together to look like 1 virtual Multilink interface. I saw some info on this searching on Cisco but it talked about Policy routing and policy maps were a pre-requisite(???) It also had some virtual-templates that confused me.

Below is the config:

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname Yorkville

!

!

!

ip cef

no ip dhcp use vrf connected

!

!

no ip domain lookup

no ip ips deny-action ips-interface

!

no ftp-server write-enable

!

!

!

no crypto isakmp enable

!

!

!

!

interface GigabitEthernet0/0

ip address 10.10.10.1 255.255.255.0

ip accounting output-packets

duplex full

speed 100

!

!

interface Serial0/0/0

no ip address

encapsulation frame-relay

no fair-queue

!

interface Serial0/0/0.1 point-to-point

description Link#1 to Mackie

ip address 17.1.150.26 255.255.255.252

ip accounting output-packets

frame-relay interface-dlci 600

!

!

interface Serial0/0/2

no ip address

encapsulation frame-relay

no fair-queue

!

interface Serial0/0/2.1 point-to-point

description Link#2 to Mackie

ip address 17.1.150.50 255.255.255.252

ip accounting output-packets

frame-relay interface-dlci 602

!

!

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.10.10.2

ip route 10.2.200.0 255.255.255.0 17.1.150.25

ip route 10.2.200.0 255.255.255.0 17.1.150.49

!

!

no ip http server

no ip http secure-server

!

access-list 10 permit any log

access-list 15 permit any log

!

end

What will I need to achieve MLPPP? I accomplished this easy on some Internet P-2-P's but the DLCI portions and 'encap frame-relay' parts have me worried with this scenario.

Thanx...

7 REPLIES
Silver

Re: How to configure Multilink PPP over Frame-relay?

At this time using MLPPP to bind multiple frame-relay DLCI's isn't a supported configuration. Instead we encourage our customers to use MFR, a protocol that allows you to share a DLCI among multiple T1 lines. This protocol is negotiated between your router, and your providers frame-relay switch, so you need to ask them to configure it as well. Here is more information:

http://www.cisco.com/en/US/products/sw/iosswrel/ps1839/products_feature_guide09186a0080087cbf.html

Re: How to configure Multilink PPP over Frame-relay?

Hi Reginald,

THis is easy. You need to create virtual templates and map these to the interfaces you want to include in the Multilink. I have implemented this and works out to be fine

and Policy maps are not a prerequisite for this.

Here is a sample config..only relevant portions have been attached

interface Multilink1

ip address 17.1.150.26 255.255.255.252

keepalive 1

ppp multilink

ppp multilink group 1

interface Serial0/0/0:0

bandwidth 1536

no ip address

encapsulation frame-relay

keepalive 1

frame-relay lmi-type ansi

!

interface Serial0/0/0:0.1 point-to-point

keepalive 1

frame-relay interface-dlci 600 ppp Virtual-Template1

interface Serial0/0/2:0

bandwidth 1536

no ip address

encapsulation frame-relay

keepalive 1

frame-relay lmi-type ansi

!

interface Serial0/0/2:0.1 point-to-point

keepalive 1

frame-relay interface-dlci 600 ppp Virtual-Template2

interface Virtual-Template1

bandwidth 1536

no ip address

keepalive 1

ppp multilink

ppp multilink group 1

!

interface Virtual-Template2

bandwidth 1536

no ip address

keepalive 1

ppp multilink

ppp multilink group 1

Check this link for more details

http://www.cisco.com/en/US/products/ps6350/products_configuration_guide_chapter09186a00804a4097.html

HTH, rate if it does

Narayan

New Member

Re: How to configure Multilink PPP over Frame-relay?

Hi Narayan,

I need to configure MLPoFR and prior finding your sample config I found the same link that you attach. Related to this link, in order to configure MLPoFR it's necessary to configure Frame Relay Traffic Shaping, and in your sample config is not configured. Do you have test this configuration without Frame Relay Traffic Shaping and it works?

I had tried configuring MLPoFR without Traffiic shaping and I get this message on the router:

FR-3-MLPOFR_ERROR: MLPoFR not configured properly on Link Virtual-Access4 Bundle Multilink1 :Frame Relay traffic shaping must be enabled

Besides, I loss some pings to the other side and the speed that I get is 6M downstream 2M upstream and it should be 6M / 6M

My config:

!

interface Multilink1

ip address 10.100.100.1 255.255.255.252

no cdp enable

ppp multilink

ppp multilink fragment disable

ppp multilink group 1

!

interface Serial0/2/0

no ip address

encapsulation frame-relay IETF

frame-relay lmi-type ansi

!

interface Serial0/2/0.1 point-to-point

bandwidth 2000

frame-relay interface-dlci 100 ppp Virtual-Template1

!

interface Serial0/2/1

no ip address

encapsulation frame-relay IETF

frame-relay lmi-type ansi

!

interface Serial0/2/1.1 point-to-point

bandwidth 2000

frame-relay interface-dlci 100 ppp Virtual-Template1

!

interface Serial0/3/0

no ip address

encapsulation frame-relay IETF

frame-relay lmi-type ansi

!

interface Serial0/3/0.1 point-to-point

bandwidth 2000

frame-relay interface-dlci 100 ppp Virtual-Template1

!

interface Virtual-Template1

no ip address

load-interval 30

ppp multilink

ppp multilink group 1

Re: How to configure Multilink PPP over Frame-relay?

Hi

I have implemented this without traffic shaping and it works out fine although you keep getting the above syslog.

Also you need to mention the Bandwidth under the virtual template interface for the multilink to interpret it correctly.

Use keepalive 1 as an option as it will reduce the timeouts you encounter when one link from the bundle fluctuates.

HTH, rate if it does

Narayan

New Member

Re: How to configure Multilink PPP over Frame-relay?

Ok, I have configured with the bandwidth on the virtual template and now the bandwidth of the interface multilink is correct.

Thanks a lot for your help.

New Member

Re: How to configure Multilink PPP over Frame-relay?

Since I'm replacing 2 serial sub-interfaces, should I have 2 Virtual Templates like your example shows or only 1 Virtual Template with bandwidth at 3072?

Re: How to configure Multilink PPP over Frame-relay?

It is preferable to have 2 virtual templates with each associated to one sub interface

Narayan

1921
Views
14
Helpful
7
Replies
CreatePlease login to create content