Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

how to create WAN and VLAN

how can i ping vlan 10 and 20 to vlan 30 and 40? in which i use 2 switch n 2 router to create WAN and VLAN? when i define vlans on switch and the i go to the router so here i can't give ip address here i attach my topology picture. please help me out.

THNAKYOU

17 REPLIES
New Member

HiYour Network topology

Hi

Your Network topology requires a few correction, you cannot have the same subnet in two different VLANs on the same switch;

What is the purpose of your topology?

Is this a test scenario for you to test and learn or is this a topology you want to implement?

It would be helpful to know what is your goal so that an appropriate answer could be given.

-Balaji

New Member

no sir its just a pratice

no sir its just a pratice topology. actually i am weak in assigning ips and subnets can you please teach me about that first?

New Member

There are numerous websites

There are numerous websites that explain about VLAN, IP address and subnetting. May be the below link is a good starter for the theory;

http://www.cisco.com/web/learning/le31/le46/cln/qlm/CCNA/icnd2/understanding-vlans-and-trunks/player.html

I would suggest to listen to the audio and try to understand the VLAN and trunk and start from there.

Please let me know if you have any specific doubts / questions and I would be glad to help you.

-Balaji

New Member

ok thanku sir.

ok thanku sir.

New Member

The topology lacks

The topology lacks information to troubleshoot;

1. Where is the DHCP server configured? is it on the router? if yes, which router?

2. Did you check if the PCs have obtained IP address using DHCP or did you assign the IP address manually?

3. Is the vlan id on the ports fa0/1 and fa0/2 same?

4. Provide me the sh run of the ports fa0/1 and fa0/2 and the IPConfig /all from the PCs PC0 and PC1

 

New Member

DHCP configuration is on

DHCP configuration is on layer3 switch

yeah i was checked and DHCP is successfully implimented.

which vlan id?

ok. i am show you my configurations.

LAYER 2 CONFIGURATION:

Switch#sh run
Building configuration...

Current configuration : 1164 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/2
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/3
 switchport mode trunk
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan10
 no ip address
!
interface Vlan20
 no ip address
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
end

 

 

LAYER 3 CONFIGURATION:

Switch#sh run
Building configuration...

Current configuration : 1635 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
ip dhcp excluded-address 192.168.10.1 192.168.10.5
ip dhcp excluded-address 192.168.20.1 192.168.20.5
!
ip dhcp pool anila
 network 192.168.10.0 255.255.255.0
 default-router 192.168.10.1
ip dhcp pool anila1
 network 192.168.20.0 255.255.255.0
 default-router 192.168.20.1
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/2
 no switchport
 ip address 192.168.30.2 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan10
 ip address 192.168.10.1 255.255.255.0
!
interface Vlan20
 ip address 192.168.20.1 255.255.255.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.30.1
!
!
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
!
end

 

 

ROUTER 0 CONFIGURATION:

Router#sh run
Building configuration...

Current configuration : 784 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.30.1 255.255.255.252
 ip nat inside
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.31.1 255.255.255.252
 ip nat outside
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
ip nat pool anila 192.18.184.105 192.18.184.110 netmask 255.255.255.248
ip nat inside source list 1 pool anila overload
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.30.2
!
!
access-list 1 permit 192.168.10.0 0.0.0.255
access-list 1 permit 192.168.20.0 0.0.0.255
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
!
end

 

 

ROUTER 1 CONFIGURATION:

Router#sh run
Building configuration...

Current configuration : 542 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.31.2 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.31.1
!
!
!
no cdp run
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
!
end

 

 

 

New Member

Your Switchport trunk

Your Switchport trunk configuration is incomplete, add the following command on the trunk port;

switchport trunk allowed vlan 10, 20

Add this configuration on both the trunk ports and see how it goes

New Member

i am applying it on LAYER 2

i am applying it on LAYER 2 switch

but still not pinged
 

Its a command to trace the

Its a command to trace the route, mean a route which path select for reach-ability. your above situation show, this route is not reachable.

HTH

kazim

New Member

layer 3 and pcs are ping but

layer 3 and pcs are ping but layer 2 and pcs are not ping same as router0 and pcs are not ping

New Member

The Layer 2 switch has no IP

The Layer 2 switch has no IP address and obviously has nothing to "ping"

What exactly do you mean by "layer 2 and pcs are not ping"?

What is your "sh ip route" command output on the router0? and Layer3 switch?

 

 

New Member

oh yes sorry i was out of

oh yes sorry i was out of mind.

 

LAYER3 OUTPUT:

Layer3#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 192.168.30.1 to network 0.0.0.0

C    192.168.10.0/24 is directly connected, Vlan10
C    192.168.20.0/24 is directly connected, Vlan20
     192.168.30.0/30 is subnetted, 1 subnets
C       192.168.30.0 is directly connected, FastEthernet0/2
S*   0.0.0.0/0 [1/0] via 192.168.30.1

 

 

ROUTER0 OUTPUT:

Router0#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 192.168.30.2 to network 0.0.0.0

     192.168.30.0/30 is subnetted, 1 subnets
C       192.168.30.0 is directly connected, FastEthernet0/0
     192.168.31.0/30 is subnetted, 1 subnets
C       192.168.31.0 is directly connected, FastEthernet0/1
S*   0.0.0.0/0 [1/0] via 192.168.30.2
Router0#

New Member

Did the PCs got the IP

Did the PCs got the IP addresses? I doubt it as you dont have the DHCP helper address configured on the L2 switch.

Provide the IPConfig / all output from the PCs

 

New Member

DHCP is configured see this.

DHCP is configured see this. and sir what is this mean "DHCP helper address configured on the L2 switch"

New Member

DHCP helper address is

DHCP helper address is required when your DHCP server is in a different subnet and you want the clients to get addresses for a different subnet.

Anyways, what is the traceroute output?
 

New Member

sir i never use this command

sir i never use this command and i dn't have any idea.. what is this?

Router0#traceroute 192.168.10.1
Type escape sequence to abort.
Tracing the route to 192.168.10.1

  1   *     *     *     
  2   *     *     *     
  3   *     *     *     
  4   *     *     *     
  5   *     *     *     
  6   *     *     *     
  7   *     *     *     
  8   *     *     *     
  9   *     *     *     
  10   *     *     *     
  11   *     *     *     
  12   *     *     *     
  13   *     *     *     
  14   *     *     *     
  15   *     *     *     
  16   *     *     *     
  17   *     *     *     
  18   *     *     *     
  19   *     *     *     
  20   *     *     *     
  21   *     *     *     
  22   *     *     *     
  23   *     *     *     
  24   *     *     *     
  25   *     *     *     
  26   *     *     *     
  27   *     *     *     
  28   *     *     *     
  29   *     *     *     
  30   *     *     *    

New Member

hi sir i am creating a

hi sir i am creating a network containing vlan,dhcp,static routing. but the problem is that PC0 can't ping here i share my topology please guide me if you can thankyou.

222
Views
0
Helpful
17
Replies