Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

How to download startup configuraton from a remote server on Cisco NX-OS

I am trying to replace the startup configuration on Cisco Nexus device using a file on remote server. I tried the instructions given at this page:

http://www.cisco.com/c/en/us/td/docs/switches/datacenter/sw/4_0/nx-os/fundamentals/configuration/guide2/fun_nx-os_book/fun_config_files.html#wp1236980

So, I tried running command copy tftp://<server-ip-address>/nexus-startup.cfg startup-config and got the following error:

sysmgr_copy_nvram_dest_action: src uri_type = 2 is not supported yet

I tried to copy the file using all the four remote server protocol and got the same error with different URI type. 1 for FTP, 128 for SCP and 512 for SFTP.

The device is a Cisco Nexus 7000 series device with following details:

Software
  BIOS:      version 3.22.0
  kickstart: version 6.1(3)
  system:    version 6.1(3)

Hardware
  cisco Nexus7000 C7010 (10 Slot) Chassis ("Supervisor module-1X")
  Intel(R) Xeon(R) CPU         with 8251588 kB of memory.

 

Please let me know what am I doing wrong and how can I rectify this error.

Thanks in advance!

-Varun

Everyone's tags (1)
3 REPLIES

Hi,Can you verify if there is

Hi,

Can you verify if there is any startup config locks? If so unlock the same and the try it out.

 

The startup configuration file can be
locked by applications on the switch. To display locks on the startup
configuration file, use the following command:
switch#
show system internal sysmgr startup-config locks
To release a lock on the startup config
uration file, use the following command:
switch#
system startup-config unlock 10
New Member

The website you cited was for

The website you cited was for NXOS 4.x code. I looked up the 6.x version (see link below), and there are differences. The first step is to erase your startup config (write erase), then reload, then try the copying steps.  Or is you cannot reload your box at the moment, maybe you try downloading your remote config to a regular file on your flash, not the startup-config itself. Then somehow work from that file locally.  HTH, paul

 

http://www.cisco.com/c/en/us/td/docs/switches/datacenter/sw/6_x/nx-os/fundamentals/configuration/guide/b_Cisco_Nexus_7000_Series_NX-OS_Fundamentals_Configuration_Guide_Release_6-x/b_Cisco_Nexus_7000_Series_NX-OS_Fundamentals_Configuration_Guide_Release_6-x_chapter_01000.html#task_1236980

New Member

I know this is very old

I know this is very old thread but i ran into same issue. 

First check if startup config has any locks if so please remove it. 

N7K-1# show system internal sysmgr startup-config locks
There are no startup-config locks acquired. (No Locks)

N7K-1#system startup-config unlock (To Unlock )

Drop the configs to bootflash: or flash: and copy it over to startup config.

This works for me. Thanks 

477
Views
0
Helpful
3
Replies