Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

How to exclude certain network from propagate through EIGRP

Hi,

I wonder how to exclude certain network from propagate through EIGRP.

For example I want to exclude 210.x.x.x network from being advertise through EIGRP but I want local network behind it to be able to propagate through the same EIGRP.

Thanks.

Regards,

Fauzi Matsa

1 ACCEPTED SOLUTION

Accepted Solutions

Re: How to exclude certain network from propagate through EIGRP

Hi Fauzi,

You can configure distribute list on router A and implement it on eigrp process running on router A.

It will look something like this

access-list 1 deny 210.x.x.x 0.x.x.x

access-list 1 permit any

router eigrp

distribute-list 1 out tunnel0

Try this out and update if it helped.

HTH, if yes please rate the post.

Ankur

5 REPLIES

Re: How to exclude certain network from propagate through EIGRP

Hi Fauzi,

What I understood from your question is you have some lan interface configured on your router with some subnet address which you want your EIGRP process to advertise from your wan interface on which you have 210.x.x.x network configured.

If this is what you want I am afraid if it is possible because EIGRP will not advertise anything on the interface which is not included in its eigrp process. So if 210.x.x.x network is not included in eigrp process it will not form any neighbor on its network with its peer and it will not advertise anything out of that interface.

Have a look at this link for more details on network command in EIGRP

http://www.cisco.com/univercd/cc/td/doc/product/software/ios124/124tcr/tirp_r/rte_eiht.htm#wp1110787

HTH, if yes please rate the post.

Ankur

New Member

Re: How to exclude certain network from propagate through EIGRP

I have attach some output and diagram for the network. As you can see from the routerisp3745.txt I want to exclude the routing 210.x.x.x from being advertise by the eigrp but I want the local lan network to be advertise. File which I Attached:

1) routerisp3745.txt --- config router A

2) routerpusat.txt --- config router B

3) shiprouteA --- sh ip route router A

4) shiprouteB --- sh ip route router B

5) diagram.jpg --- simple diagram and explaination what I want to do.

As you can see from shiprouteB I want to exclude the 210.x.x.x network. How do I do that?

Thanks.

Regards,

Fauzi Matsah

Re: How to exclude certain network from propagate through EIGRP

Hi Fauzi,

You can configure distribute list on router A and implement it on eigrp process running on router A.

It will look something like this

access-list 1 deny 210.x.x.x 0.x.x.x

access-list 1 permit any

router eigrp

distribute-list 1 out tunnel0

Try this out and update if it helped.

HTH, if yes please rate the post.

Ankur

New Member

Re: How to exclude certain network from propagate through EIGRP

Hi Ankur,

Thanks. It do the trick.

Thanks again.

-fauzi matsa

Re: How to exclude certain network from propagate through EIGRP

Hello,

I am not really clear on your setup, what is the exact IP address of the interface you do not want to advertise ? Keep in mind the following: in EIGRP, you do not actually advertise networks, but rather tell the EIGRP process which interfaces you want to include in EIGRP. So if your network statement says:

network 10.0.0.0 0.0.0.255

that means that all interfaces on your router with an IP address in the 10.0.0.0/24 range will participate in EIGRP. The best way to avoid confusion abouy what is being advertised is to use statements such as:

network 218.208.68.50 0.0.0.0

which means that only the interface with that exact IP address will participate in EIGRP.

You are also redistributing static routes into EIGRP, if you do not want the 210.x.x.x network to be advertised, you can use a route map and attach that to your redistribute statement:

route-map FILTER permit 10

match ip address 1

!

route-map FILTER permit 20

!

access-list 1 deny 210.x.x.x

!

router eigrp 1

redistribute static route-map FILTER

Does that make sense ?

Regards,

GNT

2171
Views
0
Helpful
5
Replies