Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

How to force DHCP server to assign a particaulr IP address in MPLS VPN

Apprecaite if somebody can answer the following:

R1 (Multi-VRF CE)------------R2(PE)

XYZ customer

XYZ customer connects to R2 via PPPoE.

Is there a way to assign XYZ customer a partiular IP address thru DHCP. The "host" command inside the dhcp pool doesnot work for the MPLS VPN. Is there a way to achieve this. Lets say the customer require to have 192.168.16.5 to be assigned to him all the time.

Here is the relevant config.

R1 config?

ip cef

no ip dhcp use vrf connected

!

!

ip vrf XYZ

rd 1:1

route-target export 1:1

route-target import 1:1

!

vpdn enable

vpdn ip udp ignore checksum

interface Ethernet1/0

ip address dhcp

duplex full

pppoe enable group 1

pppoe-client dial-pool-number 20

interface Dialer20

mac-address 000b.b220.3750

ip vrf forwarding ABC

ip address dhcp

ip mtu 1492

encapsulation ppp

shutdown

dialer pool 20

dialer-group 20

!

router ospf 100 vrf ABC

router-id 192.168.16.5

log-adjacency-changes

capability vrf-lite

network 192.168.16.0 0.0.0.0 area 0

network 192.168.17.0 0.0.0.0 area 0

****************************

R2 config

ip dhcp pool p20

vrf XYZ

network 192.168.16.0 255.255.255.0

!

!

ip vrf XYZ

rd 1:200

route-target export 1:2

route-target import 1:2

!

ip multicast-routing

vpdn enable

vpdn ip udp ignore checksum

!

vpdn-group 1

accept-dialin

protocol pppoe

virtual-template 20

!!

interface Ethernet1/0

no ip address

ip access-group 102 in

duplex full

pppoe enable

interface Virtual-Template20

ip vrf forwarding ABC

ip address 192.168.16.1 255.255.255.0

ip mtu 1492

peer default ip address dhcp-pool p20

!

router ospf 200 vrf ABC

log-adjacency-changes

redistribute bgp 1 subnets

network 192.168.16.0 0.0.0.255 area 0

1 REPLY
New Member

Re: How to force DHCP server to assign a particaulr IP address i

If there is no other good ways to solve this problem,I suggest u to set the ip address manually on the customers pc.So the customer can always have the ip address even under the condition of DHCP.

127
Views
0
Helpful
1
Replies