Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
kmb
Community Member

How to get 3g card dial automatically on reboot

Hello,

I have a Sprint 3g HWIC and as I understand it this card must be configured in a dialer group using DDR (Dial on demand routing).

So I set the dial idle-timeout to 0, but when I reload or reboot the router, it never dials or connects until I manually ping something on the Internet.

Is there a way to get this card up every time the router boots and keep it conected 24/7?

Thanks.

chat-script cdma "" "ATDT#777"  TIMEOUT 60 "CONNECT"
!

interface Cellular0/3/0
ip address negotiated
ip virtual-reassembly
encapsulation ppp
dialer in-band
dialer idle-timeout 0
dialer string cdma
dialer-group 1
async mode interactive
ppp chap password 7

!
ip route 0.0.0.0 0.0.0.0 Cellular0/3/0
!
ip nat inside source list 1 interface Cellular0/3/0 overload
!
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 1 remark Nat Access-List
access-list 101 deny   ip any 10.0.0.0 0.255.255.255
access-list 101 deny   ip any 172.16.0.0 0.15.255.255
access-list 101 deny   ip any 192.168.0.0 0.0.255.255
access-list 101 permit ip 192.168.0.0 0.0.255.255 any
access-list 101 remark Traffic permited to cause Cellular0/3/0 to dial out.
dialer-list 1 protocol ip list 101

5 REPLIES
Hall of Fame Super Gold

Re: How to get 3g card dial automatically on reboot

Configure an NTP server, a DynDNS server or "dialer 0 permanent".

kmb
Community Member

Re: How to get 3g card dial automatically on reboot

I have DDNS setup for the Cellular0/3/0 interface, but no packets are sent to update DDNS until the Cell is up with a newly assigned IP address that then needs updating via DDNS (catch 22).

NTP is also setup (per your suggestion) but this does not seem to make it go either as NTP updates are not initiated until the interface is up.

The "permanent" keyword is not allowed after dialer idle-timeout.

Now what do I do?

:'(

Community Member

Re: How to get 3g card dial automatically on reboot

Hi Keith,

I wonder if IP SLA might help you. Have a ping going every x minutes to an external ip address and see if that will bring up your dialer.

http://www.cisco.com/en/US/docs/ios/12_4/ip_sla/configuration/guide/hsicmp.html

Kevin

kmb
Community Member

Re: How to get 3g card dial automatically on reboot

"IP SLA" is allowed with me version IOS ...but "IP SLA MONITOR" is not an option.

Good idea though.

Hall of Fame Super Gold

Re: How to get 3g card dial automatically on reboot

You have to assign a LAN source for either NTP or DDNS. Otherwise, being the interface down they will not initiate as you noticed.

Sorry the permanenet keyword, is actally applicable to static route. that could help as well

332
Views
0
Helpful
5
Replies
CreatePlease to create content