Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

How to Load Balance ADSl and E1 links

Hi,

I have a cisco 1751 with two wan cards,

One ADSL and one E1.

My normal outgoing traffic flows for the E1 link of 256 kbps, I want to route all the outgoing traffic for the ADSl link, and leave just the E1 for the incoming request to the company.

Is that possible?, I have tried OSPF, but I didnt get good results.

Somebody have an idea how I should configure my cisco to load balance the traffic.

This is the config of the cisco 1751

controller E1 1/0

framing NO-CRC4

clock source internal

channel-group 0 timeslots 1-4

!

interface ATM0/0

description atm0

mtu 1492

bandwidth 1024

no ip address

ip nat outside

no atm ilmi-keepalive

dsl operating-mode auto

interface ATM0/0.1 point-to-point

description atm0.1

bandwidth 1024

ip nat outside

pvc 8/35

pppoe-client dial-pool-number 1

!

interface FastEthernet0/0

ip address 200.x.x.x 255.255.255.240

ip nat inside

ip tcp adjust-mss 1452

speed auto

traffic-shape group 101 128000 128000 8000 4096

interface Serial1/0:0

bandwidth 256

ip address 200.52.x.x 255.255.255.252

interface Dialer1

description DSL

mtu 1492

bandwidth 1024

ip address negotiated

ip access-group 110 in

ip nat outside

encapsulation ppp

ip tcp header-compression iphc-format

no ip mroute-cache

dialer pool 1

...............

ip route 0.0.0.0 0.0.0.0 200.52.x.x

5 REPLIES

Re: How to Load Balance ADSl and E1 links

"and leave just the E1 for the incoming request to the company. " can you clear me it exactly...?

and as your post title is to loadbalancing ...but i think above statement is taking about you want to let your internal traffice travel to internet using DSL line and want your incoming traffice will come throught the E1...

you can utilise both the link for load balancing means your internet traffic will pass through both the link ...

regards

Devang

New Member

Re: How to Load Balance ADSl and E1 links

The first idea was to balance the traffic. Using both links.

But the problem I just have 256 kilobits in the E1 and in this interface I am receiving the applications traffic (SMTP, HTTP, SSL) and I have a group of dedicated IPs for those services.

In the ADSL I have 2 megabits with a dynamic IP.

That why I thought a good idea will be route all the outgoing traffic (web browse, smtp, etc) to the ADSL and just leave the E1 for the incoming traffic of the actual applications (SMTP, HTTP, SSL)

I tried to split the traffic with these lines but it didnt work

Ip route 0.0.0.0 0.0.0.0 dialer1 1

// Metric 1 for the DSL traffic

Ip route 0.0.0.0 0.0.0.0 200.52.14.x 2

// Metric 2 for the E1

I think I need to create a private network between this cisco and the PIX to be able to nat this traffic to the DSL interface.

The PIX outside interface has one of the IP address provided for the E1 interface.

Do you have a better idea?

Re: How to Load Balance ADSl and E1 links

when you are confiugre the router with the static route using different AD then router will select the best path to the destination with the better AD means lowest AD...so router will transfer allthe data to that route so here you will not have load balancing...so for that you have to go for the both the same AD...but as you said you are having 2m ADSL and 256k of E1...then at that time if you want to let more your traffic will leave your network throught the ADSL then you need to have the unequal cost path load balancing (EIGRP support the unequal cost path load balancing) means using this you can have more traffic taravel throught the ADSL and less from the E1...or you have to go for the BGP which is complex but having more future for the policy routing...

hope this explanation helps you

remeber to rate this post if it helps

regards

Devang

New Member

Re: How to Load Balance ADSl and E1 links

Devang,

Do you have an example of the configuration will work in this case?

I added this to the router.

interface serial 0.1 point-to-point

ip summary-address eigrp 100 0.0.0.0 0.0.0.0

router eigrp 1

variance 2

network 0.0.0.0

auto-summary

But I dont know what I should configure in the interfaces serial and the dialer1

What about OSPF? is that posible to use it?

Re: How to Load Balance ADSl and E1 links

you can use it but OSPF is having equal cost path load balancing...

rate this post if it helps

regards

Devang

264
Views
0
Helpful
5
Replies
CreatePlease login to create content