Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

How to Load-balance Dual-homed BGP!?

Hey everybody, this is my first post... hopefully I'm doing this properly. I have a dual-homed ISP architecture that I would like to take from active/standby to load-balanced. I'm BGP peering with both ISPs and redistributing all the routes into my OSPF core. Is there a simple way to load-balance the two ISP links in this architecture? Maybe there's a way to carry the AS path into OSPF and calculate that into the metric? Please help!

  • WAN Routing and Switching
6 REPLIES
Silver

Re: How to Load-balance Dual-homed BGP!?

You can load-sharing it by simply to implement equal cost load-sharing (if it is same ISP).

Or try to load-sharing it by selected routes for specific path.

or just based on the routes learned from both ISP and the traffic flow to shortest path (if it is two ISPs).

If it is same ISP but dual links, check will it able to enable Multilink PPP to make two interfaces as logically grouped as a single link.

Hope this helps.

Re: How to Load-balance Dual-homed BGP!?

Can you please let me know whether you are dual homed to 2 different ISPs or a sigle ISP

What are the prefixes you are receiving from your ISP BGP peers?

Narayan

Re: How to Load-balance Dual-homed BGP!?

Hello,

you also might want to have a look at the following document, which has numerous sample configurations for BGP load balancing scenarios:

Load Sharing with BGP in Single and Multihomed Environments: Sample Configurations

http://www.cisco.com/warp/public/459/40.html

Regards,

GNT

New Member

Re: How to Load-balance Dual-homed BGP!?

Hello, I followed this documentation from cisco site. But me did not work. follows the topology and configuration attached below.

RouterA
!
interface FastEthernet0/0
ip address 10.10.10.1 255.0.0.0
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 20.20.20.1 255.0.0.0
duplex auto
speed auto
!
interface FastEthernet2/0
ip address 1.0.0.1 255.0.0.0
duplex auto
speed auto
!
interface FastEthernet2/1
ip address 2.0.0.1 255.0.0.0
duplex auto
speed auto
!
router bgp 300
no synchronization
no bgp log-neighbor-changes
network 1.0.0.0
network 2.0.0.0
neighbor 10.10.10.10 remote-as 100
neighbor 10.10.10.10 route-map UPDATES-1 in
neighbor 20.20.20.20 remote-as 200
neighbor 20.20.20.20 route-map UPDATES-2 in
no auto-summary
!  
access-list 1 permit 0.0.0.0
access-list 2 deny   0.0.0.0
access-list 2 permit any
!        
route-map UPDATES-2 permit 10
match ip address 1
!        
route-map UPDATES-2 permit 20
match ip address 2
set weight 100
!        
route-map UPDATES-1 permit 10
match ip address 1
set weight 100
!        
route-map UPDATES-1 permit 20
match ip address 2

Router SP-A
!
interface FastEthernet0/0
ip address 10.10.10.10 255.0.0.0
duplex auto
speed auto
!
router bgp 100
no synchronization
no bgp log-neighbor-changes
neighbor 10.10.10.1 remote-as 300
neighbor 10.10.10.1 default-originate
neighbor 10.10.10.1 soft-reconfiguration inbound
no auto-summary
!
Router SP-B
!
interface FastEthernet0/0
ip address 20.20.20.20 255.0.0.0
duplex auto
speed auto
!
!        
router bgp 200
no synchronization
no bgp log-neighbor-changes
neighbor 20.20.20.1 remote-as 300
neighbor 20.20.20.1 default-originate
neighbor 20.20.20.1 soft-reconfiguration inbound
no auto-summary
!


In the example of the site said to use an access-list to match traffic from 128.0.0.0 1.0.0.0 until I changed the access-list to get the default (0.0.0.0) and enter the command "
neighbor ip default-originate" even so not working. Does anyone have any idea where I'm wrong?

Regards.

Blue

Re: How to Load-balance Dual-homed BGP!?

I hate to do this to you, but why dont you give this a read and see if it helps you.

http://www.cisco.com/en/US/tech/tk365/technologies_configuration_example09186a00800945bf.shtml#conf4


HTH

Victor

New Member

Re: How to Load-balance Dual-homed BGP!?

hello lamav this was precisely what documentation of the Cisco I read. If you look at the settings are identical to the example.

Regards.

3261
Views
0
Helpful
6
Replies