Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

How to Load Balance Etherchannel, when things are static?

Folks:

This is a simple config, I have a VMWare ESX3.5 server that accesses an iSCSI storage system across a Cisco 3650 switch, On the ESX3.5 server side, there are 3 NIC's dedicated to the VMSwitch that the VMKernal accesses the iSCSI Luns. The iSCSI lun's are presented from a device with teamed NIC's that present 1 “virtual” NIC to the Cisco switch. I would like the ESX3.5 server to use each of the 3 NIC's available.

Now the rub is both the src/dest MAC's are always the same, as well as the source/dest IP addresses. Meaning the VMKernal IP address 192.168.4.14/MAC abcd.abcd.abcd.0001 will always talk to iSCSI storage server at 192.168.4.10/MAC abcd.abcd.abcd.0002. From my observations and “test etherchannel load-balance” there is only 1 NIC used to transfer data no matter what load-balance hash I use (the below is when I test XOR/IP hash.

How can I get the load to be round-robin to the three available NIC's.

Here's the appropriate Cisco config portion:

port-channel load-balance src-dst-ip

!

interface Port-channel1

description iSCSI ESX Access

switchport trunk encapsulation dot1q

switchport mode trunk

switchport nonegotiate

interface GigabitEthernet0/30

description ESX iSCSI NIC

switchport trunk encapsulation dot1q

switchport mode trunk

switchport nonegotiate

duplex full

channel-group 1 mode on

spanning-tree portfast

!

interface GigabitEthernet0/31

description ESX iSCSI NIC

switchport trunk encapsulation dot1q

switchport mode trunk

switchport nonegotiate

duplex full

channel-group 1 mode on

spanning-tree portfast

!

interface GigabitEthernet0/32

description ESX iSCSI NIC

switchport trunk encapsulation dot1q

switchport mode trunk

switchport nonegotiate

duplex full

channel-group 1 mode on

spanning-tree portfast

S1#$hannel load-balance interface p01 ip 192.168.4.10 192.168.4.14

Would select Gi0/31 of Po1

S1#$hannel load-balance interface p01 ip 192.168.4.14 192.168.4.10

Would select Gi0/31 of Po1

4 REPLIES
Hall of Fame Super Silver

Re: How to Load Balance Etherchannel, when things are static?

Hello,

on some switching platforms you can use the L4 ports to perform the exor

see the following:

Switch(config)#port-channel load-balance ?

dst-ip Dst IP Addr

dst-mac Dst Mac Addr

dst-mixed-ip-port Dst IP Addr and TCP/UDP Port

dst-port Dst TCP/UDP Port

mpls Load Balancing for MPLS packets

src-dst-ip Src XOR Dst IP Addr

src-dst-mac Src XOR Dst Mac Addr

src-dst-mixed-ip-port Src XOR Dst IP Addr and TCP/UDP Port

src-dst-port Src XOR Dst TCP/UDP Port

src-ip Src IP Addr

src-mac Src Mac Addr

src-mixed-ip-port Src IP Addr and TCP/UDP Port

src-port Src TCP/UDP Port

not all options are avaible on all platforms try to see if your switch supports src-dst-port

hope to help

Giuseppe

Community Member

Re: How to Load Balance Etherchannel, when things are static?

Giuseppe:

Thanks for responding! The Cisco IOS Software, C3560 Software (C3560-IPBASE-M), Version 12.2(25)SEE2 IOS/load-balance options for the 3650 doesn't have "port" hash options, just these:

dst-ip Dst IP Addr

dst-mac Dst Mac Addr

src-dst-ip Src XOR Dst IP Addr

src-dst-mac Src XOR Dst Mac Addr

src-ip Src IP Addr

src-mac Src Mac Addr

I'm thinking that I need to provide more variability to the source or destination. I'm looking to see if I can bind additional IP's to the iSCSI NAS appliance and serve some lun's from unique IP addresses.

Hall of Fame Super Silver

Re: How to Load Balance Etherchannel, when things are static?

Hello,

I was afraid the C3560 doesn't support the port options.

If you can make your traffic more variable you an achieve some load sharing effect

Best Regards

Giuseppe

Community Member

Re: How to Load Balance Etherchannel, when things are static?

Guiseppe:

I agree, I'll see if I can do this by adding some Nic's/IP's to the NAS device.

Mark M.

604
Views
0
Helpful
4
Replies
CreatePlease to create content