Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

how to reach 2 wan nodes that has LANs with same network ID

hi mates :)

pls see the attached figure i draw for you shows my network.

- Location A and Location B is working OSPF right now without any problems.

- we want to add a new WAN node(C) but they want computers to have the same network ID on two WAN nodes (B and C)

- is it possible to reach from A to B and C ?

- how can i achieve that? what kind of configuration should i do in order to reach two.

- would static routing between A and C solve the problem? (we can not change OSPF between A and B)

-or is it impossible to reach from A to B and C as long as B and C LANs have same network ID?

i'll appreciate all your help,

ty in advance for helping :)

6 REPLIES
Hall of Fame Super Silver

Re: how to reach 2 wan nodes that has LANs with same network ID

Hello Ohal,

the new location should use a different IP subnet.

the design should be reviewed because it is insane.

otherwise you should use NAT or some L2 transport tecnique like L2TPv3 but:

these have requirements on device types:

NAT can be done only on SW based routers or C6500 with sup720.

L2TPv3 can only be done on sw based routers.

But all this has complexity and performance penalties.

if this is a new site it is better to use a different IP subnet.

for L2TPv3 see

http://www.cisco.com/en/US/docs/ios/12_3t/12_3t2/feature/guide/gtl2tpv3.html

vlan based L2TPv3

for NAT: you need to assign two IP subnets to represent the common subnet in the different sites

siteC should see net 192.168.5.0/24 as equivalent to 192.168.10.0/24.

first site should use something like 192.168.7.0/24 when attempting to access other site's ip address.

Each router should nat its own block

ip nat pool mypool 192.168.5.2 19.168.5.254 netmask 255.255.255.0

access-list 10 permit 192.168.10.0 0.0.0.255

int loop5

ip address 192.168.5.1 255.255.255.0

int lan 0

ip nat inside

int wan0

ip nat outside

ip nat inside source list 10 pool mypool

router ospf xx

network 192.168.5.0 0.0.0.255 area YY

something similar should be done in other site

hope to help

Giuseppe

Community Member

Re: how to reach 2 wan nodes that has LANs with same network ID

ty for your fast response but i am not sure if that solves my issue.

lets say

there is a pc with 192.168.10.1 on location B

and

there is a pc with 192.168.10.2 on location C,

how can router 2 understand which IP belongs to B, which IP belongs to C and send the packet accordingly ?

Community Member

Re: how to reach 2 wan nodes that has LANs with same network ID

can can make clear the ip scheme on your serial interface,

Community Member

Re: how to reach 2 wan nodes that has LANs with same network ID

hi sohailian,

i've updated drawing and add serial interface IP Address block.

ty for trying to help

Community Member

Re: how to reach 2 wan nodes that has LANs with same network ID

Hi Ohalnet

Can u further tell that u specify only 1, 2 and3 etc on serial interface, is it in the same network that u assign on LAN like ip address for location A serial interface will be 192.168.20.1 or is it another network ID, i need the class or full address that you used or if it is public addressa nd you can not specify over here then just tell me that it is not the same class as on LAN and it is related to another class then it will be easy for me to completely do the full lab and will tell you the result.

Regards

Community Member

Re: how to reach 2 wan nodes that has LANs with same network ID

Hi,why are we doing this ?

Obviously , Routing loops Will be generated in that network ..I think I can not help you anything about arouse the dead scheme ,I just suggest you avoid this thinking ...

hope this helps ..

Long Fan

187
Views
5
Helpful
6
Replies
CreatePlease to create content