Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

How to remove subnetted route on Catalyst 3560

Hello Community,

I have been researching a way to remove this subnetted route from my L3.

There is an extra subnetted route that should not be there when I execute the command: show ip route

Below if part of my Show Run and the Show IP Route commands. You will see the 10.0.0.0/24 subnet as subnetted. I dont know why the L3 uses the 10.0.0.0/24 when I enter 10.10.10.0/24? But thats a whole different questions.

Thanks Community and sorry if I ask so many questions! I am new and getting the hang of the cisco world b/c of all of you!!!!

John

interface Vlan1

no ip address

shutdown

!

interface Vlan2

ip address 10.10.10.1 255.255.255.0

!

interface Vlan3

ip address 192.168.202.1 255.255.255.0

!

interface Vlan4

ip address 192.168.200.1 255.255.255.0

!

interface Vlan5

ip address 192.168.210.1 255.255.255.0

!

router rip

version 2

redistribute static metric 1

network 10.0.0.0

network 192.168.200.0

network 192.168.202.0

network 192.168.210.0

network 192.168.220.0

no auto-summary

!

ip classless

ip route 10.10.10.0 255.255.255.0 10.10.10.222

ip route 192.168.3.0 255.255.255.0 192.168.200.254

ip route 192.168.5.0 255.255.255.0 192.168.200.254

ip route 192.168.98.0 255.255.255.0 192.168.200.254

ip route 192.168.102.0 255.255.255.0 192.168.200.254

ip route 192.168.103.0 255.255.255.0 192.168.200.254

ip route 192.168.104.0 255.255.255.0 192.168.200.254

ip route 192.168.105.0 255.255.255.0 192.168.200.254

ip route 192.168.110.0 255.255.255.0 192.168.200.254

ip route 192.168.111.0 255.255.255.0 192.168.200.254

ip route 192.168.112.0 255.255.255.0 192.168.200.254

ip route 192.168.113.0 255.255.255.0 192.168.200.254

ip route 192.168.150.0 255.255.255.0 192.168.200.254

ip route 192.168.151.0 255.255.255.0 192.168.200.254

ip route 192.168.154.0 255.255.255.0 192.168.200.254

ip route 192.168.155.0 255.255.255.0 192.168.200.254

ip route 192.168.200.0 255.255.255.0 192.168.200.254

ip route 192.168.202.0 255.255.255.0 192.168.202.222

ip route 192.168.214.0 255.255.255.0 192.168.200.254

ip route 192.168.220.0 255.255.255.0 192.168.210.222

ip http server

!

snmp-server community public RO

!

control-plane

!

!

line con 0

line vty 0 4

password T3m5xlD2D62

login

line vty 5 15

password T3m5xlD2D62

login

!

end

arouter#sh ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

S    192.168.104.0/24 [1/0] via 192.168.200.254

S    192.168.151.0/24 [1/0] via 192.168.200.254

S    192.168.105.0/24 [1/0] via 192.168.200.254

C    192.168.210.0/24 is directly connected, Vlan5

S    192.168.150.0/24 [1/0] via 192.168.200.254

S    192.168.110.0/24 [1/0] via 192.168.200.254

S    192.168.111.0/24 [1/0] via 192.168.200.254

S    192.168.214.0/24 [1/0] via 192.168.200.254

C    192.168.200.0/24 is directly connected, Vlan4

S    192.168.98.0/24 [1/0] via 192.168.200.254

S    192.168.5.0/24 [1/0] via 192.168.200.254

C    192.168.202.0/24 is directly connected, Vlan3

     10.0.0.0/24 is subnetted, 1 subnets

C       10.10.10.0 is directly connected, Vlan2

S    192.168.113.0/24 [1/0] via 192.168.200.254

S    192.168.112.0/24 [1/0] via 192.168.200.254

S    192.168.102.0/24 [1/0] via 192.168.200.254

S    192.168.220.0/24 [1/0] via 192.168.210.222

S    192.168.103.0/24 [1/0] via 192.168.200.254

S    192.168.155.0/24 [1/0] via 192.168.200.254

S    192.168.154.0/24 [1/0] via 192.168.200.254

S    192.168.3.0/24 [1/0] via 192.168.200.254

5 REPLIES
Purple

How to remove subnetted route on Catalyst 3560

Hi John,

this is normal. the 10 network is a class A(/8) private IP address but you gave it a /24 mask so it is subnetted.

Regards.

Alain

Don't forget to rate helpful posts.

How to remove subnetted route on Catalyst 3560

just to add to what Alain said, in other words, the "sh ip route" output means that 10.0.0.0/8 was subnettet into /24 subnets  and then shows exactly  /24's which are known.

I suppose It's for  "backwards" compatibility  with a class-full routing (which nowdays shoudn't be used anymore).

New Member

How to remove subnetted route on Catalyst 3560

How can I remove that extra subnetted route?

I tried using the command, but was unsuccessful: no ip route 10.0.0.0/24

Re: How to remove subnetted route on Catalyst 3560

you can't remove it, and its not a "extra subnetted route". As I said it's just an information. if you put some additional subnets in 10.0.0.0, they will be all showed after line "  10.0.0.0/24 is subnetted, 1 subnets" in "sh ip route".

update: do you aware about what  "no ip route 10.0.0.0/24" command  exactly does?

Purple

How to remove subnetted route on Catalyst 3560

Hi,

As Konstantin said you can't remove it , it is a connected route. if you really want not to see it anymore then use a /8 instead.

ip route is for configuring a static route so it has nothing to do with connected routes and you have to specify the subnet mask not the prefix-length.

Regards.

Alain

Don't forget to rate helpful posts.
1008
Views
0
Helpful
5
Replies
CreatePlease to create content