Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

How to set the config-register on a 2960

I have tried the config-register command and it is not available. Here is part of the show ver command. I want to change the config-reg from 0xF to 0x2102.

I have run into this before but don't remember how to correct it.....I think I have to use the boot command but not sure. Here it the output

show ver

Cisco IOS Software, C2960 Software (C2960-LANBASE-M), Version 12.2(25)FX, RELEASE SOFTWARE (fc1)

ROM: Bootstrap program is C2960 boot loader

BOOTLDR: C2960 Boot Loader (C2960-HBOOT-M) Version 12.2(25r)FX, RELEASE SOFTWARE (fc4)

System returned to ROM by power-on

System image file is "flash:c2960-lanbase-mz.122-25.FX/c2960-lanbase-mz.122-25.FX.bin"

cisco WS-C2960-24TT-L (PowerPC405) processor (revision A0) with 61440K/4088K bytes of memory.

Last reset from power-on

4 Virtual Ethernet interfaces

24 FastEthernet interfaces

2 Gigabit Ethernet interfaces

The password-recovery mechanism is enabled.

64K bytes of flash-simulated non-volatile configuration memory.

Model number : WS-C2960-24TT-L

Switch Ports Model SW Version SW Image

------ ----- ----- ---------- ----------

* 1 26 WS-C2960-24TT-L 12.2(25)FX C2960-LANBASE-M

Configuration register is 0xF

Thank you

7 REPLIES

Re: How to set the config-register on a 2960

try with "confreg" command and see if it works for you.

Re: How to set the config-register on a 2960

I tried that in global config mode and it does not work.....

Mike

New Member

Re: How to set the config-register on a 2960

hi

Just off your switch and press the mode button

while pressing mode button start the switch again and keep your finger pressed on mode Button ( Mode button is present in front At Left Hand )

Now release the Mode button after 15 to 30 seconds

Now follow the below lines

If the password-recovery mechanism is enabled, this message appears:

The system has been interrupted prior to initializing the flash file system. The following

commands will initialize the flash file system, and finish loading the operating system

software:

flash_init

load_helper

boot

Step 1 Initialize the flash file system:

switch: flash_init

Step 2 If you had set the console port speed to anything other than 9600, it has been reset to that particular speed. Change the emulation software line speed to match that of the switch console port.

Step 3 Load any helper files:

switch: load_helper

Step 4 Display the contents of flash memory:

switch: dir flash:

The switch file system appears:

Directory of flash:

13 drwx 192 Mar 01 1993 22:30:48 c2960-lanbase-mz.122-25.FX

11 -rwx 5825 Mar 01 1993 22:31:59 config.text

18 -rwx 720 Mar 01 1993 02:21:30 vlan.dat

16128000 bytes total (10003456 bytes free)

Step 5 Rename the configuration file to config.text.old.

This file contains the password definition.

switch: rename flash:config.text flash:config.text.old

Step 6 Boot the system:

switch: boot

You are prompted to start the setup program. Enter N at the prompt:

Continue with the configuration dialog? [yes/no]: N

Step 7 At the switch prompt, enter privileged EXEC mode:

Switch> enable

Step 8 Rename the configuration file to its original name:

Switch# rename flash:config.text.old flash:config.text

now I hope you will done with it

If my post helps you then please do rate it

For full details follow this link

http://www.cisco.com/en/US/products/ps6406/products_configuration_guide_chapter09186a0080511fe2.html#wp1021182

And for password recovery section

http://www.cisco.com/en/US/products/ps6406/products_configuration_guide_chapter09186a0080511fe2.html#wp1090048

Take Care

Re: How to set the config-register on a 2960

I did know about that way. I was trying to change it with out having to take the switch offline.

Thanks,

Mike

New Member

Re: How to set the config-register on a 2960

Hi

Switches and router's password recovery function is different and so its not possible to change config register value in global mode of switch because switch doesn't support it. The thing you can change the password or Config register value is to rename the flash:config.text file with flash:config.old file so your switch will start work in 0x2102

HTH

New Member

Re: How to set the config-register on a 2960

didn't find the info on the web, or docs, but here is the solution if someone else is looking for; too intiutive for cisco tho ;-).

NPM6SWITCH#config t
Enter configuration commands, one per line.  End with CNTL/Z.
NPM6SWITCH(config)#line con 0
NPM6SWITCH(config-line)#speed 115200
NPM6SWITCH(config-line)#end
NPM6SWITCH#

Para restablecer la velocidad

Listo:

Despues de unas 4 horas de investigacion ya esta solucionado:

El proceso es estricto, y debe seguirse en ese orden sino no funciona

 

http://www.cisco.com/c/en/us/support/docs/switches/catalyst-2950-series-switches/12040-pswdrec-2900xl.html

 

POR FIN!!!

 

 

ANTIGUO!!!!

Tampoco funciona regresarlo a la configuracion express por defecto, asi que no hay solucion hasta el momento

!!!!!!!!!!!!!!!!!!!

ANTIGUO!!!!

El mejor procedimiento es regresarlo a la configuracion express por defecto

 

He probado con esto y al parecer el registro persiste con esta configuracion!!

 

 

Estamos en el caso de que el switch esta trabajando a 115200 y lo queremos pasar a 9600

=======================================================================

Nos conectamos al switch por consola con la velocidad de 115200

Desde consola borramos el archivo de configuracion del switch

switch#erase startup-config

confirmamos!!!

Para restablecer la velocidad de la conexion de consola a 9600

==================================================

Abrir una ventana de terminal configurado a 9600

Apagar el switch y desenchufarlo

Presionar el boton mode y sin soltarlo enchufar el switch

Esperar a que el led SYST cambie a ambar

Nos fijamos que en el prompt del terminal de consola aparecera:

switch: 

Ahi escribimos:

set BAUD 9600

luego escribimos:

boot

 

14351
Views
14
Helpful
7
Replies
CreatePlease login to create content