Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

how to verify load balancing

Hello, I've set a static mapping between 2 routers connected each other by 2 serial link.

Everything seems to work well, but how can I verify if they are load balancing traffic among the 2 serial links?

Regards

10 REPLIES
Purple

Re: how to verify load balancing

Hi,

Well, if you do a 'sh interface', you should see traffic flowing over both links. That will indicate that load-sharing is happening.

Also, the output of 'sh ip cef' will show that you have routes with multiple next-hops.

Paresh

New Member

Re: how to verify load balancing

Thanks for the quick answer.

It seems like thay are not load balancing.

Do the serial link need to have the same encapsulation?

Purple

Re: how to verify load balancing

Not at all - they can be heterogenous.

Would you be able to post the output of 'sh ip route' so that we can see what is happening ?

Paresh

New Member

Re: how to verify load balancing

Sure, on r1 this is the routing table:

1.0.0.0/32 is subnetted, 1 subnets

C 1.1.1.1 is directly connected, Loopback0

50.0.0.0/24 is subnetted, 1 subnets

S 50.0.0.0 [1/0] via 147.200.200.2

[1/0] via 148.200.200.2

147.200.0.0/24 is subnetted, 1 subnets

C 147.200.200.0 is directly connected, Serial0

148.200.0.0/24 is subnetted, 1 subnets

C 148.200.200.0 is directly connected, Serial1

C 192.168.1.0/24 is directly connected, Ethernet0

S* 0.0.0.0/0 [1/0] via 192.168.1.1, Ethernet0

where on r2 I've got:

50.0.0.0/24 is subnetted, 1 subnets

C 50.0.0.0 is directly connected, Loopback1

147.200.0.0/24 is subnetted, 1 subnets

C 147.200.200.0 is directly connected, Serial0

148.200.0.0/24 is subnetted, 1 subnets

C 148.200.200.0 is directly connected, Serial3

S 192.168.1.0/24 [1/0] via 147.200.200.1

[1/0] via 148.200.200.1

################################################

Pinging from r2 to 192.168.1.200 (ethernet 0 on r1) works fine

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Pinging from r1 to 50.0.0.1 (loopback int on r2) I get:

!U!.!U!.!U!.!U!.!U!.!U!.!U!.!U

Purple

Re: how to verify load balancing

Can you try the following from R1:

ping 147.200.200.2

and

ping 148.200.200.2

On another note, unless you have enabled per-packet load-sharing, you will not get any load-sharing when you are sending a single stream of packets to a single IP address on the other side. The load-sharing is per-destination by default.

One other thing you might want to ensure is that you have configured the 'ip cef' command on both routers.

I would appreciate you rating posts that you find helpful.

Paresh

New Member

Re: how to verify load balancing

R1#ping 147.200.200.2

!!!!!

R1#ping 148.200.200.2

!!!!!

I've enable ip cef on both sides adding the

ip load-share per-packet

on all 4 interfaces.

Now r2 to r1 communication still successful, where

the ping from r1 to r2 (loopback int) becomed:

r1#ping 50.0.0.1

....................

New Member

Re: how to verify load balancing

1. Check whether you have configured per packet load balancing. (ip load-sharing per-packet)

2. Check whether cef is enabled ( show cef interface command)

3. if possible, paste the static routes pointed to both the interfaces.

New Member

Re: how to verify load balancing

As you can see ip load-aharing per-packet has been enabled an all the interfaces. You can;t see from this post, but also ip cef is properly set.

R1:

interface Serial0

bandwidth 64

ip address 147.200.200.1 255.255.255.0

ip load-sharing per-packet

encapsulation frame-relay

no arp frame-relay

frame-relay map ip 147.200.200.2 501 broadcast

frame-relay map ip 147.200.200.3 502 broadcast

no frame-relay inverse-arp

!

interface Serial1

bandwidth 64

ip address 148.200.200.1 255.255.255.0

ip load-sharing per-packet

encapsulation ppp

clock rate 64000

!

ip default-gateway 192.168.1.1

no ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 Ethernet0 192.168.1.1 permanent

ip route 50.0.0.0 255.255.255.0 148.200.200.2

ip route 50.0.0.0 255.255.255.0 147.200.200.2

###################################################

R2:

interface Serial0

bandwidth 64

ip address 147.200.200.3 255.255.255.0

ip load-sharing per-packet

encapsulation frame-relay

fair-queue

no arp frame-relay

frame-relay map ip 147.200.200.1 205 broadcast

no frame-relay inverse-arp

!

interface Serial1

bandwidth 64

ip address 148.200.200.2 255.255.255.0

ip load-sharing per-packet

encapsulation ppp

!

ip classless

ip route 192.168.1.0 255.255.255.0 148.200.200.1

ip route 192.168.1.0 255.255.255.0 147.200.200.1

####################################################

From my prev post (see above), I also don't unserstand why r2 has got this entry in the routing table:

C 148.200.200.1/32 is directly connected, Serial3

Hall of Fame Super Silver

Re: how to verify load balancing

Stefano

The last part of your question is easy to answer: r2 has the entry for 148.200.200.1/32 because the serial interface is using ppp and the ppp negotiation puts that route into the routing table.

I note that the routing table shows it as interface serial3 where the config you posted shows it as serial1. Would I assume that you have changed some parts of the config to prepare them for posting to the forum?

I am also a little uncertain about the routing logic that you are implementing. r1 is only routing network 50.0.0.0 on the two linnks? and r2 is only routing 192.168.1.0 on the two links?

Also I think there is some inconsistency in the way that you have your network set up. On r1 you have this static route:

ip route 50.0.0.0 255.255.255.0 147.200.200.2

the next hop address relates to this frame relay map:

frame-relay map ip 147.200.200.2 501 broadcast

which I would assume should be r2. However on r2 the frame relay serial interface has this:

ip address 147.200.200.3 255.255.255.0

but the .3 address should be r3 not r2.

That inconsistency would explain some of the connectivity problems in your earlier posts like this:

Pinging from r1 to 50.0.0.1 (loopback int on r2) I get:

!U!.!U!.!U!.!U!.!U!.!U!.!U!.!U

HTH

Rick

New Member

Re: how to verify load balancing

Rick, you're right, I've manually modified the serial number before the post just to simplify.

Thanks for the PPP clarification, I was not aware of it.

About the static routing on r1 an r2, spot on.

What I want to do is load-share a connection between 2 routers using 2 connections and only static routes.

On r1 I'm using an Ethernet connection, where on r2 just a loopback interface.

About the frame-relay map thing...

Basically one link connects with a back to back cable the 2 router directly (ppp), where the other link passes through a frame-relay switch.

The interface on r1 is a multipoint, and you're right, working on the frame-relay map I get some results.

I've now removed the map to 147.200.200.2 and now I get a "better" result, but still not perfect

r1#ping 50.0.0.1

.!!!.!!!.!!!.!!!.!!!

Not perfect, but I'm getting there :-)

Bottom line, I get your point, as you must have picked up by now, this is a test lab, and jumping between configs/scenarios I often forget to remove completely the old (unwanted) config.

I will pay more attentions to this in the future.

523
Views
7
Helpful
10
Replies
CreatePlease login to create content